Subject: git-import-orig: add a suffix like ~dfsg to the upstream version if the filter option is used?

From: Charles Plessy <[email-masked]>
Date: Mon, 14 Sep 2009 21:36:43 +0900

Package: git-buildpackage
Version: 0.4.57
Severity: wishlist

Dear Guido,

many thanks for writing git-buildpackage. I was told about the filter
options of git-import-orig, and this will for sure make me a loyal
user :)

I was just wondering if you could add version renaming capacities to
the system: when filtering to remove non-DFSG-free files, I prefer to
change the upstream version number by adding ~dfsg to clearly indicate
that it is not really original. It would be really great if
git-import-orig could do it for me!

Have a nice day,

-- Charles Plessy, Debian Med packaging team, Tsurumi, Kanagawa, Japan.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages git-buildpackage depends on:
ii  devscripts                   2.10.55     scripts to make the life of a Debi
ii  git-core                     1:1.6.3.3-2 fast, scalable, distributed revisi
ii  python                       2.5.4-2     An interactive high-level object-o
ii  python-dateutil              1.4.1-3     powerful extensions to the standar
ii  python-support               1.0.3       automated rebuilding support for P

Versions of packages git-buildpackage recommends:
ii  pristine-tar                  1.00       regenerate pristine tarballs

Versions of packages git-buildpackage suggests:
pn  git-load-dirs                 <none>     (no description available)

-- no debconf information

---

From: Guido Günther <[email-masked]>
Date: Sun, 25 Oct 2009 13:32:36 +0100

> git-import-orig could do it for me!
Makes sense. As a workaround you can use --upstream-version to specify
a dfsg version.
 -- Guido