Subject: Re: c/3481: function attributes should apply to function pointers too

From: [email-masked]
Date: 29 Jun 2001 17:36:01 -0000

Thank you very much for your problem report.
It has the internal identification `c/3481'.
The individual assigned to look at your
report is: unassigned. 

>Category:       c
>Responsible:    unassigned
>Synopsis:       function attributes should apply to function pointers too
>Arrival-Date:   Fri Jun 29 10:36:01 PDT 2001

---

From: [email-masked]
Date: 5 Oct 2001 18:39:09 -0000

State-Changed-From-To: open->analyzed
State-Changed-By: jsm28
State-Changed-When: Fri Oct  5 11:39:08 2001
State-Changed-Why:
    Format attributes now (mainline) apply properly to function types,
    using the documented syntax.  Noreturn attributes work
    in the case given, but not yet in general on types, only
    on declarations of functions or pointers to functions;
    and there are other function attributes that ought
    to apply to types but currently only apply to decls.

http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view&pr=3481&database=gcc