Subject: Bug#560827: alsa-utils: "aconnect -d" on Midi Through ports uninterruptible

From: Paul Brossier <[email-masked]>
Date: Sat, 12 Dec 2009 16:43:39 +0100

Package: alsa-utils
Version: 1.0.21-1
Severity: important

Hi,

$ aconnect -li 
client 0: 'System' [type=kernel]
    0 'Timer           '
    1 'Announce        '
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
$ aconnect -lo
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
$ aconnect 14:0 14:0

$ aconnect -d 14:0 14:0

the last line never returns. the process is marked 'D Uninterruptible sleep
(usually IO)', and there is indeed no way to kill it or put it to sleep.

cheers, piem

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.31-1-686 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages alsa-utils depends on:
ii  dialog                    1.1-20080819-1 Displays user-friendly dialog boxe
ii  libasound2                1.0.21a-1      shared library for ALSA applicatio
ii  libc6                     2.10.2-2       GNU C Library: Shared libraries
ii  libncursesw5              5.7+20090803-2 shared libraries for terminal hand
ii  linux-sound-base          1.0.21+dfsg-2  base package for ALSA and OSS soun
ii  lsb-base                  3.2-23         Linux Standard Base 3.2 init scrip
ii  module-init-tools         3.11-1         tools for managing Linux kernel mo
ii  udev                      149-1          /dev/ and hotplug management daemo
ii  whiptail                  0.52.10-4.1    Displays user-friendly dialog boxe

Versions of packages alsa-utils recommends:
ii  alsa-base                  1.0.21+dfsg-2 ALSA driver configuration files
ii  pciutils                   1:3.1.4-4     Linux PCI Utilities

alsa-utils suggests no packages.

-- no debconf information

---

From: Elimar Riesebieter <[email-masked]>
Date: Sat, 12 Dec 2009 20:32:25 +0100

* Paul Brossier [091212 16:43 +0100]
> (usually IO)', and there is indeed no way to kill it or put it to sleep.

Maybe this is because you tried to oonnect 14:0 with itself?

Elimar

-- 
  We all know Linux is great... it does infinite loops in 5 seconds.
        -- Linus Torvalds

---

From: Paul Brossier <[email-masked]>
Date: Sun, 13 Dec 2009 19:53:52 +0100

> Maybe this is because you tried to oonnect 14:0 with itself?

hi,

maybe but if that's not supposed to work, the connection should not even
be made in the first place, and aconnect 14:0 14:0 should return an error.

cheers, piem

---

From: Elimar Riesebieter <[email-masked]>
Date: Sun, 17 Jan 2010 19:42:49 +0100

severity 560827 normal
thanks

* Paul Brossier [091213 19:53 +0100]
> maybe but if that's not supposed to work, 

so reduced severity

> the connection should not even

Please forward this bug upstream and let us know when you got a fix.

Elimar

-- 
  Experience is something you don't get until 
  just after you need it!