Subject: Bug#564827: aplay -Djack fails with "Sample rate non available"

From: Jonathan Nieder <[email-masked]>
Date: Mon, 11 Jan 2010 22:18:29 -0600

Package: alsa-utils
Version: 1.0.16-2

Hi,

Stock lenny system.  When jackd is running (with
“jackd -d alsa -d hw:0 -r 44100”), programs cannot talk to ALSA
(device or resource busy).  So I think, “maybe it will work if
ALSA uses jack as a backend”.  Luckily, libasound2-plugins
includes a file /usr/share/doc/libasound2-plugins/README-jack
explaining how to set this up.

Unfortunately, the instructions do not work: after setting up
asound.conf:

	$ aplay -Djack "Yardbirds - Birdland"
	Playing WAVE 'Yardbirds - Birdland.wav' : Signed 16 bit Little Endian, Rate 44100 H
	aplay: set_params:918: Sample format non available

and no sound is output.

Eventually, I did get alsa output through jack working, using
the instructions at <http://alsa.opensrc.org/index.php/Jack_(plugin)>.
Those indicate to use this configuration file:

	pcm.!default {
		type plug
		slave { pcm "jack" }
	}

	pcm.jack {
		type jack
		playback_ports {
			0 alsa_pcm:playback_1
			1 alsa_pcm:playback_2
		}
		capture_ports {
			0 alsa_pcm:capture_1
			1 alsa_pcm:capture_2
		}
	}

	ctl.mixer0 {
		type hw
		card 0
	}

The version in /usr/share/doc/libasound2-plugins/README-jack
is missing the pcm.!default and ct.mixer0 stanzas and misspells
capture_2 as pcapture_2.

With that expanded configuration file, most files play out of
the box, and for example, “aplay "Yardbirds - Birdland"” works.
But still “aplay -Djack "Yardbirds - Birdland"” still fails,
and with the same message.

Any ideas?

Thanks,
Jonathan

jackd is version 0.109.2.5

---

From: [email-masked] (Debian Bug Tracking System)
Date: Tue, 12 Jan 2010 19:15:08 +0000

This is an automatic notification regarding your Bug report
which was filed against the alsa-utils package:

#564827: aplay -Djack fails with "Sample rate non available"

It has been closed by Elimar Riesebieter <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Elimar Riesebieter <[email-masked]> by
replying to this email.

-- 
564827: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=564827
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Re: [Pkg-alsa-devel] Bug#564828: "subgraph starting at ... timed out" after about five seconds of audio playback in mplayer
From: Elimar Riesebieter <[email-masked]>
To: "Jonathan E. Brickman" <[email-masked]>, [email-masked]
Cc: Jonathan Nieder <[email-masked]>, [email-masked], [email-masked]
Date: Tue, 12 Jan 2010 20:13:54 +0100

* Jonathan E. Brickman [100112 07:32 -0600]
> Lenny isn't going to do Jack well at all, its versions of Jack and
> related libraries and apps are too old.  Squeeze with Sid libraries
> works wonderfully.

So #564828 and #564827 closed.

Elimar

-- 
  It's a good thing we don't get all 
  the government we pay for.

Subject: aplay -Djack fails with "Sample rate non available"
From: Jonathan Nieder <[email-masked]>
To: [email-masked]
Date: Mon, 11 Jan 2010 22:18:29 -0600

Package: alsa-utils
Version: 1.0.16-2

Hi,

and no sound is output.

	pcm.!default {
		type plug
		slave { pcm "jack" }
	}

	pcm.jack {
		type jack
		playback_ports {
			0 alsa_pcm:playback_1
			1 alsa_pcm:playback_2
		}
		capture_ports {
			0 alsa_pcm:capture_1
			1 alsa_pcm:capture_2
		}
	}

	ctl.mixer0 {
		type hw
		card 0
	}

Any ideas?

Thanks,
Jonathan

---

From: Jonathan Nieder <[email-masked]>
Date: Tue, 12 Jan 2010 15:43:28 -0600

reopen 564828
reopen 564827
thanks

> So #564828 and #564827 closed.

Say what?

Bug #564828 applies to sid, as I already said.  I haven’t tried to
reproduce #564827 in sid; have you?

If you don’t believe in reproducing bugs, tag it unreproducible.
If you don’t believe in fixing them, tag it wontfix.  But please
don’t close a bug for either of these reasons without a little
discussion.

Annoyed,
Jonathan