Subject: debconf-set-selections: --checkonly issues warning about password db

From: Vagrant Cascadian <[email-masked]>
Date: Sun, 27 Jun 2010 19:23:06 -0700

Package: debconf
Version: 1.5.24
Severity: wishlist
File: /usr/bin/debconf-set-selections

when running debconf-set-selections --checkonly as a non-root user, it issues
the following warning:

  debconf-set-selections --checkonly /usr/share/simple-cdd/profiles/default.preseed
  debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied

is it possible to check the format of a preseeding file without actually
accessing the debconf password database and issuing a warning?

that would be nice. thanks!

live well,
  vagrant

-- System Information:
Debian Release: 5.0.5
  APT prefers stable
  APT policy: (500, 'stable'), (103, 'testing'), (102, 'unstable'), (101, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages debconf depends on:
ii  debconf-i18n             1.5.24          full internationalization support 
ii  perl-base                5.10.0-19lenny2 minimal Perl system

Versions of packages debconf recommends:
ii  apt-utils                0.7.20.2+lenny2 APT utility programs

Versions of packages debconf suggests:
ii  debconf-doc           1.5.24             debconf documentation
pn  debconf-utils         <none>             (no description available)
pn  libgnome2-perl        <none>             (no description available)
pn  libnet-ldap-perl      <none>             (no description available)
pn  libqt-perl            <none>             (no description available)
ii  libterm-readline-gnu- 1.17a-2+b1         Perl extension for the GNU Readlin
ii  perl                  5.10.0-19lenny2    Larry Wall's Practical Extraction 
ii  whiptail              0.52.2-11.3+lenny1 Displays user-friendly dialog boxe

-- debconf information excluded

---

From: Marc Haber <[email-masked]>
Date: Fri, 18 Jun 2021 15:03:14 +0200

>that would be nice. thanks!

Can this please have some maintainer attention after almost eleven
years?

Greetings
Marc