Subject: Bug#599780: blosxom: Doesn't return 404 on non-existent blog-posting

From: Axel Beckert <[email-masked]>
Date: Mon, 11 Oct 2010 08:22:08 +0200

Package: blosxom
Version: 2.1.2-1
Severity: minor
Tags: upstream

E.g. http://noone.org/blog/blafasel just gives a complete page without
any blog-posting but also without any error message.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (600, 'stable'), (500, 'testing'), (110, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.36-rc6-686 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages blosxom depends on:
ii  perl                          5.10.1-15  Larry Wall's Practical Extraction 

Versions of packages blosxom recommends:
ii  micro-httpd [httpd]          20051212-12 really small HTTP server

blosxom suggests no packages.

-- no debconf information

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 11 Oct 2010 06:24:06 +0000

Thank you for filing a new Bug report with Debian.

This is an automatically generated reply to let you know your message
has been received.

Your message has been forwarded to the package maintainers (but not
other interested parties, as you requested) for their attention; they
will reply in due course.

As you requested using X-Debbugs-CC, your message was also forwarded to
  Axel Beckert <[email-masked]>
(after having been given a Bug report number, if it did not have one).

Your message has been sent to the package maintainer(s):
 Gerfried Fuchs <[email-masked]>

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
599780: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599780
Debian Bug Tracking System
Contact [email-masked] with problems