Subject: Re: Please mount cgroup automatically

From: Ritesh Raj Sarraf <[email-masked]>
Date: Tue, 06 Dec 2011 17:17:38 +0530

Package: initscripts
Version: 2.88dsf-13.13
Followup-For: Bug #601757

Not everyone seems to be of the opinion that a single cgroup mount point
is the right thing to do.

https://github.com/poelzi/ulatencyd/issues/26#issuecomment-3030891

Quoting the author of Ulatency:

 ulatency can be adjusted to a single mountpoint, but as said many
 times, it will suck and make it harder und more complicated to use. CPU
 subsystem is totally broken when Realtime Cgroups is enabled and you
 need constant fixing on that, making it harder with unified mountpoints.
 You can not even create more then one level of in blkio cgroup which
 will make the cpu configuration useless.
 Single mount point of all cgroup subsystems IS A BAD IDEA. You can
 configure it to do so, but it will not help you.

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (101, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages initscripts depends on:
ii  coreutils       8.13-3       
ii  debianutils     4.0.4        
ii  libc6           2.13-21      
ii  lsb-base        3.2-28       
ii  mount           2.19.1-5     
ii  sysv-rc         2.88dsf-13.13
ii  sysvinit-utils  2.88dsf-13.13

Versions of packages initscripts recommends:
ii  e2fsprogs  1.42~WIP-2011-10-16-1
ii  psmisc     22.14-1              

initscripts suggests no packages.

-- Configuration Files:
/etc/default/bootlogd changed:
BOOTLOGD_ENABLE=Yes

-- no debconf information

---

From: Ritesh Raj Sarraf <[email-masked]>
Date: Sun, 17 Jun 2012 21:39:31 +0530

> is the right thing to do.
Are there plans on fixing this for Wheezy? Currently, it is broken.

The interesting part is that lxc-checkconfig does not report any errors,
but it does not work in the current state of cgroup.

rrs@champaran:/var/lib/lxc/test1$ sudo lxc-checkconfig
Kernel config /proc/config.gz not found, looking in other places...
Found kernel config file /boot/config-3.4-trunk-amd64
--- Namespaces ---
Namespaces: enabled
Utsname namespace: enabled
Ipc namespace: enabled
Pid namespace: enabled
User namespace: enabled
Network namespace: enabled
Multiple /dev/pts instances: enabled

--- Control groups ---
Cgroup: enabled
Cgroup clone_children flag: enabled
Cgroup device: enabled
Cgroup sched: enabled
Cgroup cpu account: enabled
Cgroup memory controller: enabled
Cgroup cpuset: enabled

--- Misc ---
Veth pair device: enabled
Macvlan: enabled
Vlan: enabled
File capabilities: enabled

Note : Before booting a new kernel, you can check its configuration
usage : CONFIG=/path/to/config /usr/bin/lxc-checkconfig

It would be good to build consensus now on fixing this bug rather than
wait for the last minute.

-- 
Ritesh Raj Sarraf
RESEARCHUT - http://www.researchut.com
"Necessity is the mother of invention."