Subject: Bug#608281: dump: Restore fails if first volume file is empty

From: Michael Vezie <[email-masked]>
Date: Wed, 29 Dec 2010 11:30:44 -0500

Package: dump
Version: 0.4b41-5+b1
Severity: important

Repeat it by:

dump a filesystem to two files, one on a full filesystem, and one on 
another. (Use the filename,filename notation to specify multiple files).
Dump will fail to write the first file, and will start the backup with 
the second file. 

Restore, when it encounters this, fails in one of two ways:

If I use the M flag for multi-files (fullhome.001 is empty, and 
fullhome.002 contains the dump):

# restore ivMf fullhome.
Verify tape and initialize maps
Input is from a local file/pipe
restore: Tape read error on first record

If I forego the M flag:

# restore ivf fullhome.002
Verify tape and initialize maps
Input is from a local file/pipe
Input block size is 10
Dump tape is compressed.
Dump   date: Wed Dec  1 00:30:42 2010
Dumped from: the epoch
Level 0 dump of /home on deacon:/dev/md3
Label: HOME
restore: Tape is not volume 1 of the dump

-- System Information:
Debian Release: 5.0.3
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.18 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/bash

Versions of packages dump depends on:
ii  e2fslibs                  1.41.3-1       ext2 filesystem libraries
ii  libblkid1                 1.41.3-1       block device id library
ii  libc6                     2.7-18         GNU C Library: Shared libraries
ii  libcomerr2                1.41.3-1       common error description library
ii  libncurses5               5.7+20081213-1 shared libraries for terminal hand
ii  libreadline5              5.2-3.1        GNU readline and history libraries
ii  libuuid1                  1.41.3-1       universally unique id library
ii  tar                       1.20-1         GNU version of the tar archiving u

dump recommends no packages.

dump suggests no packages.

-- debconf information:
  dump/moving_from_etc_to_var:
  dump/dumpdates_is_a_symlink:

---

From: [email-masked] (Debian Bug Tracking System)
Date: Wed, 04 May 2011 16:39:13 +0000

Your message dated Wed, 04 May 2011 10:24:45 -0600
with message-id <[email-masked]>
has caused the   report #608281,
regarding dump: Restore fails if first volume file is empty
to be marked as having been forwarded to the upstream software
author(s) [email-masked]

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
608281: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=608281
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Re: Bug#608281: dump: Restore fails if first volume file is empty
From: Bdale Garbee <[email-masked]>
To: [email-masked]
Cc: Michael Vezie <[email-masked]>, [email-masked]
Date: Wed, 04 May 2011 10:24:45 -0600

Stelian,

I just realized this has been sitting in my bug queue for a while
without being forwarded to you.  Sorry about that!

Bdale