Subject: Bug#613024: slim: authentication failure when installed on raw Xorg

From: Shankar <[email-masked]>
Date: Sat, 12 Feb 2011 16:24:48 +0000

Package: slim
Version: 1.3.1-8
Severity: important

I am using slim on a fresh Debian Squeeze install.  The install in question is
a Debian Live CD image created with the "standard-x11" package list and running
in persistent mode (this should make it equivalent to a standard Squeeze
install with just Xorg, no DE / WM installed).  I installed xfce4 package and
then installed the slim package.

I then do sudo init 1 followed by sudo init 5 to restart the X server (or,
alternatively, restart the computer).  Slim comes up and I am able to login
normally.  The first program I open runs.  Every program after that fails with
an MIT-MAGIC-COOKIE error.  "xhosts +" reports "cannot open display :0.0".

To avoid this and get a working X configuration, I disabled slim by running
"sudo insserv -r slim."  X runs fine after that without a display manager.

Have not tried other display managers so am not sure if this error occurs in
them as well.

-- System Information:
Debian Release: 6.0
  APT prefers stable
  APT policy: (700, 'stable'), (600, 'unstable'), (500, 'squeeze-updates')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-486
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages slim depends on:
ii  debconf [debconf-2.0]         1.5.36.1   Debian configuration management sy
ii  libc6                         2.11.2-10  Embedded GNU C Library: Shared lib
ii  libgcc1                       1:4.4.5-8  GCC support library
ii  libjpeg62                     6b1-1      The Independent JPEG Group's JPEG 
ii  libpam0g                      1.1.1-6.1  Pluggable Authentication Modules l
ii  libpng12-0                    1.2.44-1   PNG library - runtime
ii  libstdc++6                    4.4.5-8    The GNU Standard C++ Library v3
ii  libx11-6                      2:1.3.3-4  X11 client-side library
ii  libxft2                       2.1.14-2   FreeType-based font drawing librar
ii  libxmu6                       2:1.0.5-2  X11 miscellaneous utility library

Versions of packages slim recommends:
ii  xterm                         261-1      X terminal emulator

Versions of packages slim suggests:
pn  scrot                         <none>     (no description available)

-- Configuration Files:
/etc/slim.conf changed:
default_path        /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
default_xserver     /usr/bin/X11/X
xserver_arguments   -nolisten tcp
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue.net; exec /bin/login"
xauth_path         /usr/bin/X11/xauth
authfile           /var/run/slim.auth
login_cmd           exec /bin/bash -login /etc/X11/Xsession %session
sessions            default,startxfce4,openbox,ion3,icewm,wmaker,blackbox,awesome
screenshot_cmd      scrot /root/slim.png
welcome_msg         Welcome to %host
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...
default_user user
auto_login yes
current_theme       debian-spacefun
lockfile            /var/run/slim.lock
logfile             /var/log/slim.log

-- debconf information:
* shared/default-x-display-manager: slim

---

From: Nobuhiro Iwamatsu <[email-masked]>
Date: Sat, 12 Feb 2011 23:24:15 +0900

Hi,

Thanks for your report!

> Have not tried other display managers so am not sure if this error occurs in

Is xauth packagr installed in your environment? Please check this.

Because this work even if this package does not install it, I do not
set it in Depends.
But I will set in Recommends.

Best regards,
  Nobuhiro
-- 
Nobuhiro Iwamatsu
   iwamatsu at {nigauri.org / debian.org}
   GPG ID: 40AD1FA6

---

From: Shankar Gopalakrishnan <[email-masked]>
Date: Mon, 14 Feb 2011 05:09:46 +0000

Sorry to have take so long to reply - I did not have access to my system for
some time.

> Thanks for your report!
No, I should be the one thanking you for all the work :)

> But I will set in Recommends.
xauth is indeed installed, so that isn't the problem.  Any idea what else
might be going on?  Perhaps this is not a slim bug at all, but something
wrong with the way live-helper is configuring the Live system.