Subject: mailman: show_qfiles does not work (for messages left by Lenny's mailman)

From: Ansgar Burchardt <[email-masked]>
Date: Mon, 21 Feb 2011 14:12:03 +0100

Package: mailman
Version: 1:2.1.13-4.1
Severity: minor

While installing the latest security update, mailman complained about
files in /var/lib/mailman/qfiles and suggested to use
/var/lib/mailman/bin/show_qfiles to examine these files.

However show_qfiles aborts with an error:

almighty-bob:/var/lib/mailman# ./bin/show_qfiles qfiles/shunt/*.pck
====================> qfiles/shunt/1292597978.7239151+566547a3f5309c27ed7a2106d9f549766cd32fba.pck
Traceback (most recent call last):
  File "./bin/show_qfiles", line 95, in <module>
    main()
  File "./bin/show_qfiles", line 88, in main
    sys.stdout.write(msg.as_string())
AttributeError: 'str' object has no attribute 'as_string'

The message in question is not very old (17 Dec 2010), but I think it was still
created with Lenny's version of mailman (we upgraded the host on that day).

Regards,
Ansgar

-- System Information:
Debian Release: 6.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages mailman depends on:
ii  apache2-mpm-itk [httpd] 2.2.16-6         multiuser MPM for Apache 2.2
ii  cron                    3.0pl1-116       process scheduling daemon
ii  debconf [debconf-2.0]   1.5.36.1         Debian configuration management sy
ii  libc6                   2.11.2-10        Embedded GNU C Library: Shared lib
ii  logrotate               3.7.8-6          Log rotation utility
ii  lsb-base                3.2-23.2squeeze1 Linux Standard Base 3.2 init scrip
ii  postfix [mail-transport 2.7.1-1          High-performance mail transport ag
ii  pwgen                   2.06-1+b1        Automatic Password generation
ii  python                  2.6.6-3+squeeze5 interactive high-level object-orie
ii  python-support          1.0.10           automated rebuilding support for P
ii  ucf                     3.0025+nmu1      Update Configuration File: preserv

mailman recommends no packages.

Versions of packages mailman suggests:
ii  listadmin                   2.40-4       command line mailman moderator que
ii  lynx                        2.8.8dev.5-1 Text-mode WWW Browser (transitiona
pn  spamassassin                <none>       (no description available)

-- Configuration Files:
/etc/mailman/apache.conf changed [not included]

-- debconf information excluded

---

From: "Thijs Kinkhorst" <[email-masked]>
Date: Sun, 14 Aug 2011 14:51:39 +0200

Hi,

On Mon, February 21, 2011 15:12, Ansgar Burchardt wrote:
> ====================>
> qfiles/shunt/1292597978.7239151+566547a3f5309c27ed7a2106d9f549766cd32fba.pck

I'm not sure that this is a bug. The upgrade process Lenny -> Squeeze will
have given the same debconf warning the securty update did, and it does
explain that the old queue files may not be compatible with the new
mailman version. If you chose 'continue regardless' in the upgrade, I
think this may be the expected behaviour.

Cheers,
Thijs