Subject: RFP: xul-ext-pencil -- GUI prototyping and diagram tool

From: Raphael Hertzog <[email-masked]>
Date: Sat, 28 May 2011 15:48:20 +0200

Package: wnpp
Severity: wishlist

* Package name    : xul-ext-pencil
  Version         : 1.2
  Upstream Author : Nguyen Tien Dung <[email-masked]>
* URL             : http://pencil.evolus.vn
* License         : GPL2+
  Programming Lang: Javascript / Xulrunner app
  Description     : The Sketching and GUI Prototyping addon for Firefox/Iceweasel

The Pencil Project's unique mission is to build a free and opensource tool for
making diagrams and GUI prototyping that everyone can use.

Top features:

    Built-in stencils for diagraming and prototyping
    Multi-page document with background page
    Inter-page linkings!
    On-screen text editing with rich-text supports
    Exporting to HTML, PNG, Openoffice.org document, Word document and PDF.
    Undo/redo supports
    Installing user-defined stencils and templates
    Standard drawing operations: aligning, z-ordering, scaling, rotating...
    Cross-platforms
    Adding external objects
    Personal Collection
    Clipart Browser
    Object snapping
    Sketchy Stencil
    And much more...

I discovered this software a few weeks ago and I would like to see it packaged
for Debian (but I don't want to do it myself).

It should probably be maintained under the umbrella of the pkg-mozext team:
http://wiki.debian.org/Teams/DebianMozExtTeam

Unfortunately the current version is not compatible with Firefox 4 yet.

Cheers,
-- 
Raphaël Hertzog ◈ Debian Developer

Follow my Debian News ▶ http://RaphaelHertzog.com (English)
                      ▶ http://RaphaelHertzog.fr (Français)

---

From: Fabrizio Regalli <[email-masked]>
Date: Tue, 31 May 2011 16:26:47 +0200

Hi Raphael,

>   Description     : The Sketching and GUI Prototyping addon for Firefox/Iceweasel

I will start working on the package, hoping to do a good job.

Cheers,
Fabrizio.