Subject: ITP: xul-ext-pencil -- GUI prototyping and diagram tool

From: Mathieu Malaterre <[email-masked]>
Date: Mon, 11 Feb 2013 10:52:09 +0100

unarchive 628285
reopen 628285
thanks

Fabrizio,

  Where do you see a base64.js ?

Steps:

  svn checkout http://evoluspencil.googlecode.com/svn/trunk/
evoluspencil-read-only
  cd evoluspencil-read-only
  find . -name base64.js
  find . | grep base64
-> empty

Thanks,

---

From: Fabrizio Regalli <[email-masked]>
Date: Tue, 12 Feb 2013 10:13:30 +0100

http://anonscm.debian.org/gitweb/?p=pkg-mozext/pencil.git;a=summary

Take a look of content/Common/Base64.js file

(this is an old ITP, maybe in the meantime the source have changed and
perhaps the file was removed)

Thank you.
Fabrizio

---

From: Fabrizio Regalli <[email-masked]>
Date: Tue, 12 Feb 2013 10:36:44 +0100

I did a quick check, and seems to be present also in new sources:

svn checkout http://evoluspencil.googlecode.com/svn/trunk/ evoluspencil-read-only
cd evoluspencil-read-only
find . -iname base64*
./Source/Common/Base64.js

Thank you.
Fabrizio

---

From: Mathieu Malaterre <[email-masked]>
Date: Tue, 12 Feb 2013 16:23:44 +0100

forwarded 628285 https://code.google.com/p/evoluspencil/issues/detail?id=541
thanks

> ./Source/Common/Base64.js

Thanks !

Let's see what upstream thinks about this. I do not think it is that
hard to replace this base64 js implementation with another.