Subject: Bug#631180: wrong gid and permissions on /usr/bin/curlftpfs

From: Christoph Scheurer <[email-masked]>
Date: Tue, 21 Jun 2011 09:44:33 +0200

Package: curlftpfs
Version: 0.9.2-3
Severity: normal

Hello,

I believe the settings for gid and permissions of /usr/bin/curlftpfs should be
the same as those for fusermount to make curlftpfs work as expected with the
Debian mechanism for the fuse group:

$ ls -l /usr/bin/fusermount
-rwsr-xr-- 1 root fuse 24292 18. Sep 2010  /usr/bin/fusermount

See also: /usr/share/doc/fuse-utils/README.Debian

-- System Information:
Debian Release: 6.0.1
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32.41-grsec (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages curlftpfs depends on:
ii  fuse-utils                    2.8.4-1.1  Filesystem in USErspace (utilities
ii  libc6                         2.11.2-10  Embedded GNU C Library: Shared lib
ii  libcurl3-gnutls               7.21.0-1   Multi-protocol file transfer libra
ii  libfuse2                      2.8.4-1.1  Filesystem in USErspace library
ii  libglib2.0-0                  2.24.2-1   The GLib library of C routines

curlftpfs recommends no packages.

curlftpfs suggests no packages.

-- no debconf information

-- 
Christoph Scheurer                                  GnuPG key Id: 0x6128C6B6

---

From: Vincent Bernat <[email-masked]>
Date: Sat, 09 Jul 2011 17:01:59 +0200

OoO  En cette matinée  ensoleillée du  mardi 21  juin 2011,  vers 09:44,

> -rwsr-xr-- 1 root fuse 24292 18. Sep 2010  /usr/bin/fusermount

There seems to be no need to  set curlftpfs to be setuid to make it work
as  a plain  user. You  only need  to have  the rights  set  properly on
/dev/fuse:

crw-rw---- 1 root fuse 10, 229  1 juil. 23:41 /dev/fuse

> See also: /usr/share/doc/fuse-utils/README.Debian

Does not exist anymore.

Maybe that  would have  been useful with  Squeeze but we  cannot correct
this kind of bugs in Squeeze. The fix is not necessary for Wheezy.
-- 
Vincent Bernat ☯ http://vincent.bernat.im

Identify bad input; recover if possible.
            - The Elements of Programming Style (Kernighan & Plauger)