Subject: /usr/sbin is not mounted at boot! So don't expect that it is please

From: [email-masked]
Date: Wed, 03 Aug 2011 09:09:16 +0800

X-Debbugs-Cc: [email-masked]
Package: alsa-utils
Version: 1.0.24.2-1
File: /lib/udev/rules.d/90-alsa-restore.rules

Gentlemen, you have blown it rather royally.

There are plenty of scripts in /lib/udev/rules.d that use RUN
$ cd /lib/udev/rules.d
$ grep RUN+= *|wc -l
123

And plenty that use /sbin

$ grep /sbin *|wc -l
26

But only one that uses /usr/sbin

$ grep /usr/sbin *|wc -l
1

And the winner is

$ grep /usr/sbin *
90-alsa-restore.rules:        RUN+="/usr/sbin/alsactl restore $attr{number}"

Which of course will fail upon boot, with plenty of errors on the console,

because /usr/sbin/ is not mounted at that time!

P.S., there already is /etc/init.d/alsa-utils so the boot case is
covered anyway.

Anyway, whatever you do, be sure you stop causing all those error
messages at boot. Thank you.

---

From: Jordi Mallach <[email-masked]>
Date: Wed, 3 Aug 2011 19:51:33 +0200

> Gentlemen, you have blown it rather royally.

jidanni, I look out of my window, and I don't see the world falling in
pieces. I just see a pair of annoying messages at boot. Don't worry, it'll
be fixed.

> because /usr/sbin/ is not mounted at that time!

It seems clear that we need to move that binary to /sbin if we want to use
it like that in udev. Luckily, this was going to happen as we try to make
our delta with ubuntu smaller (they had done this change some time ago,
not sure if the reason was to avoid this or for other reasons derived from
upstart introduction).

Jordi
-- 
Jordi Mallach Pérez  --  Debian developer     http://www.debian.org/
[email-masked]     [email-masked]     http://www.sindominio.net/
GnuPG public key information available at http://oskuro.net/

---

From: [email-masked] (Marco d'Itri)
Date: Sun, 28 Aug 2011 00:08:08 +0200

On Aug 03, Jordi Mallach <[email-masked]> wrote:

> it like that in udev.
And libasound as well.
But there is no need to, you can use a wrapper like
/lib/udev/alsa-utils.

-- 
ciao,
Marco