Subject: lintian: [PATCH] Improve description of versioned-dependency-satisfied-by-perl

From: Dominic Hargreaves <[email-masked]>
Date: Sun, 14 Aug 2011 15:46:41 +0100

Package: lintian
Version: 2.5.2
Severity: minor
Tags: patch

On Mon, Aug 08, 2011 at 10:40:31AM +0100, Dominic Hargreaves wrote:
> On Mon, Aug 08, 2011 at 07:02:03AM +0000, [email-masked] wrote:

> > Commit message:
> > 
> >     move perl 5.14 as a second alternative dependency on libextutils-parsexs-perl 2.210000
> >     
> >     Closes: #637033 -- FTBFS: unfullfillable first alternative in build-depends
> 
> Damyan, thanks for fixing this. I think I was distracted by a related
> lintian warning, which specifically suggests that perl comes first,
> forgetting the way the autobuilders interpret this.
> 
> I'll make a note to look at whether the lintian message should be
> altered.

Patch attached.

Cheers,
Dominic.

-- 
Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)
>From 85c278460c044fccdc3e742475339baf3ca6b3c5 Mon Sep 17 00:00:00 2001
From: Dominic Hargreaves <[email-masked]>
Date: Sun, 14 Aug 2011 15:42:15 +0100
Subject: [PATCH] Improve description of 
 versioned-dependency-satisfied-by-perl

The advice previously given in this description was incorrect
for versions of perl only in experimental.
---
 checks/fields.desc |    6 ++++++
 1 files changed, 6 insertions(+), 0 deletions(-)

diff --git a/checks/fields.desc b/checks/fields.desc
index 425b2d9..82c83e2 100644
--- a/checks/fields.desc
+++ b/checks/fields.desc
@@ -934,6 +934,12 @@ Info: This package declares an unnecessary versioned dependency
  versioned dependency a secondary one.
  .
  Example: perl (&gt;= 5.10.0) | libmodule-build-perl (&gt;= 0.26)
+ .
+ An exception to this is when the dependency is only satisfied in a
+ version of perl in experimental. In this case, the dependency on perl
+ should come second.
+ .
+ Example: libextutils-parsexs-perl (&gt;= 2.210000) | perl (&gt;= 5.14)
 Ref: policy 7.5
 
 Tag: package-superseded-by-perl
-- 
1.7.5.4

---

From: Niels Thykier <[email-masked]>
Date: Mon, 15 Aug 2011 22:33:48 +0200

clone 637793 -1
retitle -1 lintian: ensure perl-provides does not incl. perl from exp
tag 637793 pending
thanks

>> I'll make a note to look at whether the lintian message should be

Hi,

I feel a better solution would be to ensure we never emit the tag in
such case.  I suspect our data file might pick up the perl in
experimental (as well?) if refreshed on a system with experimental enabled.

Anyhow, for now I have committed this patch and cloned this bug to keep
a tracker for "the above".  Thanks for the report and patch. :)

~Niels