Subject: Bug#642835: Bug#642706: bin-prot: FTBFS: Command '/usr/bin/ocamlbuild syntax/pa_bin_prot.cma syntax/pa_bin_prot.cmxa syntax/pa_bin_prot.a lib/libbin_prot.a lib/dllbin_prot.so lib/bin_prot.cma lib/bin_prot.cmxa lib/bin_prot.a lib_test/test_runner.native -tag debug' terminated with error code 10

From: Stéphane Glondu <[email-masked]>
Date: Sun, 25 Sep 2011 15:38:06 +0200

Le 25/09/2011 00:00, Eric Cooper a écrit :
> I get the same error.  Here's what I did to reproduce it.
> 
> $ apt-get source libbin-prot-camlp4-dev
> $ cd bin-prot-1.3.1/
> $ DIST=sid ARCH=amd64 git-pbuilder update
> $ pdebuild --pbuilder cowbuilder -- --basepath /var/cache/pbuilder/base-sid-amd64.cow

Well... this is very strange. The same steps (except that my chroot is
in /var/cache/pbuilder/base.cow) do not produce any error on amd64. But
I get the error on i386 and armel.

Same symptoms with bug #642835. Investigating...

Cheers,

-- 
Stéphane

---

From: Stéphane Glondu <[email-masked]>
Date: Sun, 25 Sep 2011 17:59:30 +0200

tags 642706 - unreproducible
thanks

> I get the error on i386 and armel.

In my amd64 sid chroot, /bin/sh was symlinked to bash. After linking it
to dash, I can reproduce the error. The error disappears if I downgrade
dash to 0.5.5.1-7.4. I'm not yet sure who's to blame here... I'm putting
dash maintainers in the loop.

Cheers,

-- 
Stéphane

---

From: Jonathan Nieder <[email-masked]>
Date: Sun, 16 Oct 2011 06:04:42 -0500

Hi,

Mònica Ramírez Arceda wrote:

> During a rebuild of all packages in sid, your package failed to build on
> amd64.
[...]
>> + ocamlfind ocamldep -pp 'cpp -DARCH_SIXTYFOUR' -package unix -package bigarray -modules lib/unsafe_read_c.mli > lib/unsafe_read_c.mli.depends
>> Command exited with code 2.
>> E: Command '/usr/bin/ocamlbuild syntax/pa_bin_prot.cma syntax/pa_bin_prot.cmxa syntax/pa_bin_prot.a lib/libbin_prot.a lib/dllbin_prot.so lib/bin_prot.cma lib/bin_prot.cmxa lib/bin_prot.a lib_test/test_runner.native -tag debug' terminated with error code 10

Thanks again for all your work in tracking these down!  I assume
bin-prot/sid and sexplib310 build correctly again against dash
0.5.7-2.

So what should be done with these bugs?  I am tempted to say:

 - lower severity to important, since we have a workaround
 - reassign to current ocaml-nox
 - merge and mark as forwarded to
   http://caml.inria.fr/mantis/view.php?id=5371

Does that sound reasonable?

Jonathan
who is looking forward to having a few fewer RC bugs on his radar :)

---

From: Stéphane Glondu <[email-masked]>
Date: Sun, 16 Oct 2011 14:07:11 +0200

merge 642706 642835
severity 642706 important
reassign 642706 ocaml-nox
found 642706 3.12.0-7
retitle 642706 ocamlbuild: questionable job control
forwarded 642706 http://caml.inria.fr/mantis/view.php?id=5371
affects 642706 src:bin-prot src:sexplib310
thanks

> Does that sound reasonable?

Agreed.

-- 
Stéphane