Subject: Re: Bug#642922: regression: "sh -c" change causes FTBFS

From: Stéphane Glondu <[email-masked]>
Date: Sun, 25 Sep 2011 19:41:30 +0200

block 642835 by 642922
block 642706 by 642922
severity 642922 serious
thanks

Le 25/09/2011 19:28, Stéphane Glondu a écrit :
> Bugs #642706 (bin-prot FTBFS) and #642835 (sexplib310 FTBFS) can be
> fixed by reverting the patch submitted at [1]. I don't understand why.
> 
> [1] http://thread.gmane.org/gmane.comp.shells.dash/556
> 
> While investigating #642706, in the failing case, I observed that a
> cpp process called with "sh -c" gets SIGPIPE while writing to
> stderr. In the succeeding case, the write is successful, and is read
> by the ocamlbuild process that started "sh -c cpp ...".

Raising severity, since it blocks serious bugs.

Cheers,

-- 
Stéphane

---

From: Jonathan Nieder <[email-masked]>
Date: Sun, 25 Sep 2011 13:39:44 -0500

severity 642922 important
quit

>> [1] http://thread.gmane.org/gmane.comp.shells.dash/556
[...]
> Raising severity, since it blocks serious bugs.

Thanks for letting me know.  This is important (and a regression), but
it should be possible to work around in ocamlbuild as easily as using
"bash", so I don't see why that would make it release-critical.

I'll investigate further to see if the underlying problem is an
assumption in the relevant scripts that would be violated by ksh93,
too, or just a dash bug.

Thanks,
Jonathan