Subject: Bug#648479: savelog: make -d default behaviour

From: Robert Sander <[email-masked]>
Date: Sat, 12 Nov 2011 00:14:57 +0100

Package: debianutils
Version: 3.4
Severity: wishlist

Please make -d "date extension" the default behaviour of savelog.

Motivation:

We are using an rsync based incremental backup (like rsnapshot).
When files stay the same only hardlinks are created on the backup volume.
Rotated logfiles with daily or weekly changing names need more space.

-- System Information:
Debian Release: 6.0.3
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'proposed-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.39-bpo.2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages debianutils depends on:
ii  libc6                         2.11.2-10  Embedded GNU C Library: Shared lib
ii  sensible-utils                0.0.4      Utilities for sensible alternative

debianutils recommends no packages.

debianutils suggests no packages.

-- no debconf information

-- 
Robert Sander

---

From: Clint Adams <[email-masked]>
Date: Sat, 28 Jan 2012 20:46:26 +0000

> Please make -d "date extension" the default behaviour of savelog.

This would break existing scripts.