Subject: alsa-utils: alsa fails to recognize VIA8237 (AD1888) - no sound (ICE1712 - OK)

From: Eduard Tibet <[email-masked]>
Date: Fri, 25 Nov 2011 21:07:43 +0300

Package: alsa-utils
Version: 1.0.23-3
Severity: normal

alsa-utils: alsa fails to recognize VIA8237 (AD1888) - no sound (ICE1712 - OK)

After upgrading to squeeze (to be honest it was clean install of 6.0) I have no
sound on AD1888 due to failure in recognition of my sound cards with "Unknown
hardware: ... Hardware is initialized using a guess method" message. I'm sure
that it is not hardware problem - I have deprecated Win XP installation so
there sound works. Moreover recently I bought ICE1712 sound card and it works
well on my Debian box. I digged into a web to find the solution but with now
success - there are bug reports with such messages ("Unknown hardware:") but no
one related exact to my problem (no sound & hardware OK). I've purged (--purge
remove) and installed alsa-utils several times - no success.

One strange thing is this message in dmesg log ("codec_read"):

[    6.018656] VIA 82xx Audio 0000:00:11.5: PCI INT C -> GSI 22 (level, low) ->
IRQ 22
[    6.020035] VIA 82xx Audio 0000:00:11.5: setting latency timer to 64
[    6.534469] codec_read: codec 0 is not valid [0xfe0000]
[    6.541541] codec_read: codec 0 is not valid [0xfe0000]
[    6.548020] codec_read: codec 0 is not valid [0xfe0000]
[    6.554233] codec_read: codec 0 is not valid [0xfe0000]

Other info (Please note, that for testing purpose I take my ICE1712 out - there
are no related strings in dmesg and other log below):

== uname:
eduardtibet@tekomspb:~$ uname -a
Linux tekomspb 2.6.32-5-686 #1 SMP Thu Nov 3 04:23:54 UTC 2011 i686 GNU/Linux

= alsactl output:
eduardtibet@tekomspb:~$ sudo alsactl restore
Unknown hardware: "VIA8237" "Analog Devices AD1888" "AC97a:41445368" "0x1043"
"0x810d"
Hardware is initialized using a guess method

= cat /proc/asound/version
eduardtibet@tekomspb:~$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.21.

= cat /proc/asound/cards
eduardtibet@tekomspb:~$ cat /proc/asound/cards
 0 [V8237          ]: VIA8237 - VIA 8237
                      VIA 8237 with AD1888 at 0xe400, irq 22

= lsmod | grep snd
eduardtibet@tekomspb:~$ lsmod | grep snd
snd_via82xx            15256  1
gameport                6061  1 snd_via82xx
snd_ac97_codec         79200  1 snd_via82xx
ac97_bus                 710  1 snd_ac97_codec
snd_pcm_oss            28671  0
snd_mixer_oss          10461  1 snd_pcm_oss
snd_pcm                47226  3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_page_alloc          5045  2 snd_via82xx,snd_pcm
snd_mpu401_uart         4067  1 snd_via82xx
snd_seq_midi            3576  0
snd_rawmidi            12513  2 snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event      3684  1 snd_seq_midi
snd_seq                35463  2 snd_seq_midi,snd_seq_midi_event
snd_timer              12270  2 snd_pcm,snd_seq
snd_seq_device          3673  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    34423  12
snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_mpu401_uart,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               3450  1 snd

= lspci -vv | grep -A 12 audio
eduardtibet@tekomspb:~$ sudo lspci -vv | grep -A 12 audio
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 60)
        Subsystem: ASUSTeK Computer Inc. Asus P5VD1-X (AD1888 codec [SoundMax])
        Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
        Interrupt: pin C routed to IRQ 22
        Region 0: I/O ports at e400 [size=256]
        Capabilities: [c0] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: VIA 82xx Audio

00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller
(rev 80)
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-

-- System Information:
Debian Release: 6.0.3
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages alsa-utils depends on:
ii  libasound2              1.0.23-2.1       shared library for ALSA applicatio
ii  libc6                   2.11.2-10        Embedded GNU C Library: Shared lib
ii  libncursesw5            5.7+20100313-5   shared libraries for terminal hand
ii  linux-sound-base        1.0.23+dfsg-2    base package for ALSA and OSS soun
ii  lsb-base                3.2-23.2squeeze1 Linux Standard Base 3.2 init scrip
ii  module-init-tools       3.12-1           tools for managing Linux kernel mo
ii  udev                    164-3            /dev/ and hotplug management daemo
ii  whiptail                0.52.11-1        Displays user-friendly dialog boxe

Versions of packages alsa-utils recommends:
ii  alsa-base                  1.0.23+dfsg-2 ALSA driver configuration files
ii  pciutils                   1:3.1.7-6     Linux PCI Utilities

alsa-utils suggests no packages.

-- no debconf information

---

From: Elimar Riesebieter <[email-masked]>
Date: Sat, 26 Nov 2011 10:06:42 +0100

> Linux tekomspb 2.6.32-5-686 #1 SMP Thu Nov 3 04:23:54 UTC 2011 i686 GNU/Linux

Either install a newer kernel or try to compile 1.0.23 drivers from
source (apt-get install alsa-source) using module-assistant.

We don't maintain such old installations.

Elimar
-- 
  Excellent day for drinking heavily.
  Spike the office water cooler;-)