Subject: rhythmbox: crashes when re-checking an option in the preference pane

From: Andrew Engelbrecht <[email-masked]>
Date: Mon, 06 Feb 2012 20:07:01 -0500

Package: rhythmbox
Version: 2.95-1
Severity: normal

Dear Maintainer,

Opening the preference pane in rhythmbox and then checking the "Watch my
library for new files" option twice, so it turns off and then back on again,
causes the program to crash every time for me. When it starts back up again,
the option is thankfully enabled.

-Andrew

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages rhythmbox depends on:
ii  dbus                             1.4.16-1
ii  gnome-icon-theme                 3.2.1.2-1
ii  gstreamer0.10-plugins-base       0.10.35-1
ii  gstreamer0.10-plugins-good       0.10.30-2.1
ii  gstreamer0.10-x                  0.10.35-1
ii  libatk1.0-0                      2.2.0-2
ii  libc6                            2.13-24
ii  libcairo-gobject2                1.10.2-6.2
ii  libcairo2                        1.10.2-6.2
ii  libffi5                          3.0.10-3
ii  libfontconfig1                   2.8.0-3.1
ii  libfreetype6                     2.4.8-1
ii  libgdk-pixbuf2.0-0               2.24.0-2
ii  libgirepository-1.0-1            1.31.1-1
ii  libglib2.0-0                     2.30.2-6
ii  libgstreamer-plugins-base0.10-0  0.10.35-1
ii  libgstreamer0.10-0               0.10.35-1
ii  libgtk-3-0                       3.2.3-1
ii  libice6                          2:1.0.7-2
ii  libpango1.0-0                    1.29.4-2
ii  libpeas-1.0-0                    1.2.0-1
ii  librhythmbox-core5               2.95-1
ii  libsm6                           2:1.2.0-2
ii  libsoup-gnome2.4-1               2.34.3-1
ii  libsoup2.4-1                     2.34.3-1
ii  libtdb1                          1.2.9-4+b1
ii  libtotem-plparser17              2.32.6-2
ii  libxml2                          2.7.8.dfsg-7
ii  media-player-info                16-1
ii  python-gi                        3.0.3-3
ii  python-gst0.10                   0.10.22-2
ii  rhythmbox-data                   2.95-1
ii  zlib1g                           1:1.2.3.4.dfsg-3

Versions of packages rhythmbox recommends:
ii  avahi-daemon                0.6.30-6
ii  gstreamer0.10-plugins-ugly  0.10.18-3+b1
ii  gstreamer0.10-pulseaudio    0.10.30-2.1
ii  gvfs-backends               1.10.1-2
ii  notification-daemon         0.7.3-1
ii  rhythmbox-plugins           2.95-1
ii  yelp                        3.2.1+dfsg-1+b1

Versions of packages rhythmbox suggests:
ii  gnome-codec-install          <none>
ii  gnome-control-center         1:3.2.2-2
ii  gstreamer0.10-plugins-bad    0.10.22-3
ii  rhythmbox-plugin-cdrecorder  2.95-1

---

From: althaser <[email-masked]>
Date: Sun, 2 Mar 2014 22:55:22 +0000

Hey Andrew,

Could you please still reproduce this issue with newer rhythmbox version
like 2.97-2.1 or 3.0.1-1+b1 ?

here it works fine with 3.0.1-1+b2.

thanks
regards
althaser