Subject: Re: [Piuparts-devel] Bug#677238: piuparts: does not play well with TMPDIR on tmpfs

From: Andreas Beckmann <[email-masked]>
Date: Tue, 12 Jun 2012 17:25:13 +0200

forcemerge 661312 677238
thanks

Not a problem with tmpfs. Just with the mount options nodev/nosuid.

Andreas

---

From: Luca Capello <[email-masked]>
Date: Thu, 14 Jun 2012 15:01:08 +0200

affects 661312 + initscripts
thanks

Hi there!

On Tue, 12 Jun 2012 20:50:49 +0200, Luca Capello wrote:
> On Tue, 12 Jun 2012 17:25:13 +0200, Andreas Beckmann wrote:
>> forcemerge 661312 677238
>> thanks
>>
> Ops, I looked for bugs with title "tmp" or "TMP", but not "temp" :-(
>
> Now it also explains why pbuilder worked and piuparts did not: pbuilder
> uses /home/luca/var/cache/pbuilder/build, which is a tmpfs, but with no
> nodev/nosuid, while piuparts uses /tmp, which originally came from the
> "/tmp as tmpfs" migration.

This means that RAMTMP=yes as default in /etc/default/tmpfs will break
piuparts, /lib/init/mount-functions.sh from initscripts_2.88dsf-27 has:

--8<---------------cut here---------------start------------->8---
   541          # Mount /tmp as tmpfs if enabled.
   542          if [ yes = "$RAMTMP" ]; then
   543                  domount "$MNTMODE" tmpfs shmfs /tmp tmpfs "-onodev,nosuid$TMP_OPT"
   544                  # Make sure we don't get cleaned
   545                  touch /tmp/.tmpfs
   546          else
   547                  # When root is still read only, this will fail.
   548                  if [ mount_noupdate != "$MNTMODE" ] && [ rw = "$rootmode" ]; then
   549                          chmod "$TMP_MODE" /tmp
   550                  fi
   551          fi
   552  }
--8<---------------cut here---------------end--------------->8---

Thx, bye,
Gismo / Luca