Subject: Bug#661958: transition: apache2

From: Arno Töll <[email-masked]>
Date: Sat, 03 Mar 2012 00:43:27 +0100

Package: release.debian.org
Severity: normal
User: [email-masked]
Usertags: transition

We are in preparation of a transition of the Apache web server which is moving
to a new major release (from 2.2 to 2.4). This is going to affect a large
number of software in the Debian ecosystem, as Apache has a substantial number
of reverse dependencies which are going to need a source transition.  There are
several classes of affected packages:

* modules: These need adjustments in their configuration, dependencies and
  possibly some code changes
* web applications: These probably only need changes
  to included configurations.
* gnome-user-share: This pacakge includes its own complete configuration which
  needs to be updated.

We are willing to assist the affected reverse dependencies with patches, NMUs
and bug reports if required. First, let us point out the status quo. Apache
consists of three major packages currently:

* apache2 - an almost empty meta-package (depends on -common and a MPM package)
* apache2.2-bin - contains all binaries and modules, including MPM binaries
* apache2.2-common - containts init scripts, arch-independent data, conffiles

Additionally there are MPM packages (apache2-mpm-worker + 4 alternatives) which
are essentially empty, but mark an appropriate conflict resolution situation,
as these MPMs can't be used concurrently at the same time and some reverse
dependencies or users might have certain preferences. However, the actual
binaries already lie in the apache2.2-bin package, the MPM packages only put
symlinks in place.  The upcoming upgrade breaks ABIs. Thus,

we are required to rename several packages. Our ABI didn't change since Etch,
so we expect people having a lot of unmaintained and third party modules
sitting around and such outdated modules would break the webserver at postinst
time or when trying to start the updated web server at latest. While we are at
it, we try to make future transitions more manageable as the current situation
is complicated to say the least (e.g. conffiles in apache2.2-common). The API
changes are incremental, however. The actual code changes required will be
rather small in most modules. That makes the transition a lot of work, but not
impossible. We do not expect any major API incompatibility, but some modules
(like mod_php and mod_perl) will need larger changes included in new upstream
versions.

In future we want three packages:

* apache2: containting conffiles, init scripts, Debian specifics
* apache2-bin: containing binaries, providing a versioned virtual package
  determining the ABI.  Reverse dependencies are supposed to depend on this
  package exclusively (e.g. apache2-api-YYYYMMNN)
* apache2-data: containing arch-independent data (icons, error pages, ...)

The MPM packages are not needed anymore, as MPMs are simple modules in 2.4
which can be loaded at runtime. Additionally we need to rename the -dev
package, as we are going to get rid of the threaded/prefork distinction at -dev
level, too. To achieve a smooth upgrade path for all setups we are going to
need transitional packages.  We think it is feasible to rename the -dev package
without transitional package, as we want to improve declaration of reverse
dependencies, so a source change is needed anyway. To assist package
maintainers we wrote a debhelper (dh_apache2) which helps maintainers setting
up appropriate dependencies as well as possbibly Lintian checks. We plan to
announce this change on a separate mail to debian-devel-announce once an upload
is ready.

Our suggested timeline:

* We hope to have a package ready for experimental in mid-March.
* We approach an upload to Sid in April, and would like to start filing bugs if
  required by then as well

Depending on consensus, this opportunity could also be used to change
dependencies of web applications on web servers to some recommended defaults.
Lighttpd and nginx maintainers signaled interest to homogenize dependencies of
web applications.

Affected reverse dependencies:

73 Module source packages (from "dak rm -nR -b apache2.2-common
apache2-threaded-dev apache2-prefork-dev"):

apache-mod-auth-ntlm-winbind
apache-upload-progress-module
apparmor
axis2c
dacs
gridsite
libapache2-authcookie-perl
libapache2-mod-auth-cas
libapache2-mod-authn-sasl
libapache2-mod-authn-yubikey
libapache2-mod-authnz-external
libapache2-mod-auth-openid
libapache2-mod-auth-pam
libapache2-mod-auth-pgsql
libapache2-mod-auth-plain
libapache2-mod-authz-unixgroup
libapache2-mod-bw
libapache2-mod-defensible
libapache2-mod-encoding
libapache2-mod-fcgid
libapache2-mod-geoip
libapache2-mod-ldap-userdir
libapache2-mod-lisp
libapache2-mod-macro
libapache2-mod-perl2
libapache2-mod-python
libapache2-mod-qos
libapache2-mod-rivet
libapache2-mod-rpaf
libapache2-mod-ruid2
libapache2-mod-xsendfile
libapache2-reload-perl
libapache-authenhook-perl
libapache-mod-auth-kerb
libapache-mod-auth-radius
libapache-mod-evasive
libapache-mod-fastcgi/non-free
libapache-mod-jk
libapache-mod-layout
libapache-mod-log-sql
libapache-mod-musicindex
libapache-mod-random
libapache-mod-removeip
libapache-singleton-perl
libapreq2
libcgi-application-dispatch-perl
libembperl-perl
mod-auth-mysql
mod-authn-webid
mod-dnssd
mod-gnutls
mod-mime-xattr
mod-mono
mod-proxy-html
mod-ruby
modsecurity-apache
mod-spamhaus
mod-vhost-hash-alias
mod-vhost-ldap
mod-wsgi
neko
ocamlnet
parser
passenger
php5
rampart
scgi
shibboleth-sp2
speedy-cgi-perl
subversion
suphp
uwsgi
webauth

Source packages of web applications, etc.: 129 packages Searched by looking for
/etc/.*apache.* with apt-file. It is likely that not all of these require
adjustments.

acidbase
ampache
apt-cacher
auth2db
backuppc
bandwidthd
bcfg2
check-mk
chemical-structures
cipux-cat-web
collabtive
cricket
dcmtk
debian-edu-config
dhelp
dico
docbookwiki
doc-central
docvert
dotclear
dpkg-www
d-push
drupal6
drupal7
dsc-statistics
dwww
emacspeak
emboss-explorer
fai
fail2ban
fookebox
freeradius
frontaccounting
fusionforge
gallery
gallery2
ganglia
gbrowse
git
glpi
gosa
haci
heartbeat
ikiwiki-hosting
ipplan
iptotal
jffnms
jpoker
jsmath
jsxgraph
knowledgeroot
kolabd
kolab-webadmin
kolab-webclient
ldap-account-manager
lemonldap-ng
letodms
libapache-gallery-perl
libapache-mod-fastcgi
lightsquid
linkchecker
lire
logcheck
lurker
lwat
mahara
mailman
mediawiki
minit
mobyle
movabletype-opensource
mumble
mumble-django
munin
mythweb
nagvis
nanourl
netams
netdisco
Netdisco
ojs
phamm
phpgacl
phpldapadmin
phpmyadmin
phppgadmin
php-xajax
piwigo
pnopaste
pnp4nagios
poker-network
request-tracker3.8
request-tracker4
roundcube
routino
rtgui
rtpg
sagan-rules
scuttle
semanticscuttle
simba
simplesamlphp
sitesummary
slbackup-php
smb2www
smbind
smokeping
spip
spotweb
squirrelmail
sugarplum
sympa
torrentflux
torrus
twitter-bootstrap
typo3-src
ukolovnik
usemod-wiki
w3c-linkchecker
webgui
websvn
wims
xemacs21-packages
xsp
xymon
yocto-reader
zabbix
zoneminder
zoph

2 special cases (from "dak rm -nR -b apache2.2-bin"):

gnome-user-share
mod-dnssd

---

From: Julien Cristau <[email-masked]>
Date: Sat, 24 Mar 2012 22:36:48 +0100

> * We approach an upload to Sid in April, and would like to start filing bugs if
With apache 2.4 now in experimental, I'd suggest filing bugs on reverse
dependencies ASAP, to give maintainers as much time as possible to
update their packages and get them tested.

Cheers,
Julien

---

From: Arno Töll <[email-masked]>
Date: Mon, 02 Apr 2012 00:08:06 +0200

> apache2-threaded-dev apache2-prefork-dev"):
[...]

For these packages the mass bugs were failed today. They are being
tracked under the usertag "apache24transition" for the user
"[email-masked]", see [1].

[1]
http://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=apache24transition;users=[email-masked]

- -- 
with kind regards,
Arno Töll
IRC: daemonkeeper on Freenode/OFTC
GnuPG Key-ID: 0x9D80F36D

---

From: Arno Töll <[email-masked]>
Date: Sun, 15 Apr 2012 22:46:07 +0200

Hello again,

we've just uploaded Apache2 2.4.2-1 to experimental. We consider this
version matured enough to be used for a wider audience. Therefore, we
kindly ask for permission to upload our package to unstable as soon as
it fits for you.

> apache2-threaded-dev apache2-prefork-dev"):

Along that upload I would like to raise remaining bug severities of
packages outlined in that list above and which effectively means, these
bugs would become release critical.

> /etc/.*apache.* with apt-file. It is likely that not all of these require

Finally, I'd like to mass file bugs with severity "important" for these
web applications.

-- 
with kind regards,
Arno Töll

---

From: Russ Allbery <[email-masked]>
Date: Sun, 15 Apr 2012 20:34:55 -0700

> bugs would become release critical.

Just to mention, while I am going to start working on this as soon as I
can, I do have a couple of Apache module packages for which the port to
2.4 is definitely non-trivial.  For Shibboleth, for example, it's going to
requite a significant upstream release since the way that it handles
authorization rules doesn't work at all.  Upstream is working on that, but
it's going to be a little bit more.

I don't know if that's an argument against making all of those bugs
release-critical... but certainly they do need to be fixed before the
release, so it's directly true.  I kind of don't want the working packages
to be removed from testing, though (not that making the bugs RC causes
that directly).

-- 
Russ Allbery ([email-masked])               <http://www.eyrie.org/~eagle/>

---

From: Julien Cristau <[email-masked]>
Date: Mon, 16 Apr 2012 19:37:18 +0200

> Finally, I'd like to mass file bugs with severity "important" for these
What prevents you from doing that now?  If you give other maintainers
more time to adjust their packages, you'll have to fix fewer packages
yourself...

Cheers,
Julien

---

From: Arno Töll <[email-masked]>
Date: Mon, 16 Apr 2012 20:02:26 +0200

Hi,

> more time to adjust their packages, you'll have to fix fewer packages

we didn't until now, as we didn't consider the apache2 default
configuration fixed until the last upload. Now, as that's sorted out we
could possibly proceed in doing so.

However, I was not sure if we should hassle web application maintainers
already, as the apache2 package is not in unstable yet and their web
applications most likely rely on a third party module (think of mod_php5
for example) which is not available for Apache 2.4 at the moment.

This leaves maintainers of web application with a transition bug they
can't work on easily as it is blocked by a transition of other packages
first.

---

From: Julien Cristau <[email-masked]>
Date: Sat, 21 Apr 2012 15:10:24 +0200

> for example) which is not available for Apache 2.4 at the moment.
One way to avoid this is to get a php5 uploaded to experimental built
against the new apache.

Cheers,
Julien

---

From: Arno Töll <[email-masked]>
Date: Sat, 21 Apr 2012 15:13:53 +0200

Hi,

> One way to avoid this is to get a php5 uploaded to experimental built

We already requested PHP maintainers to do so. Alternatively PHP web
applications can test by using a (Fast-)CGI alternative.

We just filed the web app bugs a minute ago, too - just for the record.
They are tracked as user [email-masked] usertag
apache24webapptransition. See [1]

[1]
http://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=apache24webapptransition;users=[email-masked]

---

From: Ondřej Surý <[email-masked]>
Date: Mon, 23 Apr 2012 08:20:55 +0200

> applications can test by using a (Fast-)CGI alternative.

I'll take care of it within 1(ish) week (I will be outside internet
access from Thu to Sun,
so if I don't make it I will have to wait to next Mon-Tue).

O.
-- 
Ondřej Surý <[email-masked]>

---

From: [email-masked] (Debian Bug Tracking System)
Date: Thu, 01 Aug 2013 22:18:04 +0000

This is an automatic notification regarding your Bug report
which was filed against the release.debian.org package:

#661958: transition: apache2 2.4

It has been closed by "Adam D. Barratt" <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact "Adam D. Barratt" <[email-masked]> by
replying to this email.

-- 
661958: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=661958
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Re: Bug#661958: Reboot Apache2 2.4 transition
From: "Adam D. Barratt" <[email-masked]>
To: Arno Töll <[email-masked]>, [email-masked]
Cc: Debian PHP Maintainers <[email-masked]>, Alberto Gonzalez Iniesta <[email-masked]>, Debian Python Modules Team <[email-masked]>, Regis Boudin <[email-masked]>, Debian Java Maintainers <[email-masked]>, Peter Samuelson <[email-masked]>, Tatsuki Sugiura <[email-masked]>
Date: Thu, 01 Aug 2013 23:14:52 +0100

On Sat, 2013-05-04 at 18:12 +0200, Arno Töll wrote:
> Now that Wheezy is ehrm virtually released ..., we'd like to reboot the
> Apache 2.4 transition process as soon as possible.

This is all done now:

   apache2 |       2.4.6-2 |    testing | source, amd64, armel, armhf, i386, ia64, kfreebsd-amd64, kfreebsd-i386, mips, mipsel, powerpc, s390, s390x, sparc
      php5 |  5.5.1+dfsg-1 |    testing | source, all

Regards,

Adam

Subject: transition: apache2
From: Arno Töll <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sat, 03 Mar 2012 00:43:27 +0100

Our suggested timeline:

acidbase
ampache
apt-cacher
auth2db
backuppc
bandwidthd
bcfg2
check-mk
chemical-structures
cipux-cat-web
collabtive
cricket
dcmtk
debian-edu-config
dhelp
dico
docbookwiki
doc-central
docvert
dotclear
dpkg-www
d-push
drupal6
drupal7
dsc-statistics
dwww
emacspeak
emboss-explorer
fai
fail2ban
fookebox
freeradius
frontaccounting
fusionforge
gallery
gallery2
ganglia
gbrowse
git
glpi
gosa
haci
heartbeat
ikiwiki-hosting
ipplan
iptotal
jffnms
jpoker
jsmath
jsxgraph
knowledgeroot
kolabd
kolab-webadmin
kolab-webclient
ldap-account-manager
lemonldap-ng
letodms
libapache-gallery-perl
libapache-mod-fastcgi
lightsquid
linkchecker
lire
logcheck
lurker
lwat
mahara
mailman
mediawiki
minit
mobyle
movabletype-opensource
mumble
mumble-django
munin
mythweb
nagvis
nanourl
netams
netdisco
Netdisco
ojs
phamm
phpgacl
phpldapadmin
phpmyadmin
phppgadmin
php-xajax
piwigo
pnopaste
pnp4nagios
poker-network
request-tracker3.8
request-tracker4
roundcube
routino
rtgui
rtpg
sagan-rules
scuttle
semanticscuttle
simba
simplesamlphp
sitesummary
slbackup-php
smb2www
smbind
smokeping
spip
spotweb
squirrelmail
sugarplum
sympa
torrentflux
torrus
twitter-bootstrap
typo3-src
ukolovnik
usemod-wiki
w3c-linkchecker
webgui
websvn
wims
xemacs21-packages
xsp
xymon
yocto-reader
zabbix
zoneminder
zoph

gnome-user-share
mod-dnssd