Subject: Bug#674936: pulseaudio: Html5 player can change system volume on track changing. Pls disable it.

From: Ploskov Aleksandr <[email-masked]>
Date: Fri, 31 Jul 2015 12:17:03 +0300

Package: pulseaudio
Version: 6.0-2
Followup-For: Bug #674936

Dear Maintainer,

I went to Youtube and tried to listen music. But when I change the track,
 volume jumps up, to html5 player volume settings. It means, html5 player had 
higher priority, than user (by default). My browser is ephipany. I think, it's
browser-independent.
Changing config file (flat-volumes = no) help to solve my problem.
Please, change default settings to "flat-volumes = no", without help on russian
linux forum, I couldn't solve this problem alone, as user.

-- Package-specific info:
File '/etc/default/pulseaudio' does not exist

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.0.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages pulseaudio depends on:
ii  adduser                       3.113+nmu3
ii  libasound2                    1.0.29-1
ii  libasound2-plugins            1.0.29-1
ii  libc6                         2.19-19
ii  libcap2                       1:2.24-9
ii  libdbus-1-3                   1.8.20-1
ii  libfftw3-single3              3.3.4-2
ii  libgcc1                       1:5.1.1-14
ii  libice6                       2:1.0.9-1+b1
ii  libltdl7                      2.4.2-1.11
ii  liborc-0.4-0                  1:0.4.24-1
ii  libpulse0                     6.0-2
ii  libsm6                        2:1.2.2-1+b1
ii  libsndfile1                   1.0.25-9.1
ii  libspeexdsp1                  1.2~rc1.2-1
ii  libstdc++6                    5.1.1-14
ii  libsystemd0                   222-2
ii  libtdb1                       1.3.5-1
ii  libudev1                      222-2
ii  libwebrtc-audio-processing-0  0.1-3
ii  libx11-6                      2:1.6.3-1
ii  libx11-xcb1                   2:1.6.3-1
ii  libxcb1                       1.10-3+b1
ii  libxtst6                      2:1.2.2-1+b1
ii  lsb-base                      4.1+Debian13+nmu1
ii  pulseaudio-utils              6.0-2
ii  udev                          222-2

Versions of packages pulseaudio recommends:
ii  pulseaudio-module-x11  6.0-2
ii  rtkit                  0.11-2

Versions of packages pulseaudio suggests:
pn  paman        <none>
pn  paprefs      <none>
pn  pavucontrol  <none>
pn  pavumeter    <none>

-- Configuration Files:
/etc/pulse/daemon.conf changed:
; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no
; high-priority = yes
; nice-level = -11
; realtime-scheduling = yes
; realtime-priority = 5
; exit-idle-time = 20
; scache-idle-time = 20
; dl-search-path = (depends on architecture)
; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa
; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0
; resample-method = speex-float-1
; enable-remixing = yes
; enable-lfe-remixing = no
flat-volumes = no
; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 200000
; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; default-sample-channels = 2
; default-channel-map = front-left,front-right
; default-fragments = 4
; default-fragment-size-msec = 25
; enable-deferred-volume = yes
; deferred-volume-safety-margin-usec = 8000
; deferred-volume-extra-delay-usec = 0

-- no debconf information

---

From: Felipe Sateler <[email-masked]>
Date: Fri, 31 Jul 2015 09:02:12 -0300

Control: forcemerge 697119 -1
Control: retitle -1 pulseaudio: disable flat volumes

> linux forum, I couldn't solve this problem alone, as user.

Hi, this has already been requested, but so far it has not been changed

-- 

Saludos,
Felipe Sateler