Subject: make PDF smaller with version1.4

From: Hideki Yamane <[email-masked]>
Date: Mon, 4 Jun 2012 04:22:29 +0900

Package: texlive-latex-extra-doc
Version: 2012.20120529-1
Severity: wishlist

Hi,

 I got a advice from Munehiro Yamamoto (TeX package maintainer in VineLinux)
 to reduce PDF file size in TeX related package. It's just using pdfwrite
 device in GS to down its pdf level to 1.4.

----------------------------------------------------------------------------
how to
----------------------------------------------------------------------------

 I wrote temporary script as compress.sh, to exec gs like this,

>     gs -sDEVICE=pdfwrite -dCompatibilityLevel=1.4 -dNOPAUSE -dQUIET -dBATCH \
>     -sOutputFile=$i.output $i && echo "$i"

 It re-Distiller pdf files to PDF1.4 via GS's pdfwrite, its script consumes 
 15 min in my box.

> real	15m36.362s
> user	15m4.020s
> sys	0m17.365s

----------------------------------------------------------------------------
result
----------------------------------------------------------------------------
$ du -h *xz
279M	data.tar.xz
245M	usr.orig.tar.xz
145M	usr.tar.xz

  279MB -> 245MB (best xz compression, reduce 30MB as Bug#)
  279MB -> 145MB (re-Distiller + best xz compression =130MB!)

 I think that's worth to try it :)
 And I've filed this to texlive-latex-extra-doc, however it may be applied to
 other packages.

-- 
Regards,

 Hideki Yamane     henrich @ debian.or.jp/org
 http://wiki.debian.org/HidekiYamane

---

From: Hideki Yamane <[email-masked]>
Date: Fri, 6 Oct 2017 15:38:45 +0900

Hi again,

* Tried to apply PDF size reduction to all texlive-*-doc packages
-> Total:1416.4MB becomes 1024.8MB, 28% reduction.

* All -doc packages have nothing difference with PDF-1.4 and other versions,
  so just convert to PDF-1.4 is enough.

* Compare size with original
-----------------------------------------------------------
texlive-fonts-extra-doc
105M    original
72M     PDF-1.4

-> 32% reduction

texlive-fonts-recommended-doc
3.4M    original
2.8M    PDF-1.4

-> 17%

texlive-latex-base-doc
54M     original
62M     PDF-1.4

-> bigger...

texlive-latex-extra-doc
496M    original
316M    PDF-1.4

-> 36%

texlive-latex-recommended-doc
47M     original
42M     PDF-1.4

-> 10%

texlive-metapost-doc
37M     original
32M     PDF-1.4

-> 13%

texlive-pictures-doc
133M    original
157M    PDF-1.4

-> bigger...

texlive-pstricks-doc
283M    original
200M    PDF-1.4

-> 29%

texlive-publishers-doc
175M    original
120M    PDF-1.4

-> 31%

texlive-science-doc
60M     original
34M     PDF-1.4

-> 46%

texlive-humanities-doc
23M     original
19M     PDF-1.4

-> 17%
-----------------------------------------------------------

* texlive-pictures-doc and texlive-latex-base-doc become
bigger size with PDF-1.4. So we should exclude them.

---

From: Norbert Preining <[email-masked]>
Date: Fri, 6 Oct 2017 21:01:11 +0900

> * Compare size with original

How did you convert? And did you check that *all* files are still
correct after conversion/recompression?

Norbert

--
PREINING Norbert                               http://www.preining.info
Accelia Inc.     +    JAIST     +    TeX Live     +    Debian Developer
GPG: 0x860CDC13   fp: F7D8 A928 26E3 16A1 9FA0 ACF0 6CAC A448 860C DC13