Subject: xulrunner-14.0: Regression from XR 13: Fails to start: Cannot find XULRunner runtime directory. Exiting.

From: Axel Beckert <[email-masked]>
Date: Sun, 29 Jul 2012 11:58:08 +0200

Package: xulrunner-14.0
Version: 14.0.1-2
Severity: important
Forwarded: https://bugzilla.mozilla.org/show_bug.cgi?id=756786
Tags: upstream

[This bug report is a summary of the thread on the
 pkg-mozilla-maintainers list mentioned below.]

xulrunner-14.0 is unable to start and hence more or less unusable for
XULRunner applications which don't use xulrunner-stub:

$ xulrunner-14.0
Cannot find XULRunner runtime directory. Exiting.
$

Compared with xulrunner-13.0:

$ xulrunner-13.0
Mozilla XULRunner 13.0.1

Usage: xulrunner [OPTIONS]
       xulrunner APP-FILE [APP-OPTIONS...]

OPTIONS
      --app                  specify APP-FILE (optional)
  -h, --help                 show this message
  -v, --version              show version
  --gre-version              print the GRE version string on stdout
  --install-app <application> [<destination> [<directoryname>]]
                             Install a XUL application.

APP-FILE
  Application initialization file.

APP-OPTIONS
  Application specific options.
$

The same happens when trying to run a XULRunner application which
doesn't use xulrunner-stub (like Conkeror) with xulrunner-14.0:

$ xulrunner-14.0 /usr/share/conkeror/application.ini
Cannot find XULRunner runtime directory. Exiting.
$

(For that reason, the conkeror package currently only supports XULRunner
up to version 13 and is hence not directly affected, but relies on older
versions being available instead.)

This is tracked upstream at
https://bugzilla.mozilla.org/show_bug.cgi?id=756786 also affects the
xulrunner-15.0 and xulrunner-16.0 packages from the archive at
http://mozilla.debian.net/.

Workaround is to directly use /usr/lib/xulrunner-*/xulrunner-bin from
the according version (which is not in the shell's search path by
default).

xulrunner-stub using applications like iceweasel are not affected.

On the pkg-mozilla-maintainers list the issue is discussed in this
thread:

Start at http://lists.alioth.debian.org/pipermail/pkg-mozilla-maintainers/2012-May/012713.html
Continued at http://lists.alioth.debian.org/pipermail/pkg-mozilla-maintainers/2012-July/012976.html

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (900, 'testing'), (600, 'stable'), (200, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.4-trunk-686-pae (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages xulrunner-14.0 depends on:
ii  libasound2                1.0.25-3
ii  libatk1.0-0               2.4.0-2
ii  libbz2-1.0                1.0.6-3
ii  libc6                     2.13-35
ii  libcairo2                 1.12.2-2
ii  libdbus-1-3               1.6.4-1
ii  libdbus-glib-1-2          0.100-1
ii  libevent-2.0-5            2.0.19-stable-3
ii  libfontconfig1            2.9.0-7
ii  libfreetype6              2.4.9-1
ii  libgcc1                   1:4.7.1-5
ii  libgdk-pixbuf2.0-0        2.26.1-1
ii  libglib2.0-0              2.32.3-1
ii  libgtk2.0-0               2.24.10-1
ii  libhunspell-1.3-0         1.3.2-4
ii  libjpeg8                  8d-1
ii  libmozjs14d               14.0.1-2
ii  libnotify4                0.7.5-1
ii  libnspr4                  2:4.9.2-1
ii  libnspr4-0d               2:4.9.2-1
ii  libnss3                   2:3.13.5-1
ii  libnss3-1d                2:3.13.5-1
ii  libpango1.0-0             1.30.0-1
ii  libpixman-1-0             0.26.0-3
ii  libsqlite3-0              3.7.13-1
ii  libstartup-notification0  0.12-1
ii  libstdc++6                4.7.1-5
ii  libvpx1                   1.1.0-1
ii  libx11-6                  2:1.5.0-1
ii  libxext6                  2:1.3.1-2
ii  libxrender1               1:0.9.7-1
ii  libxt6                    1:1.1.3-1
ii  zlib1g                    1:1.2.7.dfsg-13

xulrunner-14.0 recommends no packages.

Versions of packages xulrunner-14.0 suggests:
ii  libcanberra0  0.28-4
pn  libgnomeui-0  <none>

-- no debconf information

---

From: Jörg Sommer <[email-masked]>
Date: Mon, 30 Jul 2012 11:43:19 +0200

> the according version (which is not in the shell's search path by

Another workaround is to copy the file
/usr/lib/xulrunner-13.0/run-mozilla.sh to /usr/lib/xulrunner-14.0.
This file didn't change since xulrunner 10.

Regards, Jörg.
-- 
Wenn Du jedesmal stehen bleibst, wenn ein Hund bellt, wirst du Deine Reise
nie beenden.                                       (Arabisches Sprichwort)