Subject: libgtk-vnc-2.0-0: custom keyboard (ctrl:nocaps) not taken into account

From: Luca Capello <[email-masked]>
Date: Sat, 03 Nov 2012 17:21:56 +0100

Package: libgtk-vnc-2.0-0
Version: 0.5.1-1
Severity: normal
Usertags: pca.it-virtualization

Hi there!

The Ctrl-left key on my ThinkPad X60 is broken, thus I re-mapped it to
CapsLock in /etc/default/keyboard, see:

  <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=621835#83>

However, virt-viewer does not like it and it obliges me to use the
broken Ctrl-left key.  The same happens with gvncviewer, thus reported
it to libgtk-vnc ;-)

Thx, bye,
Gismo / Luca

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.6-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libgtk-vnc-2.0-0 depends on:
ii  libatk1.0-0         2.4.0-2
ii  libc6               2.13-36
ii  libcairo-gobject2   1.12.2-2
ii  libcairo2           1.12.2-2
ii  libgcrypt11         1.5.0-3
ii  libgdk-pixbuf2.0-0  2.26.1-1
ii  libglib2.0-0        2.33.12+really2.32.4-3
ii  libgnutls26         2.12.20-1
ii  libgpg-error0       1.10-3.1
ii  libgtk-3-0          3.4.2-4
ii  libgvnc-1.0-0       0.5.1-1
ii  libpango1.0-0       1.30.0-1
ii  libsasl2-2          2.1.25.dfsg1-6
ii  libx11-6            2:1.5.0-1
ii  zlib1g              1:1.2.7.dfsg-13

libgtk-vnc-2.0-0 recommends no packages.

libgtk-vnc-2.0-0 suggests no packages.

-- no debconf information

---

From: Guido Günther <[email-masked]>
Date: Sun, 25 Nov 2012 20:31:57 +0100

Hi Luca,
> broken Ctrl-left key.  The same happens with gvncviewer, thus reported

Sorry for the late reply. As far as I understand Gtk-VNC it uses the
"hardware keycode" so the remapping will pass unnoticed (see
./src/vncdisplaykeymap_xorgevdev2rfb.c). Does it work if you remap in
the VM?
Cheers,
 -- Guido

> _______________________________________________
> Pkg-libvirt-maintainers mailing list
> [email-masked]
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-libvirt-maintainers