Subject: Bug#698985: alsa-utils: alsamixer does not work. Broken pipe.

From: Azuki <[email-masked]>
Date: Sat, 26 Jan 2013 09:36:44 +0900

Package: alsa-utils
Version: 1.0.23-3
Severity: normal

I use usb-sound-card AS372(chip:CM6620).
When I type 'alsamixer', An error of 'cannot load mixer controls: Broken pipe' is displayed, and alsamixer does not work.

$ alsamixer
cannot load mixer controls: Broken pipe

$ alsactl init 0
Unknown hardware: "USB-Audio" "USB Mixer" "USB147a:e055" "" ""
Hardware is initialized using a guess method

$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.24.

$ cat /proc/asound/cards
 0 [Audio          ]: USB-Audio - USB2.0 High-Speed True HD Audio
                      CMEDIA USB2.0 High-Speed True HD Audio at usb-0000:00:13.5-1, high speed

$ lsmod | grep snd
snd_usb_audio          84349  0 
snd_pcm                67626  1 snd_usb_audio
snd_page_alloc         12969  1 snd_pcm
snd_hwdep              13148  1 snd_usb_audio
snd_usbmidi_lib        23305  1 snd_usb_audio
snd_seq_midi           12848  0 
snd_seq_midi_event     13316  1 snd_seq_midi
snd_rawmidi            22850  2 snd_usbmidi_lib,snd_seq_midi
snd_seq                44755  2 snd_seq_midi,snd_seq_midi_event
snd_timer              22704  2 snd_pcm,snd_seq
snd_seq_device         13155  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    52577  8 snd_usb_audio,snd_pcm,snd_hwdep,snd_usbmidi_lib,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              13014  1 snd
usbcore               127627  6 snd_usb_audio,snd_usbmidi_lib,usbhid,ohci_hcd,ehci_hcd

$ lsusb
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:c058 Logitech, Inc. M115 Mouse
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 147a:e055 Formosa Industrial Computing, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

$ dmesg | grep usb
[    3.643791] usbcore: registered new interface driver usbfs
[    3.643859] usbcore: registered new interface driver hub
[    3.643932] usbcore: registered new device driver usb
[    3.680171] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    3.680174] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.680176] usb usb1: Product: EHCI Host Controller
[    3.680178] usb usb1: Manufacturer: Linux 3.2.0-0.bpo.4-rt-amd64 ehci_hcd
[    3.680180] usb usb1: SerialNumber: 0000:00:13.5
[    3.752563] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
[    3.752566] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.752568] usb usb2: Product: OHCI Host Controller
[    3.752570] usb usb2: Manufacturer: Linux 3.2.0-0.bpo.4-rt-amd64 ohci_hcd
[    3.752572] usb usb2: SerialNumber: 0000:00:13.0
[    3.812116] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
[    3.812119] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.812121] usb usb3: Product: OHCI Host Controller
[    3.812123] usb usb3: Manufacturer: Linux 3.2.0-0.bpo.4-rt-amd64 ohci_hcd
[    3.812125] usb usb3: SerialNumber: 0000:00:13.1
[    3.872067] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
[    3.872070] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.872073] usb usb4: Product: OHCI Host Controller
[    3.872074] usb usb4: Manufacturer: Linux 3.2.0-0.bpo.4-rt-amd64 ohci_hcd
[    3.872077] usb usb4: SerialNumber: 0000:00:13.2
[    3.932077] usb usb5: New USB device found, idVendor=1d6b, idProduct=0001
[    3.932081] usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.932083] usb usb5: Product: OHCI Host Controller
[    3.932085] usb usb5: Manufacturer: Linux 3.2.0-0.bpo.4-rt-amd64 ohci_hcd
[    3.932087] usb usb5: SerialNumber: 0000:00:13.3
[    3.992042] usb 1-1: new high-speed USB device number 2 using ehci_hcd
[    3.992101] usb usb6: New USB device found, idVendor=1d6b, idProduct=0001
[    3.992104] usb usb6: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.992107] usb usb6: Product: OHCI Host Controller
[    3.992109] usb usb6: Manufacturer: Linux 3.2.0-0.bpo.4-rt-amd64 ohci_hcd
[    3.992111] usb usb6: SerialNumber: 0000:00:13.4
[    4.159092] usb 1-1: New USB device found, idVendor=147a, idProduct=e055
[    4.159096] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    4.159099] usb 1-1: Product: USB2.0 High-Speed True HD Audio
[    4.159102] usb 1-1: Manufacturer: CMEDIA
[    4.261845] input: CMEDIA USB2.0 High-Speed True HD Audio as /devices/pci0000:00/0000:00:13.5/usb1/1-1/1-1:1.5/input/input4
[    4.261995] generic-usb 0003:147A:E055.0001: input,hidraw0: USB HID v1.00 Device [CMEDIA USB2.0 High-Speed True HD Audio] on usb-0000:00:13.5-1/input5
[    4.262024] usbcore: registered new interface driver usbhid
[    4.262026] usbhid: USB HID core driver
[    4.448730] usbcore: registered new interface driver snd-usb-audio
[    4.484053] usb 3-1: new low-speed USB device number 2 using ohci_hcd
[    4.651067] usb 3-1: New USB device found, idVendor=046d, idProduct=c058
[    4.651070] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    4.651072] usb 3-1: Product: USB Optical Mouse
[    4.651074] usb 3-1: Manufacturer: Logitech
[    4.658336] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:13.1/usb3/3-1/3-1:1.0/input/input5
[    4.658572] generic-usb 0003:046D:C058.0002: input,hidraw1: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:13.1-1/input0

$ dmesg | grep cannot
[    4.444125] 2:4:1: clock source 25 is not valid, cannot use
[    4.447375] 2:4:2: clock source 25 is not valid, cannot use
[    4.447927] cannot get ctl value: req = 0x83, wValue = 0x201, wIndex = 0x0, type = 4
[    4.447980] cannot get ctl value: req = 0x83, wValue = 0x201, wIndex = 0x0, type = 4
[   96.865959] 2:4:2: clock source 25 is not valid, cannot use
[   96.866976] 2:4:2: clock source 25 is not valid, cannot use
[   98.020249] cannot get ctl value: req = 0x81, wValue = 0x0, wIndex = 0xa00, type = 3
[ 1780.099968] cannot get ctl value: req = 0x81, wValue = 0x0, wIndex = 0xa00, type = 3

Upper error is shown several hundred lines and buries log exhaustively.

$ dpkg -l | grep alsa
ii  alsa-base                            1.0.23+dfsg-2                      ALSA driver configuration files
ii  alsa-oss                             1.0.17-4                           ALSA wrapper for OSS applications
ii  alsa-utils                           1.0.23-3                           Utilities for configuring and using ALSA
ii  libsdl1.2debian-alsa                 1.2.14-6.1                         Simple DirectMedia Layer (with X11 and ALSA options)

$ dpkg -l | grep audio
ii  libaudio2                            1.9.2-4                            Network Audio System - shared libraries
ii  libaudiofile0                        0.2.6-8                            Open-source version of SGI's audiofile library
ii  libcdparanoia0                       3.10.2+debian-9                    audio extraction tool for sampling CDs (library)
ii  libmad0                              0.15.1b-5                          MPEG audio decoder library
ii  libsndfile1                          1.0.21-3+squeeze1                  Library for reading/writing audio files
ii  libwavpack1                          4.60.1-1                           an audio codec (lossy and lossless) - library
ii  pulseaudio                           0.9.21-3+squeeze1                  PulseAudio sound server

$ dpkg -l | grep sound
ii  esound-common                        0.2.41-8                           Enlightened Sound Daemon - Common files
ii  libasound2                           1.0.23-2.1                         shared library for ALSA applications
ii  libasound2-plugins                   1.0.23-1+b1                        ALSA library additional plugins
ii  linux-sound-base                     1.0.23+dfsg-2                      base package for ALSA and OSS sound systems
ii  pulseaudio                           0.9.21-3+squeeze1                  PulseAudio sound server

$ dpkg -l | grep usb
ii  libusb-0.1-4                         2:0.1.12-16                        userspace USB programming library
ii  usbutils                             0.87-5squeeze1                     Linux USB utilities

-- System Information:
Debian Release: 6.0.6
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-0.bpo.4-rt-amd64 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages alsa-utils depends on:
ii  libasound2              1.0.23-2.1       shared library for ALSA applicatio
ii  libc6                   2.11.3-4         Embedded GNU C Library: Shared lib
ii  libncursesw5            5.7+20100313-5   shared libraries for terminal hand
ii  linux-sound-base        1.0.23+dfsg-2    base package for ALSA and OSS soun
ii  lsb-base                3.2-23.2squeeze1 Linux Standard Base 3.2 init scrip
ii  module-init-tools       3.12-2           tools for managing Linux kernel mo
ii  udev                    164-3            /dev/ and hotplug management daemo
ii  whiptail                0.52.11-1        Displays user-friendly dialog boxe

Versions of packages alsa-utils recommends:
ii  alsa-base                  1.0.23+dfsg-2 ALSA driver configuration files
ii  pciutils                   1:3.1.7-6     Linux PCI Utilities

alsa-utils suggests no packages.

-- no debconf information

---

From: Elimar Riesebieter <[email-masked]>
Date: Sat, 26 Jan 2013 08:41:37 +0100

> Hardware is initialized using a guess method

Please update to latest alsa (which is 1.0.25 in Debian). We don't
support 1.0.23 anymore.

Elimar
-- 
  Do you smell something burning or ist it me?