Subject: Bug#698985: [Pkg-alsa-devel] Bug#698985: alsa-utils: alsamixer does not work. Broken pipe.

From: Elimar Riesebieter <[email-masked]>
Date: Sun, 27 Jan 2013 09:49:42 +0100

* Azuki <[email-masked]> [2013-01-26 19:18 -0500]:

> 
> > Please update to latest alsa (which is 1.0.25 in Debian). We don't
> > support 1.0.23 anymore.
> > 
> 
> I updated it to 1.0.25, but got the same errors.
> 
> $ alsamixer
> cannot load mixer controls: Broken pipe
> 
> $ dpkg -l | gre alsa
> ii  alsa-base                            1.0.25+2+nmu2                      ALSA driver configuration files
> ii  alsa-utils                           1.0.25-4                           Utilities for configuring and using ALSA
> ii  libsdl1.2debian-alsa                 1.2.14-6.1                         Simple DirectMedia Layer (with X11 and ALSA options)
> 
> $ cat /proc/asound/cards
> 0 [Audio          ]: USB-Audio - USB2.0 High-Speed True HD Audio
>                       CMEDIA USB2.0 High-Speed True HD Audio at usb-0000:00:13.5-1, high speed
> 
> $ alsactl init 0
> Found hardware: "USB-Audio" "USB Mixer" "USB147a:e055" "" ""
> Hardware is initialized using a generic method

ALSA just runs fine ;-)

[...]
> $ cat /var/log/messages | grep alsa
> pulseaudio[8536]: [pulseaudio] alsa-util.c: Unable to load mixer: Broken pipe
> pulseaudio[10666]: [pulseaudio] alsa-util.c: Unable to load mixer: Broken pipe
> pulseaudio[1550]: [pulseaudio] alsa-util.c: Unable to load mixer: Broken pipe

It seems to be a bug in pulseaudio.....

> $ cat /proc/asound/card0/usbmixer
> USB Mixer: usb_id=0x147ae055, ctrlif=0, ctlerr=0
> Card: CMEDIA USB2.0 High-Speed True HD Audio at usb-0000:00:13.5-1, high speed
>   Unit: 10
>     Control: name="PCM Capture Source", index=0
>     Info: id=10, control=0, cmask=0x0, channels=1, type="U8"
>     Volume: min=1, max=3, dBmin=0, dBmax=0
[...]
> When I used kernel 2.6.32-46, the error of "clock source" was not output.
> I can get the sound with pulseaudio, but cannot control it with alsamixer.

When pulse is running alsamixer is pointless.

You can try to shut down pulse as follows and test again:

$ echo "autospawn=no" >> .pulse/client.conf
$ pulseaudio -k

Elimar
-- 
  Learned men are the cisterns of knowledge,
  not the fountainheads ;-)

---

From: Elimar Riesebieter <[email-masked]>
Date: Sun, 27 Jan 2013 10:04:15 +0100

* Elimar Riesebieter <[email-masked]> [2013-01-27 09:49 +0100]:

[...]> 
> $ echo "autospawn=no" >> .pulse/client.conf

$ echo "autospawn=no" >> $HOME/.pulse/client.conf

Elimar
-- 
  Excellent day for drinking heavily.
  Spike the office water cooler;-)