Subject: Bug#705739: ruby-capybara: please enable Selenium::WebDriver support

From: Jérémy Bobbio <[email-masked]>
Date: Fri, 19 Apr 2013 14:16:11 +0200

Package: ruby-capybara
Version: 2.0.2-1
Severity: wishlist
Control: block -1 by 703492

The `:selenium` driver is currently disabled in the Debian package for
Capybara.

It should be enabled once the `selenium-webdriver` gem is packaged.

-- 
Jérémy Bobbio                        .''`. 
[email-masked]                    : :Ⓐ  :  # apt-get install anarchism
                                    `. `'` 
                                      `-

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Wed, 17 Nov 2021 21:09:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the ruby-capybara package:

#705739: ruby-capybara: please enable Selenium::WebDriver support

It has been closed by Debian FTP Masters <[email-masked]> (reply to Daniel Leidert <[email-masked]>).

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Debian FTP Masters <[email-masked]> (reply to Daniel Leidert <[email-masked]>) by
replying to this email.

-- 
705739: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=705739
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Bug#705739: fixed in ruby-capybara 3.36.0+ds-1
From: Debian FTP Masters <[email-masked]>
To: [email-masked]
Date: Wed, 17 Nov 2021 21:06:19 +0000

Source: ruby-capybara
Source-Version: 3.36.0+ds-1
Done: Daniel Leidert <[email-masked]>

We believe that the bug you reported is fixed in the latest version of
ruby-capybara, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Daniel Leidert <[email-masked]> (supplier of updated ruby-capybara package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Wed, 17 Nov 2021 21:29:03 +0100
Source: ruby-capybara
Architecture: source
Version: 3.36.0+ds-1
Distribution: unstable
Urgency: medium
Maintainer: Debian Ruby Team <[email-masked]>
Changed-By: Daniel Leidert <[email-masked]>
Closes: 705739 996147
Changes:
 ruby-capybara (3.36.0+ds-1) unstable; urgency=medium
 .
   * Team upload.
   * New upstream version 3.36.0.
     - Fixes keyword argument handling (closes: #996147).
 .
   [ Utkarsh Gupta ]
   * Refresh patches
   * Add Selenium::WebDriver BD dependency (closes: #705739).
   * Add myself as the uploader
   * Fix package wrt cme
   * Drop dependency on ruby-interpreter
   * Add salsa-ci.yml
 .
   [ Daniel Leidert ]
   * d/control: Add Rules-Requires-Root field.
     (Standards-Version): Bump to 4.6.0.
   * d/copyright: Exclude jquery files from the tarball. Add Upstream-Contact.
     (Copyright): Add team.
   * d/ruby-capybara.links: Remove file. Must be handled in d/rules.
   * d/ruby-capybara.lintian-overrides: Adjust override.
   * d/ruby-tests.rake: Update with gem2deb template.
   * d/rules: Use gem installation layout. Ignore the test result with Ruby 3.0.
     The tests explicitly mention to not have been tested with Ruby 3, but we
     require this version of capybara urgently.
     (override_dh_link): Add override to create jquery links.
   * d/watch: Handle repackaging.
   * d/README.Debian: Remove file. Does not apply anymore.
   * d/README.source: Adjust hint.
   * d/patches/0001-Remove-support-for-the-selenium-driver.patch: Remove patch.
     The ruby-selenium-driver package is available.
   * d/patches/0002-Inhibit-tests-for-the-selenium-driver.patch: Ditto.
   * d/patches/0003-Inhibit-tests-that-needs-more-than-one-driver.patch: Ditto.
   * d/patches/0004-Inhibit-test-for-SSL.patch: Update patch and
     rename to d/patches/inhibit-test-for-SSL.patch.
   * d/patches/fix-rack-version-nomethoderror.patch: Add patch.
     - Prevent a NoMethodError when trying to determine the rack gem version.
   * d/patches/remove-jquery-from-gemspec.patch: Add patch.
     - Remove references to jquery files stripped from the source.
   * d/patches/dont-require-selenium-statistics.patch: Add patch.
     - Remove selenium_statistics usage as long as it is not packaged.
   * d/patches/fix-rspec-before-block.patch: Add patch.
     - Fix a problem with the before block not being executed.
   * d/patches/series: Adjust file.
   * d/upstream/metadata: Add metadata.
Checksums-Sha1:
 6c248138e3a4115f992e2ae1f01ce5a4e772d542 2369 ruby-capybara_3.36.0+ds-1.dsc
 eab2409572cc64872a6cdcdce575365da1b8db01 217760 ruby-capybara_3.36.0+ds.orig.tar.xz
 bf17361e30b21ccdb510279fb2c2568d52fc006b 7940 ruby-capybara_3.36.0+ds-1.debian.tar.xz
 136b188bcb4ca788596998fd8390c0a1da039430 10451 ruby-capybara_3.36.0+ds-1_amd64.buildinfo
Checksums-Sha256:
 47b37866153e47db97f1da271043cb7cc5f7f4d840640c944f0a621ae986b184 2369 ruby-capybara_3.36.0+ds-1.dsc
 0ea29b7a9b5232d696ec7b74ddab868e4cf92654e767ddb1369a00f656369f8d 217760 ruby-capybara_3.36.0+ds.orig.tar.xz
 9e1861b7365b9b71fef2a694063e417129e0a5dd820f9118240f782bdb3ead67 7940 ruby-capybara_3.36.0+ds-1.debian.tar.xz
 a588f5971dc44e7e037926970bd81e62332e3a189bdee6ca857b75438397c3ab 10451 ruby-capybara_3.36.0+ds-1_amd64.buildinfo
Files:
 f8095b71f19071d55eaa405aee53f9b1 2369 ruby optional ruby-capybara_3.36.0+ds-1.dsc
 60f5745c2241b21212b8a22677fe5bcc 217760 ruby optional ruby-capybara_3.36.0+ds.orig.tar.xz
 3c003ebb36b9497674feca464832efb8 7940 ruby optional ruby-capybara_3.36.0+ds-1.debian.tar.xz
 58aa9a1979985d5d6abc6eba3a21e6b4 10451 ruby optional ruby-capybara_3.36.0+ds-1_amd64.buildinfo

Subject: ruby-capybara: please enable Selenium::WebDriver support
From: Jérémy Bobbio <[email-masked]>
To: [email-masked]
Date: Fri, 19 Apr 2013 14:16:11 +0200

Package: ruby-capybara
Version: 2.0.2-1
Severity: wishlist