Subject: alsa-utils: No sound after fresh install

From: Marc <[email-masked]>
Date: Wed, 29 May 2013 10:11:37 +0200

Package: alsa-utils
Version: 1.0.23-3
Severity: wishlist

It happen on several computers with Wheezy.
alsa-utils 1.0.25-4
All work fine after:
# alsactl init 0
(As /proc/asound/cards reported my sound card was id 0)
Maybe it's possible to add a initialization line in the
postinst script ?
Maybe not, because we need to know the sound card id.
Thanks&Regards,
Marc

-- System Information:
Debian Release: 6.0.7
  APT prefers oldstable
  APT policy: (910, 'oldstable'), (500, 'oldstable-proposed-updates')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_CH.UTF-8, LC_CTYPE=fr_CH.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages alsa-utils depends on:
ii  libasound2              1.0.23-2.1       shared library for ALSA applicatio
ii  libc6                   2.11.3-4         Embedded GNU C Library: Shared lib
ii  libncursesw5            5.7+20100313-5   shared libraries for terminal hand
ii  linux-sound-base        1.0.23+dfsg-2    base package for ALSA and OSS soun
ii  lsb-base                3.2-23.2squeeze1 Linux Standard Base 3.2 init scrip
ii  module-init-tools       3.12-2           tools for managing Linux kernel mo
ii  udev                    164-3            /dev/ and hotplug management daemo
ii  whiptail                0.52.11-1        Displays user-friendly dialog boxe

Versions of packages alsa-utils recommends:
ii  alsa-base                  1.0.23+dfsg-2 ALSA driver configuration files
ii  pciutils                   1:3.1.7-6     Linux PCI Utilities

alsa-utils suggests no packages.

-- no debconf information

---

From: Judicael Courant <[email-masked]>
Date: Sat, 02 Jan 2016 13:04:38 +0100

Package: alsa-utils
Version: 1.0.28-1
Followup-For: Bug #710221

Dear Maintainer,

I second Marc's <[email-masked]> wish: I painfully experienced the same
problem with Jessie. I spent three hours reading (random) docs to
understand why I had no sound and trying various configuration tricks
until I figured a simple 'alsactl init' would solve my problem

I updated some pages on the wiki to help other users, however if you
could add a line 'alsactl init' to the postinst script, that would be
greatly appreciated.

(BTW, no need for a card id: 'alsactl init' is supposed to initialize
all devices according to the man page.)

Thanks!

J. Courant.

-- System Information:
Debian Release: 8.2
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages alsa-utils depends on:
ii  kmod            18-3
ii  libasound2      1.0.28-1
ii  libc6           2.19-18+deb8u1
ii  libncursesw5    5.9+20140913-1+b1
ii  libsamplerate0  0.1.8-8
ii  libtinfo5       5.9+20140913-1+b1
ii  lsb-base        4.1+Debian13+nmu1
ii  whiptail        0.52.17-1+b1

alsa-utils recommends no packages.