Subject: Bug#721014: backupninja: Allow to configure debug mode in config file

From: Olivier Berger <[email-masked]>
Date: Tue, 27 Aug 2013 09:58:17 +0200

Package: backupninja
Version: 1.0.1-1
Severity: wishlist
Tags: upstream

Hi.

It would be great to be able to disable the debug option to be able to set debug off in a particular conf file, set with -f, so that backupninja --run doesn't produce debug details on stderr.

This would allow running backupninja through anacron for instance.

All that is required is that there's a getconf debug after the setfile, to disable the debug set when parsing option --run.

I may provide a patch if this isn't clear.

Hope this helps.

Best regards,

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (900, 'testing')
Architecture: i386 (i686)

Kernel: Linux 3.10-2-686-pae (SMP w/2 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages backupninja depends on:
ii  bash               4.2+dfsg-1
ii  bsd-mailx [mailx]  8.1.2-0.20111106cvs-1
ii  dialog             1.2-20130523-1
ii  gawk               1:4.0.1+dfsg-2.1
ii  mawk               1.3.3-17

backupninja recommends no packages.

Versions of packages backupninja suggests:
ii  bzip2          1.0.6-5
ii  debconf-utils  1.5.50
ii  duplicity      0.6.21-3
ii  genisoimage    9:1.1.11-2
ii  hwinfo         16.0-2.2
ii  mdadm          3.2.5-5
ii  rdiff-backup   1.2.8-7
ii  rsync          3.0.9-4
ii  subversion     1.6.17dfsg-4.1
pn  trickle        <none>
ii  wodim          9:1.1.11-2

-- debconf-show failed

---

From: Olivier Berger <[email-masked]>
Date: Tue, 27 Aug 2013 10:28:15 +0200

> This would allow running backupninja through anacron for instance.

See #420534 for such an example of the need for this.

Best regards,
-- 
Olivier BERGER 
http://www-public.telecom-sudparis.eu/~berger_o/ - OpenPGP-Id: 2048R/5819D7E8
Ingenieur Recherche - Dept INF
Institut Mines-Telecom, Telecom SudParis, Evry (France)

---

From: intrigeri <[email-masked]>
Date: Tue, 03 Sep 2013 13:04:18 +0200

Hi,

Olivier Berger wrote (27 Aug 2013 07:58:17 GMT) :
> It would be great to be able to disable the debug option to be able to set debug off
> in a particular conf file, set with -f, so that backupninja --run doesn't produce
> debug details on stderr.

> the debug set when parsing option --run.

How about supporting --no-debug instead, that would override the --run
defaults mangling?

---

From: Olivier Berger <[email-masked]>
Date: Tue, 03 Sep 2013 14:19:13 +0200

Hi.

> How about supporting --no-debug instead, that would override the --run

That's an option too, of course :-)

Thanks for your interest.

Best regards,