Subject: xwiimote: xwiikeymap often fails to connect to new wiimotes

From: Matthew Gabeler-Lee <[email-masked]>
Date: Thu, 26 Dec 2013 01:54:22 -0500

Package: xwiimote
Version: 0.3+20120630-5+b1
Severity: normal

The xwiikeymap tool attempts to configure new wiimotes as they connect, but
it has a glitch.  tools/xwiikeymap.c line 218 has a short sleep after a new
device appears, but this sleep is too short.  Extending it from 10ms to
100ms works for me.

Upstream seems to have abandoned xwiikeymap (it is no longer in the github
repo), in favor of the xorg input driver, which I see has an ITP for debian,
but no package yet yet.

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.11-2-amd64 (SMP w/12 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages xwiimote depends on:
ii  libc6         2.17-97
ii  libncurses5   5.9+20130608-1
ii  libtinfo5     5.9+20130608-1
ii  libxwiimote1  0.3+20120630-5+b1

xwiimote recommends no packages.

xwiimote suggests no packages.

-- no debconf information

---

From: Nobuhiro Iwamatsu <[email-masked]>
Date: Mon, 21 Apr 2014 10:05:42 +0900

Hi,

> device appears, but this sleep is too short.  Extending it from 10ms to

I just upload new xwiimote to experimental (not install yet).
Could you check with this version? I have only old Wiimote.
xwiimote-2 is in experimental, but we can use this in unstable.

> repo), in favor of the xorg input driver, which I see has an ITP for debian,

I see. xwiikeymap removed by upstream developer. Because xorg input driver is
used instead of xwiikeymap.
About  xorg input driver, I will talk with ITPer (#707781).

Best regards,
  Nobuhiro

-- 
Nobuhiro Iwamatsu
   iwamatsu at {nigauri.org / debian.org}
   GPG ID: 40AD1FA6

---

From: Matthew Gabeler-Lee <[email-masked]>
Date: Tue, 29 Jul 2014 22:55:57 -0400 (EDT)

> xwiimote-2 is in experimental, but we can use this in unstable.

Well, I never got around to testing this (found a better wireless input 
device for my needs), and now the new version is uploaded which doesn't 
have xwiikeymap, so I think this bug can be closed.

-- 
 	-Matt
"Reality is that which, when you stop believing in it, doesn't go away".
                 -- Philip K. Dick
GPG pubkey fingerprint: A57F B354 FD30 A502 795B 9637 3EF1 3F22 A85E 2AD1