Subject: Me too!

From: Dima Kogan <[email-masked]>
Date: Wed, 05 Nov 2014 14:52:21 -0800

Hi. I have the same issue. Alex, do you have any more insight into
getting this working? I can see that the mouse motions are indeed
represented in a reasonable way in the file (I can plot the paths, and
they look right), but the playback just goes to the origin and stays
there, like you say

---

From: Dima Kogan <[email-masked]>
Date: Wed, 05 Nov 2014 15:02:16 -0800

I found a workaround: record normally, but replay with
--force-core-replay. I haven't looked deeply into why this works. The
recorded file has events from the 'Virtual core pointer' and from the
'Synaptics Touchpad'. Removing one or the other doesn't fix it, but
passing that option does.

---

From: Dima Kogan <[email-masked]>
Date: Thu, 06 Nov 2014 12:57:12 -0800

Henrik Sandklef <[email-masked]> writes:

> I am currently not on my Debian laptop, but I can say that it works
> fine on my Ubuntu 14.10.
>
> Can you give me your xserver version?
>  ... typically do:  xdpyinfo | head -10

dima@shorty:~$ xdpyinfo| head -n 10

name of display:    :0.0
version number:    11.0
vendor string:    The X.Org Foundation
vendor release number:    11600000
X.Org version: 1.16.0
maximum request size:  16777212 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    7
dima@shorty:~$ dpkg -l xorg
dpkg-query: no packages found matching xorg

dima@shorty:~$ dpkg -l xserver-xorg

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                   Version          Architecture     Description
+++-======================-================-================-==================================================
ii  xserver-xorg           1:7.7+7          amd64            X.Org X server

---

From: Henrik Sandklef <[email-masked]>
Date: Thu, 6 Nov 2014 21:54:56 +0100

/h

My X server is:
 version number:    11.0

---

From: Henrik Sandklef <[email-masked]>
Date: Thu, 6 Nov 2014 22:24:05 +0100

Thanks, that was quick. Hmmm, same X as here.

How about your input devices, can you list them?
  You can use xinput (with no args).

Also I would like to check your recorded Xnee file, 

  Cut paste from this command: cnee --record --events-to-record 10 --mouse --keyboard 

  Move your mouse a bit and Xnee will stop recording.

/h

---

From: Dima Kogan <[email-masked]>
Date: Thu, 06 Nov 2014 13:27:58 -0800

>   You can use xinput (with no args).

Hi. I'm attaching a recorded file that has some mouse motion. I start in
one corner, then move to the middle and trace out a star. You can see
the path with this:

 awk -F, '$2==6 {print $3,$4}' /tmp/xnee.xns | feedgnuplot --lines --points --domain

On my box, replaying with

 cnee --force-core-replay --replay -f /tmp/xnee.xns

works, but omitting the --force-core-replay has the behavior described
earlier: cursor moves to the top-left and insists on staying there.

xinput output:

  ⎡ Virtual core pointer                          id=2    [master pointer  (3)]
  ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
  ⎜   ↳ Synaptics Touchpad                        id=7    [slave  pointer  (2)]
  ⎜   ↳ trackpoint                                id=8    [slave  pointer  (2)]
  ⎜   ↳ Logitech USB Receiver                     id=16   [slave  pointer  (2)]
  ⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
      ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
      ↳ Generic Keyboard                          id=6    [slave  keyboard (3)]
      ↳ Power Button                              id=9    [slave  keyboard (3)]
      ↳ Video Bus                                 id=10   [slave  keyboard (3)]
      ↳ Sleep Button                              id=11   [slave  keyboard (3)]
      ↳ ThinkPad Extra Buttons                    id=12   [slave  keyboard (3)]
      ↳ ACPI Virtual Keyboard Device              id=13   [slave  keyboard (3)]
      ↳   USB Keyboard                            id=14   [slave  keyboard (3)]
      ↳   USB Keyboard                            id=15   [slave  keyboard (3)]
      ↳ Logitech USB Receiver                     id=17   [slave  keyboard (3)]

I have an /etc/X11/xorg.conf. Relevant pieces:

    Section "ServerLayout"
            Identifier     "Default Layout"
            InputDevice    "Generic Keyboard"
            InputDevice    "Synaptics Touchpad"
            InputDevice    "trackpoint"
    EndSection

    Section "InputDevice"
            Identifier  "trackpoint"
            Option      "Device" "/dev/input/by-path/platform-i8042-serio-2-event-mouse"
            Driver      "evdev"
            Option      "Protocol" "ImPS/2"
            Option      "Emulate3Buttons" "false"
            Option      "EmulateWheel" "true"
            Option      "EmulateWheelTimeOut" "0"
            Option      "EmulateWheelButton" "0"
            Option      "EmulateWheelInertia" "10"
            Option      "XAxisMapping" "6 7"
            Option      "ZAxisMapping" "4 5"
            Option      "YAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
            Identifier  "Synaptics Touchpad"
            Driver      "synaptics"
            Option      "Device" "/dev/input/by-path/platform-i8042-serio-1-event-mouse"
            Option      "HorizScrollDelta" "60"
            Option      "HorizEdgeScroll" "1"
            Option      "VertEdgeScroll"  "1"
            Option      "EmulateMidButtonTime" "0"
            Option      "VertTwoFingerScroll" "0"
            Option      "SHMConfig" "on"
            Option      "RTCornerButton" "4"
            Option      "RBCornerButton" "5"
            Option      "LTCornerButton" "0"
            Option      "LBCornerButton" "0"
            Option      "TapButton1" "1"
            Option      "TapButton2" "0"
            Option      "TapButton3" "0"
            Option      "Emulate3Buttons" "0"
            Option      "MinSpeed" "0.3"
            Option      "MaxSpeed" "0.4"
            Option      "AccelFactor" "0.5"
    EndSection

None of that looks particularly noteworthy to me, but I'm no expert.

---

From: Henrik Sandklef <[email-masked]>
Date: Tue, 11 Nov 2014 00:05:22 +0100

Can you run the same command you had problem with:

  cnee --record --mouse -o /tmp/xnee.xns --first-last --smp

and use a mouse instead of the Touchpad. This is really not likely the
cause, but I would like to make sure.

/h

---

From: Dima Kogan <[email-masked]>
Date: Mon, 10 Nov 2014 15:13:22 -0800

> cause, but I would like to make sure.

That's it!

Currently my laptop is on a docking station, so both a touchpad and a
USB mouse are available. Recording events from the USB mouse works just
fine, but recording events from the touchpad requires
--force-core-replay, as described previously. This is both with the
stock xnee and with the one you sent a few days ago. I'm attaching 4
xnee recordings, showing all combinations of (USB,touchpad) and (debian
cnee,patched cnee).

---

From: [email-masked]
Date: Tue, 11 Nov 2014 19:55:18 +0100

OK. Thanks a lot.

 I will try to resolve it. Probably boils down to me - think there's a bug when replaying an enumerated device recorded with a different device number...... Cant remember how I decided to solve it. Woops :(

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

---

From: Henrik Sandklef <[email-masked]>
Date: Fri, 14 Nov 2014 09:55:18 +0100

Great...I think, but I am confused (well, I guess I've always been). 

Can you send over a log when running a replay session.
* Use the debian xnee
* Use the touchpad
* Replay (something) like this:
    cnee --replay --file  xnee_debian_touchpad.xns  --verbose -e touchpadd.err
  the important thind is to use the --verbose option

/h

---

From: Dima Kogan <[email-masked]>
Date: Fri, 14 Nov 2014 10:00:30 -0800

>   the important thind is to use the --verbose option

OK. I played back a touchpad recording, so the pointer went to the
corner. The err log is attached. The console also spit out the
following. Thanks a lot.

dima@shorty:~$ cnee --replay --file /tmp/xnee_debian_touchpad.xns  --verbose -e touchpadd.err                    
 ---> xnee_find_option_entry_impl
      xnee_find_option_entry_impl: "-e"
        Compare 'file'  'e'
        Compare 'help'  'e'
        Compare 'flags'  'e'
        Compare 'project'  'e'
        Compare 'version'  'e'
        Compare 'retype-file'  'e'
        Compare 'write-settings'  'e'
        Compare 'print-settings'  'e'
        Compare 'print-event-names'  'e'
        Compare 'print-event-name'  'e'
        Compare 'print-error-names'  'e'
        Compare 'print-error-name'  'e'
        Compare 'print-reply-names'  'e'
        Compare 'print-request-names'  'e'
        Compare 'print-request-name'  'e'
        Compare 'keyboard'  'e'
        Compare 'mouse'  'e'
        Compare 'print-data-names'  'e'
        Compare 'manpage'  'e'
        Compare 'texipage'  'e'
        Compare 'type-help'  'e'
        Compare 'demonstration'  'e'
        Compare 'check-syntax'  'e'
        Compare 'get-xinput-event-base'  'e'
        Compare 'disable-xinput-events'  'e'
        Compare 'replay-backend'  'e'
        Compare 'force-core-replay'  'e'
        Compare 'record-replay'  'e'
 <--- xnee_find_option_entry_impl
 ---> xnee_find_option_entry_impl
      xnee_find_option_entry_impl: "-e"
        Compare 'err-file'  'e'
** Found key: 1   for option e at 0 in option array  (err-file)
Found xns entry for '-e' 'touchpadd.err' at position: 0
        long option: 'err-file'
        short option:'e'
xnee_resource.c:1168-->xnee_parse_option_impl() Handling: 'XNEE_ERR_FILE_KEY' 
--> xnee_prepare
---> xnee_open_files
---  xnee_open_files: handling err
---  xnee_open_files: opening err: touchpadd.err
Workaround: Creating context on data display instead of control 
            You can ignore this message
Workaround: Creating context on data display instead of control 
            You can ignore this message
NOTIFICATION: If you have problem with Xnee and recording device events: File a bug report including this text.
NOTIFICATION: If you have problem with Xnee and recording device events: File a bug report including this text.
NOTIFICATION: If you have problem with Xnee and recording device events: File a bug report including this text.
Workaround: Creating context on data display instead of control 
            You can ignore this message
####################################
#         System information       #
####################################
# Date:                   2014:11:14 
# Time:                   10:00:17 
# Xnee program:           cnee 
# Xnee version:           3.19 
# Xnee home:              http://www.gnu.org/software/xnee/ 
# Xnee info mailing list: [email-masked] 
# Xnee bug mailing list:  [email-masked] 
# X version:              11 
# X revision:             0 
# X vendor:               The X.Org Foundation 
# X vendor release:       11600000 
# Record version major:   1
# Record version minor:   13
# OS name:                Linux 
# OS Release:             3.16-3-amd64 
# OS Version:             #1 SMP Debian 3.16.5-1 (2014-10-10) 
# Machine:                x86_64 
# Nodename:               shorty 
# Display name:           :0.0
# Dimension:              1400x1050
Workaround: Creating context on data display instead of control 
            You can ignore this message

---

From: Henrik Sandklef <[email-masked]>
Date: Sun, 16 Nov 2014 12:07:19 +0100

Sorry, more work for you :(

Can you take the recorded file (xnee_debian_touchpad.xns) and replace
(device number) 16 with 7. Typically;

  cat xnee_debian_touchpad.xns | sed 's/,16,/,7,/g' > xnee_debian_touchpad-mod.xns

and replay the same way:

 * Use the debian xnee
 * Use the touchpad

     cnee  -e touchpadd.mod.err --replay --file  xnee_debian_touchpad-mod.xns  --verbose

/h

---

From: Dima Kogan <[email-masked]>
Date: Sun, 16 Nov 2014 11:07:30 -0800

> Sorry, more work for you :(

No problem at all

>   cat xnee_debian_touchpad.xns | sed 's/,16,/,7,/g' > xnee_debian_touchpad-mod.xns

Hmmm. That file has no match for ,16, so that sed command does nothing.
Did you mean a different log file or a different device?