Subject: gnome-shell not starting with gdm3/mesa/llvm-3.4 but does start from startx & lightdm regardless

From: Philip Hands <[email-masked]>
Date: Sun, 15 Mar 2015 09:03:18 +0000

Package: libgl1-mesa-dri
Version: 10.3.2-1~hands.1
Followup-For: Bug #775235

Just installed jessie on a Dell Latitude D505 and got the symptoms
described here (getting the "Oops" screen from attempting to log in via
gdm3, and seeing the underrun errors in the logs)

Tried rebuilding mesa with llvm-3.4 (hence the ~hands.1 version) but that
did not help.  I suppose it's possible that I somehow failed to build
the packages, but this is a clean machine, it doesn't have llvm-3.5
installed, and I just ran debuild after installing packages until the
build-depends were satisfied.

Anyway, doing this did not solve the problem.

However, I note that even with the standard packages it was possible to
get Gnome running via startx from the text console.  I also note that
installing lightdm and running from there solves the problem (only tested
with my recompiled mesa packages, but since they are exhibiting the bug
I'd guess that would also be true for the standard packages -- I'm about
to reinstall this machine so I can confirm that later if necessary)

So, in my case this bug seems to be something specific about the way
that gdm3 runs things, since other things manage to start Gnome.

Hints about where gdm3 might be logging what happened would be useful.

-- Package-specific info:
glxinfo:
--------
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_fbconfig_float, GLX_ARB_framebuffer_sRGB, GLX_ARB_multisample, 
    GLX_EXT_create_context_es2_profile, GLX_EXT_framebuffer_sRGB, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, 
    GLX_OML_swap_method, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, GLX_SGI_swap_control
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float, 
    GLX_ARB_framebuffer_sRGB, GLX_ARB_get_proc_address, GLX_ARB_multisample, 
    GLX_EXT_buffer_age, GLX_EXT_create_context_es2_profile, 
    GLX_EXT_fbconfig_packed_float, GLX_EXT_framebuffer_sRGB, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_swap_control, GLX_OML_swap_method, GLX_OML_sync_control, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
    GLX_SGIX_visual_select_group, GLX_SGI_make_current_read, 
    GLX_SGI_swap_control, GLX_SGI_video_sync
GLX version: 1.4
GLX extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_fbconfig_float, GLX_ARB_framebuffer_sRGB, 
    GLX_ARB_get_proc_address, GLX_ARB_multisample, 
    GLX_EXT_create_context_es2_profile, GLX_EXT_framebuffer_sRGB, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_OML_swap_method, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, GLX_SGI_make_current_read
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.3.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
    GL_AMD_conservative_depth, GL_AMD_draw_buffers_blend, 
    GL_AMD_seamless_cubemap_per_texture, GL_AMD_shader_trinary_minmax, 
    GL_ANGLE_texture_compression_dxt3, GL_ANGLE_texture_compression_dxt5, 
    GL_ARB_ES2_compatibility, GL_ARB_ES3_compatibility, 
    GL_ARB_blend_func_extended, GL_ARB_clear_buffer_object, 
    GL_ARB_compressed_texture_pixel_storage, 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_ARB_copy_buffer, GL_ARB_debug_output, GL_ARB_depth_buffer_float, 
    GL_ARB_depth_clamp, GL_ARB_draw_buffers, GL_ARB_draw_buffers_blend, 
    GL_ARB_draw_elements_base_vertex, GL_ARB_draw_indirect, 
    GL_ARB_draw_instanced, GL_ARB_explicit_attrib_location, 
    GL_ARB_explicit_uniform_location, GL_ARB_fragment_coord_conventions, 
    GL_ARB_fragment_layer_viewport, GL_ARB_fragment_shader, 
    GL_ARB_framebuffer_object, GL_ARB_framebuffer_sRGB, 
    GL_ARB_get_program_binary, GL_ARB_half_float_pixel, 
    GL_ARB_half_float_vertex, GL_ARB_instanced_arrays, 
    GL_ARB_internalformat_query, GL_ARB_invalidate_subdata, 
    GL_ARB_map_buffer_alignment, GL_ARB_map_buffer_range, GL_ARB_multi_bind, 
    GL_ARB_multi_draw_indirect, GL_ARB_occlusion_query2, 
    GL_ARB_pixel_buffer_object, GL_ARB_point_sprite, GL_ARB_provoking_vertex, 
    GL_ARB_robustness, GL_ARB_sampler_objects, GL_ARB_seamless_cube_map, 
    GL_ARB_seamless_cubemap_per_texture, GL_ARB_separate_shader_objects, 
    GL_ARB_shader_bit_encoding, GL_ARB_shader_objects, 
    GL_ARB_shader_texture_lod, GL_ARB_shading_language_420pack, 
    GL_ARB_shading_language_packing, GL_ARB_stencil_texturing, GL_ARB_sync, 
    GL_ARB_texture_buffer_object, GL_ARB_texture_buffer_object_rgb32, 
    GL_ARB_texture_buffer_range, GL_ARB_texture_compression_rgtc, 
    GL_ARB_texture_float, GL_ARB_texture_mirror_clamp_to_edge, 
    GL_ARB_texture_multisample, GL_ARB_texture_non_power_of_two, 
    GL_ARB_texture_query_levels, GL_ARB_texture_rectangle, GL_ARB_texture_rg, 
    GL_ARB_texture_rgb10_a2ui, GL_ARB_texture_storage, 
    GL_ARB_texture_storage_multisample, GL_ARB_texture_swizzle, 
    GL_ARB_timer_query, GL_ARB_transform_feedback2, 
    GL_ARB_transform_feedback3, GL_ARB_transform_feedback_instanced, 
    GL_ARB_uniform_buffer_object, GL_ARB_vertex_array_bgra, 
    GL_ARB_vertex_array_object, GL_ARB_vertex_attrib_binding, 
    GL_ARB_vertex_shader, GL_ARB_vertex_type_10f_11f_11f_rev, 
    GL_ARB_vertex_type_2_10_10_10_rev, GL_ARB_viewport_array, 
    GL_ATI_blend_equation_separate, GL_ATI_texture_compression_3dc, 
    GL_ATI_texture_float, GL_ATI_texture_mirror_once, GL_EXT_abgr, 
    GL_EXT_blend_equation_separate, GL_EXT_draw_buffers2, 
    GL_EXT_draw_instanced, GL_EXT_framebuffer_blit, 
    GL_EXT_framebuffer_multisample, GL_EXT_framebuffer_multisample_blit_scaled, 
    GL_EXT_framebuffer_sRGB, GL_EXT_packed_depth_stencil, GL_EXT_packed_float, 
    GL_EXT_pixel_buffer_object, GL_EXT_provoking_vertex, 
    GL_EXT_shader_integer_mix, GL_EXT_texture_array, 
    GL_EXT_texture_compression_dxt1, GL_EXT_texture_compression_latc, 
    GL_EXT_texture_compression_rgtc, GL_EXT_texture_compression_s3tc, 
    GL_EXT_texture_integer, GL_EXT_texture_mirror_clamp, GL_EXT_texture_sRGB, 
    GL_EXT_texture_sRGB_decode, GL_EXT_texture_shared_exponent, 
    GL_EXT_texture_snorm, GL_EXT_texture_swizzle, GL_EXT_timer_query, 
    GL_EXT_transform_feedback, GL_EXT_vertex_array_bgra, 
    GL_IBM_multimode_draw_arrays, GL_KHR_debug, GL_MESA_pack_invert, 
    GL_MESA_texture_signed_rgba, GL_MESA_ycbcr_texture, 
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil, 
    GL_OES_EGL_image, GL_OES_read_format, GL_S3_s3tc

OpenGL version string: 3.0 Mesa 10.3.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
    GL_AMD_conservative_depth, GL_AMD_draw_buffers_blend, 
    GL_AMD_seamless_cubemap_per_texture, GL_AMD_shader_trinary_minmax, 
    GL_ANGLE_texture_compression_dxt3, GL_ANGLE_texture_compression_dxt5, 
    GL_APPLE_packed_pixels, GL_APPLE_vertex_array_object, 
    GL_ARB_ES2_compatibility, GL_ARB_ES3_compatibility, 
    GL_ARB_blend_func_extended, GL_ARB_clear_buffer_object, 
    GL_ARB_color_buffer_float, GL_ARB_compressed_texture_pixel_storage, 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_ARB_copy_buffer, GL_ARB_debug_output, GL_ARB_depth_buffer_float, 
    GL_ARB_depth_clamp, GL_ARB_depth_texture, GL_ARB_draw_buffers, 
    GL_ARB_draw_buffers_blend, GL_ARB_draw_elements_base_vertex, 
    GL_ARB_draw_instanced, GL_ARB_explicit_attrib_location, 
    GL_ARB_explicit_uniform_location, GL_ARB_fragment_coord_conventions, 
    GL_ARB_fragment_program, GL_ARB_fragment_program_shadow, 
    GL_ARB_fragment_shader, GL_ARB_framebuffer_object, 
    GL_ARB_framebuffer_sRGB, GL_ARB_get_program_binary, 
    GL_ARB_half_float_pixel, GL_ARB_half_float_vertex, 
    GL_ARB_instanced_arrays, GL_ARB_internalformat_query, 
    GL_ARB_invalidate_subdata, GL_ARB_map_buffer_alignment, 
    GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multisample, 
    GL_ARB_multitexture, GL_ARB_occlusion_query, GL_ARB_occlusion_query2, 
    GL_ARB_pixel_buffer_object, GL_ARB_point_parameters, GL_ARB_point_sprite, 
    GL_ARB_provoking_vertex, GL_ARB_robustness, GL_ARB_sampler_objects, 
    GL_ARB_seamless_cube_map, GL_ARB_seamless_cubemap_per_texture, 
    GL_ARB_separate_shader_objects, GL_ARB_shader_bit_encoding, 
    GL_ARB_shader_objects, GL_ARB_shader_texture_lod, 
    GL_ARB_shading_language_100, GL_ARB_shading_language_420pack, 
    GL_ARB_shading_language_packing, GL_ARB_shadow, GL_ARB_stencil_texturing, 
    GL_ARB_sync, GL_ARB_texture_border_clamp, GL_ARB_texture_compression, 
    GL_ARB_texture_compression_rgtc, GL_ARB_texture_cube_map, 
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine, 
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3, 
    GL_ARB_texture_float, GL_ARB_texture_mirror_clamp_to_edge, 
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_multisample, 
    GL_ARB_texture_non_power_of_two, GL_ARB_texture_query_levels, 
    GL_ARB_texture_rectangle, GL_ARB_texture_rg, GL_ARB_texture_rgb10_a2ui, 
    GL_ARB_texture_storage, GL_ARB_texture_storage_multisample, 
    GL_ARB_texture_swizzle, GL_ARB_timer_query, GL_ARB_transform_feedback2, 
    GL_ARB_transform_feedback3, GL_ARB_transform_feedback_instanced, 
    GL_ARB_transpose_matrix, GL_ARB_uniform_buffer_object, 
    GL_ARB_vertex_array_bgra, GL_ARB_vertex_array_object, 
    GL_ARB_vertex_attrib_binding, GL_ARB_vertex_buffer_object, 
    GL_ARB_vertex_program, GL_ARB_vertex_shader, 
    GL_ARB_vertex_type_10f_11f_11f_rev, GL_ARB_vertex_type_2_10_10_10_rev, 
    GL_ARB_window_pos, GL_ATI_blend_equation_separate, GL_ATI_draw_buffers, 
    GL_ATI_separate_stencil, GL_ATI_texture_compression_3dc, 
    GL_ATI_texture_env_combine3, GL_ATI_texture_float, 
    GL_ATI_texture_mirror_once, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, 
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate, 
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_compiled_vertex_array, 
    GL_EXT_copy_texture, GL_EXT_draw_buffers2, GL_EXT_draw_instanced, 
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_blit, 
    GL_EXT_framebuffer_multisample, GL_EXT_framebuffer_multisample_blit_scaled, 
    GL_EXT_framebuffer_object, GL_EXT_framebuffer_sRGB, 
    GL_EXT_gpu_program_parameters, GL_EXT_multi_draw_arrays, 
    GL_EXT_packed_depth_stencil, GL_EXT_packed_float, GL_EXT_packed_pixels, 
    GL_EXT_pixel_buffer_object, GL_EXT_point_parameters, 
    GL_EXT_polygon_offset, GL_EXT_provoking_vertex, GL_EXT_rescale_normal, 
    GL_EXT_secondary_color, GL_EXT_separate_specular_color, 
    GL_EXT_shader_integer_mix, GL_EXT_shadow_funcs, GL_EXT_stencil_two_side, 
    GL_EXT_stencil_wrap, GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D, 
    GL_EXT_texture_array, GL_EXT_texture_compression_dxt1, 
    GL_EXT_texture_compression_latc, GL_EXT_texture_compression_rgtc, 
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map, 
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add, 
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, 
    GL_EXT_texture_integer, GL_EXT_texture_lod_bias, 
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object, 
    GL_EXT_texture_rectangle, GL_EXT_texture_sRGB, GL_EXT_texture_sRGB_decode, 
    GL_EXT_texture_shared_exponent, GL_EXT_texture_snorm, 
    GL_EXT_texture_swizzle, GL_EXT_timer_query, GL_EXT_transform_feedback, 
    GL_EXT_vertex_array, GL_EXT_vertex_array_bgra, 
    GL_IBM_multimode_draw_arrays, GL_IBM_rasterpos_clip, 
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate, GL_KHR_debug, 
    GL_MESA_pack_invert, GL_MESA_texture_signed_rgba, GL_MESA_window_pos, 
    GL_MESA_ycbcr_texture, GL_NV_blend_square, GL_NV_conditional_render, 
    GL_NV_depth_clamp, GL_NV_fog_distance, GL_NV_light_max_exponent, 
    GL_NV_packed_depth_stencil, GL_NV_primitive_restart, 
    GL_NV_texgen_reflection, GL_NV_texture_env_combine4, 
    GL_NV_texture_rectangle, GL_OES_EGL_image, GL_OES_read_format, 
    GL_S3_s3tc, GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp, 
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays

OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.3.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0
OpenGL ES profile extensions:
    GL_ANGLE_texture_compression_dxt3, GL_ANGLE_texture_compression_dxt5, 
    GL_APPLE_texture_max_level, GL_EXT_blend_minmax, 
    GL_EXT_color_buffer_float, GL_EXT_discard_framebuffer, 
    GL_EXT_map_buffer_range, GL_EXT_multi_draw_arrays, 
    GL_EXT_read_format_bgra, GL_EXT_separate_shader_objects, 
    GL_EXT_shader_integer_mix, GL_EXT_texture_compression_dxt1, 
    GL_EXT_texture_format_BGRA8888, GL_EXT_texture_rg, 
    GL_EXT_texture_type_2_10_10_10_REV, GL_EXT_unpack_subimage, 
    GL_NV_draw_buffers, GL_NV_fbo_color_attachments, GL_NV_read_buffer, 
    GL_OES_EGL_image, GL_OES_EGL_image_external, 
    GL_OES_compressed_ETC1_RGB8_texture, GL_OES_depth24, GL_OES_depth_texture, 
    GL_OES_depth_texture_cube_map, GL_OES_element_index_uint, 
    GL_OES_fbo_render_mipmap, GL_OES_get_program_binary, GL_OES_mapbuffer, 
    GL_OES_packed_depth_stencil, GL_OES_rgb8_rgba8, 
    GL_OES_standard_derivatives, GL_OES_stencil8, GL_OES_surfaceless_context, 
    GL_OES_texture_3D, GL_OES_texture_npot, GL_OES_vertex_array_object

12 GLX Visuals
    visual  x   bf lv rg d st  colorbuffer  sr ax dp st accumbuffer  ms  cav
  id dep cl sp  sz l  ci b ro  r  g  b  a F gb bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------------
0x021 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x022 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x066 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
0x067 24 tc  0  32  0 r  . .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
0x068 24 tc  0  32  0 r  . .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x069 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8 16 16 16 16  0 0 Slow
0x06a 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
0x06b 24 dc  0  32  0 r  . .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
0x06c 24 dc  0  32  0 r  . .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x06d 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x06e 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8 16 16 16 16  0 0 Slow
0x04d 32 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None

24 GLXFBConfigs:
    visual  x   bf lv rg d st  colorbuffer  sr ax dp st accumbuffer  ms  cav
  id dep cl sp  sz l  ci b ro  r  g  b  a F gb bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------------
0x04e  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0  0  0  0  0  0  0  0 0 None
0x04f  0 tc  0  16  0 r  . .   5  6  5  0 .  .  0  0  0  0  0  0  0  0 0 None
0x050  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
0x051  0 tc  0  16  0 r  . .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
0x052 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
0x053 24 tc  0  32  0 r  . .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
0x054 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x055 24 tc  0  32  0 r  . .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x056  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
0x057  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0 16 16 16  0  0 0 Slow
0x058 32 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x059 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8 16 16 16 16  0 0 Slow
0x05a  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0  0  0  0  0  0  0  0 0 None
0x05b  0 dc  0  16  0 r  . .   5  6  5  0 .  .  0  0  0  0  0  0  0  0 0 None
0x05c  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
0x05d  0 dc  0  16  0 r  . .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
0x05e 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
0x05f 24 dc  0  32  0 r  . .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
0x060 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x061 24 dc  0  32  0 r  . .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x062  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
0x063  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0 16 16 16  0  0 0 Slow
0x064 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x065 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8 16 16 16 16  0 0 Slow

X server symlink status:
------------------------
lrwxrwxrwx 1 root root 13 Mar 14 11:55 /etc/X11/X -> /usr/bin/Xorg
-rwxr-xr-x 1 root root 2564976 Feb 11 01:23 /usr/bin/Xorg

VGA-compatible devices on PCI bus:
----------------------------------
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)

/etc/X11/xorg.conf does not exist.

/etc/X11/xorg.conf.d does not exist.

/etc/modprobe.d contains no KMS configuration files.

Kernel version (/proc/version):
-------------------------------
Linux version 3.16.0-4-586 ([email-masked]) (gcc version 4.8.4 (Debian 4.8.4-1) ) #1 Debian 3.16.7-ckt7-1 (2015-03-01)

Xorg X server log files on system:
----------------------------------
-rw-r--r-- 1 root root 24377 Mar 14 16:40 /var/log/Xorg.2.log
-rw-r--r-- 1 root root 24241 Mar 15 08:24 /var/log/Xorg.0.log

Contents of most recent Xorg X server log file (/var/log/Xorg.0.log):
---------------------------------------------------------------------
[   477.678] 
X.Org X Server 1.16.4
Release Date: 2014-12-20
[   477.678] X Protocol Version 11, Revision 0
[   477.678] Build Operating System: Linux 3.2.0-4-amd64 i686 Debian
[   477.678] Current Operating System: Linux d505 3.16.0-4-586 #1 Debian 3.16.7-ckt7-1 (2015-03-01) i686
[   477.678] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-586 root=UUID=1535aeb8-12b2-416d-8d7b-ce9d49b8f379 ro quiet
[   477.678] Build Date: 11 February 2015  01:14:26AM
[   477.678] xorg-server 2:1.16.4-1 (http://www.debian.org/support) 
[   477.678] Current version of pixman: 0.32.6
[   477.678] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   477.678] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   477.678] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar 15 08:23:36 2015
[   477.678] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   477.679] (==) No Layout section.  Using the first Screen section.
[   477.679] (==) No screen section available. Using defaults.
[   477.679] (**) |-->Screen "Default Screen Section" (0)
[   477.679] (**) |   |-->Monitor "<default monitor>"
[   477.679] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   477.680] (==) Automatically adding devices
[   477.680] (==) Automatically enabling devices
[   477.680] (==) Automatically adding GPU devices
[   477.680] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   477.680] 	Entry deleted from font path.
[   477.680] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[   477.680] (==) ModulePath set to "/usr/lib/xorg/modules"
[   477.680] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   477.680] (II) Loader magic: 0xb778a700
[   477.680] (II) Module ABI versions:
[   477.680] 	X.Org ANSI C Emulation: 0.4
[   477.680] 	X.Org Video Driver: 18.0
[   477.680] 	X.Org XInput driver : 21.0
[   477.680] 	X.Org Server Extension : 8.0
[   477.680] (II) xfree86: Adding drm device (/dev/dri/card0)
[   477.682] (--) PCI:*(0:0:2:0) 8086:3582:1028:0163 rev 2, Mem @ 0xf0000000/134217728, 0xfaf80000/524288, I/O @ 0x0000c000/8
[   477.682] (--) PCI: (0:0:2:1) 8086:3582:1028:0163 rev 2, Mem @ 0xe8000000/134217728, 0xfaf00000/524288
[   477.682] (II) LoadModule: "glx"
[   477.683] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   477.685] (II) Module glx: vendor="X.Org Foundation"
[   477.685] 	compiled for 1.16.4, module version = 1.0.0
[   477.685] 	ABI class: X.Org Server Extension, version 8.0
[   477.685] (==) AIGLX enabled
[   477.685] (==) Matched intel as autoconfigured driver 0
[   477.685] (==) Matched intel as autoconfigured driver 1
[   477.685] (==) Matched modesetting as autoconfigured driver 2
[   477.685] (==) Matched fbdev as autoconfigured driver 3
[   477.685] (==) Matched vesa as autoconfigured driver 4
[   477.685] (==) Assigned the driver to the xf86ConfigLayout
[   477.685] (II) LoadModule: "intel"
[   477.685] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   477.686] (II) Module intel: vendor="X.Org Foundation"
[   477.686] 	compiled for 1.15.99.904, module version = 2.21.15
[   477.686] 	Module class: X.Org Video Driver
[   477.686] 	ABI class: X.Org Video Driver, version 18.0
[   477.686] (II) LoadModule: "modesetting"
[   477.686] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   477.687] (II) Module modesetting: vendor="X.Org Foundation"
[   477.687] 	compiled for 1.15.99.904, module version = 0.9.0
[   477.687] 	Module class: X.Org Video Driver
[   477.687] 	ABI class: X.Org Video Driver, version 18.0
[   477.687] (II) LoadModule: "fbdev"
[   477.687] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   477.687] (II) Module fbdev: vendor="X.Org Foundation"
[   477.687] 	compiled for 1.15.99.904, module version = 0.4.4
[   477.687] 	Module class: X.Org Video Driver
[   477.687] 	ABI class: X.Org Video Driver, version 18.0
[   477.687] (II) LoadModule: "vesa"
[   477.687] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   477.687] (II) Module vesa: vendor="X.Org Foundation"
[   477.688] 	compiled for 1.15.99.904, module version = 2.3.3
[   477.688] 	Module class: X.Org Video Driver
[   477.688] 	ABI class: X.Org Video Driver, version 18.0
[   477.688] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
	HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
	HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
	HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
	HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
[   477.688] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   477.688] (II) FBDEV: driver for framebuffer: fbdev
[   477.688] (II) VESA: driver for VESA chipsets: vesa
[   477.688] (++) using VT number 7

[   477.697] (WW) Falling back to old probe method for modesetting
[   477.697] (WW) Falling back to old probe method for fbdev
[   477.697] (II) Loading sub module "fbdevhw"
[   477.697] (II) LoadModule: "fbdevhw"
[   477.697] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   477.698] (II) Module fbdevhw: vendor="X.Org Foundation"
[   477.698] 	compiled for 1.16.4, module version = 0.0.2
[   477.698] 	ABI class: X.Org Video Driver, version 18.0
[   477.698] (WW) Falling back to old probe method for vesa
[   477.698] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[   477.698] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[   477.698] (==) intel(0): RGB weight 888
[   477.698] (==) intel(0): Default visual is TrueColor
[   477.698] (--) intel(0): Integrated Graphics Chipset: Intel(R) 852GM/855GM
[   477.698] (**) intel(0): Relaxed fencing disabled
[   477.698] (**) intel(0): Wait on SwapBuffers? enabled
[   477.698] (**) intel(0): Triple buffering? enabled
[   477.698] (**) intel(0): Framebuffer tiled
[   477.698] (**) intel(0): Pixmaps tiled
[   477.699] (**) intel(0): 3D buffers tiled
[   477.699] (**) intel(0): SwapBuffers wait enabled
[   477.699] (==) intel(0): video overlay key set to 0x101fe
[   477.699] (II) intel(0): Output LVDS1 has no monitor section
[   477.732] (--) intel(0): found backlight control interface /sys/class/backlight/dell_backlight
[   477.868] (II) intel(0): Output VGA1 has no monitor section
[   477.964] (II) intel(0): Output DVI1 has no monitor section
[   477.964] (II) intel(0): EDID for output LVDS1
[   477.964] (II) intel(0): Manufacturer: LGP  Model: b946  Serial#: 0
[   477.964] (II) intel(0): Year: 2003  Week: 0
[   477.964] (II) intel(0): EDID Version: 1.3
[   477.964] (II) intel(0): Digital Display Input
[   477.964] (II) intel(0): Max Image Size [cm]: horiz.: 30  vert.: 23
[   477.964] (II) intel(0): Gamma: 2.20
[   477.964] (II) intel(0): No DPMS capabilities specified
[   477.964] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
[   477.964] (II) intel(0): First detailed timing is preferred mode
[   477.964] (II) intel(0): redX: 0.590 redY: 0.340   greenX: 0.322 greenY: 0.531
[   477.964] (II) intel(0): blueX: 0.156 blueY: 0.135   whiteX: 0.312 whiteY: 0.328
[   477.964] (II) intel(0): Manufacturer's mask: 0
[   477.964] (II) intel(0): Supported detailed timing:
[   477.964] (II) intel(0): clock: 65.0 MHz   Image Size:  304 x 228 mm
[   477.964] (II) intel(0): h_active: 1024  h_sync: 1048  h_sync_end 1184 h_blank_end 1344 h_border: 0
[   477.964] (II) intel(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 806 v_border: 0
[   477.964] (II) intel(0): Supported detailed timing:
[   477.964] (II) intel(0): clock: 65.0 MHz   Image Size:  304 x 228 mm
[   477.964] (II) intel(0): h_active: 1024  h_sync: 1048  h_sync_end 1184 h_blank_end 1344 h_border: 0
[   477.964] (II) intel(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 806 v_border: 0
[   477.964] (II) intel(0):  F1124
[   477.964] (II) intel(0):  ȸ���hH
[   477.964] (II) intel(0): EDID (in hex):
[   477.964] (II) intel(0): 	00ffffffffffff0030f046b900000000
[   477.964] (II) intel(0): 	000d0103801e17780a08209757528828
[   477.964] (II) intel(0): 	22505400000001010101010101010101
[   477.964] (II) intel(0): 	01010101010164190040410026301888
[   477.964] (II) intel(0): 	360030e4100000186419004041002630
[   477.964] (II) intel(0): 	1888360030e410000000000000fe0046
[   477.964] (II) intel(0): 	31313234003135305830390a000000fe
[   477.964] (II) intel(0): 	00c8b8a8988868480001000a2020004f
[   477.965] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "576x432" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "680x384" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "680x384" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "720x450" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "800x512" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "840x525" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "840x525" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "960x540" (doublescan mode not supported)
[   477.965] (II) intel(0): Not using default mode "960x600" (doublescan mode not supported)
[   477.965] (II) intel(0): Printing probed modes for output LVDS1
[   477.965] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz eP)
[   477.965] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[   477.965] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[   477.965] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[   478.100] (II) intel(0): EDID for output VGA1
[   478.196] (II) intel(0): EDID for output DVI1
[   478.196] (II) intel(0): Output LVDS1 connected
[   478.196] (II) intel(0): Output VGA1 disconnected
[   478.196] (II) intel(0): Output DVI1 disconnected
[   478.196] (II) intel(0): Using exact sizes for initial modes
[   478.196] (II) intel(0): Output LVDS1 using initial mode 1024x768
[   478.196] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[   478.196] (II) intel(0): Kernel page flipping support detected, enabling
[   478.196] (==) intel(0): DPI set to (96, 96)
[   478.196] (II) Loading sub module "fb"
[   478.196] (II) LoadModule: "fb"
[   478.196] (II) Loading /usr/lib/xorg/modules/libfb.so
[   478.197] (II) Module fb: vendor="X.Org Foundation"
[   478.197] 	compiled for 1.16.4, module version = 1.0.0
[   478.197] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   478.197] (II) Loading sub module "dri2"
[   478.197] (II) LoadModule: "dri2"
[   478.197] (II) Module "dri2" already built-in
[   478.197] (II) UnloadModule: "modesetting"
[   478.197] (II) Unloading modesetting
[   478.197] (II) UnloadModule: "fbdev"
[   478.197] (II) Unloading fbdev
[   478.197] (II) UnloadSubModule: "fbdevhw"
[   478.197] (II) Unloading fbdevhw
[   478.197] (II) UnloadModule: "vesa"
[   478.197] (II) Unloading vesa
[   478.197] (==) Depth 24 pixmap format is 32 bpp
[   478.197] (II) intel(0): [DRI2] Setup complete
[   478.197] (II) intel(0): [DRI2]   DRI driver: i915
[   478.197] (II) intel(0): Allocated new frame buffer 1024x768 stride 4096, tiled
[   478.197] (II) UXA(0): Driver registered support for the following operations:
[   478.198] (II)         solid
[   478.198] (II)         copy
[   478.198] (II)         composite (RENDER acceleration)
[   478.198] (II)         put_image
[   478.198] (II)         get_image
[   478.198] (==) intel(0): Backing store enabled
[   478.198] (==) intel(0): Silken mouse enabled
[   478.198] (II) intel(0): Initializing HW Cursor
[   478.198] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[   478.309] (==) intel(0): DPMS enabled
[   478.309] (==) intel(0): Intel XvMC decoder disabled
[   478.310] (II) intel(0): Set up overlay video
[   478.310] (II) intel(0): direct rendering: DRI2 Enabled
[   478.310] (==) intel(0): hotplug detection: "enabled"
[   478.324] (--) RandR disabled
[   478.343] (II) SELinux: Disabled on system
[   478.351] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[   478.351] (II) AIGLX: enabled GLX_ARB_create_context
[   478.351] (II) AIGLX: enabled GLX_ARB_create_context_profile
[   478.351] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[   478.351] (II) AIGLX: enabled GLX_INTEL_swap_event
[   478.351] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[   478.351] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[   478.351] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[   478.351] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[   478.351] (II) AIGLX: Loaded and initialized i915
[   478.351] (II) GLX: Initialized DRI2 GL provider for screen 0
[   478.352] (II) intel(0): Setting screen physical size to 270 x 203
[   478.435] (II) config/udev: Adding input device Video Bus (/dev/input/event1)
[   478.436] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[   478.436] (II) LoadModule: "evdev"
[   478.436] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[   478.437] (II) Module evdev: vendor="X.Org Foundation"
[   478.437] 	compiled for 1.16.0, module version = 2.9.0
[   478.437] 	Module class: X.Org XInput Driver
[   478.437] 	ABI class: X.Org XInput driver, version 21.0
[   478.437] (II) Using input driver 'evdev' for 'Video Bus'
[   478.437] (**) Video Bus: always reports core events
[   478.437] (**) evdev: Video Bus: Device: "/dev/input/event1"
[   478.437] (--) evdev: Video Bus: Vendor 0 Product 0x6
[   478.437] (--) evdev: Video Bus: Found keys
[   478.437] (II) evdev: Video Bus: Configuring as keyboard
[   478.437] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2/event1"
[   478.437] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 6)
[   478.437] (**) Option "xkb_rules" "evdev"
[   478.437] (**) Option "xkb_model" "pc105"
[   478.437] (**) Option "xkb_layout" "de"
[   478.482] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[   478.483] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   478.483] (II) Using input driver 'evdev' for 'Power Button'
[   478.483] (**) Power Button: always reports core events
[   478.483] (**) evdev: Power Button: Device: "/dev/input/event3"
[   478.483] (--) evdev: Power Button: Vendor 0 Product 0x1
[   478.483] (--) evdev: Power Button: Found keys
[   478.483] (II) evdev: Power Button: Configuring as keyboard
[   478.483] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input4/event3"
[   478.483] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[   478.483] (**) Option "xkb_rules" "evdev"
[   478.483] (**) Option "xkb_model" "pc105"
[   478.483] (**) Option "xkb_layout" "de"
[   478.484] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[   478.484] (II) No input driver specified, ignoring this device.
[   478.484] (II) This device may have been added with another device file.
[   478.485] (II) config/udev: Adding input device Sleep Button (/dev/input/event4)
[   478.485] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[   478.485] (II) Using input driver 'evdev' for 'Sleep Button'
[   478.485] (**) Sleep Button: always reports core events
[   478.485] (**) evdev: Sleep Button: Device: "/dev/input/event4"
[   478.485] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[   478.485] (--) evdev: Sleep Button: Found keys
[   478.485] (II) evdev: Sleep Button: Configuring as keyboard
[   478.485] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input5/event4"
[   478.485] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[   478.485] (**) Option "xkb_rules" "evdev"
[   478.485] (**) Option "xkb_model" "pc105"
[   478.485] (**) Option "xkb_layout" "de"
[   478.487] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[   478.487] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[   478.487] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[   478.487] (**) AT Translated Set 2 keyboard: always reports core events
[   478.487] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[   478.487] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[   478.487] (--) evdev: AT Translated Set 2 keyboard: Found keys
[   478.487] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[   478.487] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[   478.487] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[   478.487] (**) Option "xkb_rules" "evdev"
[   478.487] (**) Option "xkb_model" "pc105"
[   478.487] (**) Option "xkb_layout" "de"
[   478.488] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/event7)
[   478.489] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "evdev touchpad catchall"
[   478.489] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "touchpad catchall"
[   478.489] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "Default clickpad buttons"
[   478.489] (II) LoadModule: "synaptics"
[   478.489] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[   478.489] (II) Module synaptics: vendor="X.Org Foundation"
[   478.489] 	compiled for 1.16.0.901, module version = 1.8.99
[   478.489] 	Module class: X.Org XInput Driver
[   478.489] 	ABI class: X.Org XInput driver, version 21.0
[   478.489] (II) Using input driver 'synaptics' for 'AlpsPS/2 ALPS GlidePoint'
[   478.489] (**) AlpsPS/2 ALPS GlidePoint: always reports core events
[   478.489] (**) Option "Device" "/dev/input/event7"
[   478.490] (--) synaptics: AlpsPS/2 ALPS GlidePoint: x-axis range 0 - 1023 (res 0)
[   478.490] (--) synaptics: AlpsPS/2 ALPS GlidePoint: y-axis range 0 - 767 (res 0)
[   478.490] (--) synaptics: AlpsPS/2 ALPS GlidePoint: pressure range 0 - 127
[   478.490] (II) synaptics: AlpsPS/2 ALPS GlidePoint: device does not report finger width.
[   478.490] (--) synaptics: AlpsPS/2 ALPS GlidePoint: buttons: left right middle
[   478.490] (--) synaptics: AlpsPS/2 ALPS GlidePoint: Vendor 0x2 Product 0x8
[   478.490] (--) synaptics: AlpsPS/2 ALPS GlidePoint: invalid finger width range.  defaulting to 0 - 15
[   478.490] (--) synaptics: AlpsPS/2 ALPS GlidePoint: touchpad found
[   478.490] (**) AlpsPS/2 ALPS GlidePoint: always reports core events
[   478.490] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event7"
[   478.490] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS GlidePoint" (type: TOUCHPAD, id 10)
[   478.490] (**) synaptics: AlpsPS/2 ALPS GlidePoint: (accel) MinSpeed is now constant deceleration 2.5
[   478.490] (**) synaptics: AlpsPS/2 ALPS GlidePoint: (accel) MaxSpeed is now 1.75
[   478.490] (**) synaptics: AlpsPS/2 ALPS GlidePoint: (accel) AccelFactor is now 0.156
[   478.491] (**) AlpsPS/2 ALPS GlidePoint: (accel) keeping acceleration scheme 1
[   478.491] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration profile 1
[   478.491] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration factor: 2.000
[   478.491] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration threshold: 4
[   478.491] (--) synaptics: AlpsPS/2 ALPS GlidePoint: touchpad found
[   478.491] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse1)
[   478.491] (**) AlpsPS/2 ALPS GlidePoint: Ignoring device from InputClass "touchpad ignore duplicates"
[   478.492] (II) config/udev: Adding input device ALPS PS/2 Device (/dev/input/event6)
[   478.492] (**) ALPS PS/2 Device: Applying InputClass "evdev pointer catchall"
[   478.492] (II) Using input driver 'evdev' for 'ALPS PS/2 Device'
[   478.492] (**) ALPS PS/2 Device: always reports core events
[   478.492] (**) evdev: ALPS PS/2 Device: Device: "/dev/input/event6"
[   478.492] (--) evdev: ALPS PS/2 Device: Vendor 0x2 Product 0x8
[   478.492] (--) evdev: ALPS PS/2 Device: Found 3 mouse buttons
[   478.492] (--) evdev: ALPS PS/2 Device: Found relative axes
[   478.492] (--) evdev: ALPS PS/2 Device: Found x and y relative axes
[   478.492] (II) evdev: ALPS PS/2 Device: Configuring as mouse
[   478.492] (**) evdev: ALPS PS/2 Device: YAxisMapping: buttons 4 and 5
[   478.492] (**) evdev: ALPS PS/2 Device: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   478.492] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input8/event6"
[   478.492] (II) XINPUT: Adding extended input device "ALPS PS/2 Device" (type: MOUSE, id 11)
[   478.493] (II) evdev: ALPS PS/2 Device: initialized for relative axes.
[   478.493] (**) ALPS PS/2 Device: (accel) keeping acceleration scheme 1
[   478.493] (**) ALPS PS/2 Device: (accel) acceleration profile 0
[   478.493] (**) ALPS PS/2 Device: (accel) acceleration factor: 2.000
[   478.493] (**) ALPS PS/2 Device: (accel) acceleration threshold: 4
[   478.494] (II) config/udev: Adding input device ALPS PS/2 Device (/dev/input/mouse0)
[   478.494] (II) No input driver specified, ignoring this device.
[   478.494] (II) This device may have been added with another device file.
[   478.494] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
[   478.494] (II) No input driver specified, ignoring this device.
[   478.494] (II) This device may have been added with another device file.
[   526.897] (II) intel(0): EDID vendor "LGP", prod id 47430
[   526.897] (II) intel(0): DDCModeFromDetailedTiming: 1024x768 Warning: We only handle separate sync.
[   526.897] (II) intel(0): Printing DDC gathered Modelines:
[   526.897] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz eP)
[   537.616] (II) intel(0): EDID vendor "LGP", prod id 47430
[   537.616] (II) intel(0): DDCModeFromDetailedTiming: 1024x768 Warning: We only handle separate sync.
[   537.616] (II) intel(0): Printing DDC gathered Modelines:
[   537.616] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz eP)

udev information:
-----------------
P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2
E: EV=3
E: ID_FOR_SEAT=input-acpi-LNXVIDEO_00
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-LNXVIDEO:00
E: ID_PATH_TAG=acpi-LNXVIDEO_00
E: KEY=3e000b 0 0 0 0 0 0 0
E: MODALIAS=input:b0019v0000p0006e0000-e0,1,kE0,E1,E3,F1,F2,F3,F4,F5,ramlsfw
E: NAME="Video Bus"
E: PHYS="LNXVIDEO/video/input0"
E: PRODUCT=19/0/6/0
E: PROP=0
E: SUBSYSTEM=input
E: TAGS=:seat:
E: USEC_INITIALIZED=325930

P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2/event1
N: input/event1
E: BACKSPACE=guess
E: DEVNAME=/dev/input/event1
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2/event1
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-LNXVIDEO:00
E: ID_PATH_TAG=acpi-LNXVIDEO_00
E: MAJOR=13
E: MINOR=65
E: SUBSYSTEM=input
E: TAGS=:power-switch:
E: USEC_INITIALIZED=977824
E: XKBLAYOUT=de
E: XKBMODEL=pc105

P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input4
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input4
E: EV=3
E: ID_FOR_SEAT=input-acpi-PNP0C0C_00
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-PNP0C0C:00
E: ID_PATH_TAG=acpi-PNP0C0C_00
E: KEY=100000 0 0 0
E: MODALIAS=input:b0019v0000p0001e0000-e0,1,k74,ramlsfw
E: NAME="Power Button"
E: PHYS="PNP0C0C/button/input0"
E: PRODUCT=19/0/1/0
E: PROP=0
E: SUBSYSTEM=input
E: TAGS=:seat:
E: USEC_INITIALIZED=635809

P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input4/event3
N: input/event3
E: BACKSPACE=guess
E: DEVNAME=/dev/input/event3
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input4/event3
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-PNP0C0C:00
E: ID_PATH_TAG=acpi-PNP0C0C_00
E: MAJOR=13
E: MINOR=67
E: SUBSYSTEM=input
E: TAGS=:power-switch:
E: USEC_INITIALIZED=982015
E: XKBLAYOUT=de
E: XKBMODEL=pc105

P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input3
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input3
E: EV=21
E: ID_FOR_SEAT=input-acpi-PNP0C0D_00
E: ID_INPUT=1
E: ID_PATH=acpi-PNP0C0D:00
E: ID_PATH_TAG=acpi-PNP0C0D_00
E: MODALIAS=input:b0019v0000p0005e0000-e0,5,kramlsfw0,
E: NAME="Lid Switch"
E: PHYS="PNP0C0D/button/input0"
E: PRODUCT=19/0/5/0
E: PROP=0
E: SUBSYSTEM=input
E: SW=1
E: TAGS=:seat:
E: USEC_INITIALIZED=634168

P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input3/event2
N: input/event2
E: DEVNAME=/dev/input/event2
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input3/event2
E: ID_INPUT=1
E: ID_PATH=acpi-PNP0C0D:00
E: ID_PATH_TAG=acpi-PNP0C0D_00
E: MAJOR=13
E: MINOR=66
E: SUBSYSTEM=input
E: TAGS=:power-switch:
E: USEC_INITIALIZED=979706

P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input5
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input5
E: EV=3
E: ID_FOR_SEAT=input-acpi-PNP0C0E_00
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-PNP0C0E:00
E: ID_PATH_TAG=acpi-PNP0C0E_00
E: KEY=4000 0 0 0 0
E: MODALIAS=input:b0019v0000p0003e0000-e0,1,k8E,ramlsfw
E: NAME="Sleep Button"
E: PHYS="PNP0C0E/button/input0"
E: PRODUCT=19/0/3/0
E: PROP=0
E: SUBSYSTEM=input
E: TAGS=:seat:
E: USEC_INITIALIZED=637952

P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input5/event4
N: input/event4
E: BACKSPACE=guess
E: DEVNAME=/dev/input/event4
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input5/event4
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-PNP0C0E:00
E: ID_PATH_TAG=acpi-PNP0C0E_00
E: MAJOR=13
E: MINOR=68
E: SUBSYSTEM=input
E: TAGS=:power-switch:
E: USEC_INITIALIZED=984274
E: XKBLAYOUT=de
E: XKBMODEL=pc105

P: /devices/platform/i8042/serio0/input/input0
E: DEVPATH=/devices/platform/i8042/serio0/input/input0
E: EV=120013
E: ID_FOR_SEAT=input-platform-i8042-serio-0
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_INPUT_KEYBOARD=1
E: ID_PATH=platform-i8042-serio-0
E: ID_PATH_TAG=platform-i8042-serio-0
E: ID_SERIAL=noserial
E: KEY=1100f 2902000 8380307c f910f001 feffffdf ffefffff ffffffff fffffffe
E: LED=7
E: MODALIAS=input:b0011v0001p0001eAB41-e0,1,4,11,14,k71,72,73,74,75,76,77,79,7A,7B,7C,7D,7E,7F,80,8C,8D,8E,8F,94,98,9B,9C,9D,9E,9F,A2,A3,A4,A5,A6,AC,AD,B7,B8,B9,BF,CD,D4,D7,D9,E0,E1,E2,E3,EC,F0,ram4,l0,1,2,sfw
E: MSC=10
E: NAME="AT Translated Set 2 keyboard"
E: PHYS="isa0060/serio0/input0"
E: PRODUCT=11/1/1/ab41
E: PROP=0
E: SUBSYSTEM=input
E: TAGS=:seat:
E: USEC_INITIALIZED=19978

P: /devices/platform/i8042/serio0/input/input0/event0
N: input/event0
S: input/by-path/platform-i8042-serio-0-event-kbd
E: BACKSPACE=guess
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-0-event-kbd
E: DEVNAME=/dev/input/event0
E: DEVPATH=/devices/platform/i8042/serio0/input/input0/event0
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_INPUT_KEYBOARD=1
E: ID_PATH=platform-i8042-serio-0
E: ID_PATH_TAG=platform-i8042-serio-0
E: ID_SERIAL=noserial
E: KEYBOARD_KEY_81=playpause
E: KEYBOARD_KEY_82=stopcd
E: KEYBOARD_KEY_83=previoussong
E: KEYBOARD_KEY_84=nextsong
E: KEYBOARD_KEY_85=brightnessdown
E: KEYBOARD_KEY_86=brightnessup
E: KEYBOARD_KEY_87=battery
E: KEYBOARD_KEY_88=unknown
E: KEYBOARD_KEY_89=ejectclosecd
E: KEYBOARD_KEY_8F=switchvideomode
E: KEYBOARD_KEY_8a=suspend
E: KEYBOARD_KEY_8b=switchvideomode
E: KEYBOARD_KEY_8c=unknown
E: KEYBOARD_KEY_90=previoussong
E: KEYBOARD_KEY_91=prog1
E: KEYBOARD_KEY_92=media
E: KEYBOARD_KEY_93=unknown
E: KEYBOARD_KEY_95=camera
E: KEYBOARD_KEY_97=email
E: KEYBOARD_KEY_98=f21
E: KEYBOARD_KEY_99=nextsong
E: KEYBOARD_KEY_9a=setup
E: KEYBOARD_KEY_9b=switchvideomode
E: KEYBOARD_KEY_9e=!f21
E: KEYBOARD_KEY_a2=playpause
E: KEYBOARD_KEY_a4=stopcd
E: KEYBOARD_KEY_d8=screenlock
E: KEYBOARD_KEY_d9=f21
E: KEYBOARD_KEY_ed=media
E: MAJOR=13
E: MINOR=64
E: SUBSYSTEM=input
E: USEC_INITIALIZED=975680
E: XKBLAYOUT=de
E: XKBMODEL=pc105

P: /devices/platform/i8042/serio1/input/input6
E: ABS=1000003
E: DEVPATH=/devices/platform/i8042/serio1/input/input6
E: EV=b
E: ID_FOR_SEAT=input-platform-i8042-serio-1
E: ID_INPUT=1
E: ID_INPUT_TOUCHPAD=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: KEY=420 0 70000 0 0 0 0 0 0 0 0
E: MODALIAS=input:b0011v0002p0008e0200-e0,1,3,k110,111,112,145,14A,ra0,1,18,mlsfw
E: NAME="AlpsPS/2 ALPS GlidePoint"
E: PHYS="isa0060/serio1/input0"
E: PRODUCT=11/2/8/200
E: PROP=0
E: SUBSYSTEM=input
E: TAGS=:seat:
E: USEC_INITIALIZED=211903

P: /devices/platform/i8042/serio1/input/input6/event7
N: input/event7
S: input/by-path/platform-i8042-serio-1-event-mouse
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-event-mouse
E: DEVNAME=/dev/input/event7
E: DEVPATH=/devices/platform/i8042/serio1/input/input6/event7
E: ID_INPUT=1
E: ID_INPUT_TOUCHPAD=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: MAJOR=13
E: MINOR=71
E: SUBSYSTEM=input
E: USEC_INITIALIZED=214349

P: /devices/platform/i8042/serio1/input/input6/mouse1
N: input/mouse1
S: input/by-path/platform-i8042-serio-1-mouse
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-mouse
E: DEVNAME=/dev/input/mouse1
E: DEVPATH=/devices/platform/i8042/serio1/input/input6/mouse1
E: ID_INPUT=1
E: ID_INPUT_TOUCHPAD=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: MAJOR=13
E: MINOR=33
E: SUBSYSTEM=input
E: USEC_INITIALIZED=214289

P: /devices/platform/i8042/serio1/input/input8
E: DEVPATH=/devices/platform/i8042/serio1/input/input8
E: EV=7
E: ID_FOR_SEAT=input-platform-i8042-serio-1
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: KEY=70000 0 0 0 0 0 0 0 0
E: MODALIAS=input:b0011v0002p0008e0000-e0,1,2,k110,111,112,r0,1,amlsfw
E: NAME="ALPS PS/2 Device"
E: PHYS="isa0060/serio1/input1"
E: PRODUCT=11/2/8/0
E: PROP=0
E: REL=3
E: SUBSYSTEM=input
E: TAGS=:seat:
E: USEC_INITIALIZED=189070

P: /devices/platform/i8042/serio1/input/input8/event6
N: input/event6
S: input/by-path/platform-i8042-serio-1-event-mouse
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-event-mouse
E: DEVNAME=/dev/input/event6
E: DEVPATH=/devices/platform/i8042/serio1/input/input8/event6
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: MAJOR=13
E: MINOR=70
E: SUBSYSTEM=input
E: USEC_INITIALIZED=191751

P: /devices/platform/i8042/serio1/input/input8/mouse0
N: input/mouse0
S: input/by-path/platform-i8042-serio-1-mouse
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-mouse
E: DEVNAME=/dev/input/mouse0
E: DEVPATH=/devices/platform/i8042/serio1/input/input8/mouse0
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: MAJOR=13
E: MINOR=32
E: SUBSYSTEM=input
E: USEC_INITIALIZED=190503

P: /devices/platform/pcspkr/input/input7
E: DEVPATH=/devices/platform/pcspkr/input/input7
E: EV=40001
E: ID_FOR_SEAT=input-platform-pcspkr
E: ID_INPUT=1
E: ID_PATH=platform-pcspkr
E: ID_PATH_TAG=platform-pcspkr
E: ID_SERIAL=noserial
E: MODALIAS=input:b0010v001Fp0001e0100-e0,12,kramls1,2,fw
E: NAME="PC Speaker"
E: PHYS="isa0061/input0"
E: PRODUCT=10/1f/1/100
E: PROP=0
E: SND=6
E: SUBSYSTEM=input
E: TAGS=:seat:
E: USEC_INITIALIZED=144959

P: /devices/platform/pcspkr/input/input7/event5
N: input/event5
S: input/by-path/platform-pcspkr-event-spkr
E: DEVLINKS=/dev/input/by-path/platform-pcspkr-event-spkr
E: DEVNAME=/dev/input/event5
E: DEVPATH=/devices/platform/pcspkr/input/input7/event5
E: ID_INPUT=1
E: ID_PATH=platform-pcspkr
E: ID_PATH_TAG=platform-pcspkr
E: ID_SERIAL=noserial
E: MAJOR=13
E: MINOR=69
E: SUBSYSTEM=input
E: USEC_INITIALIZED=146207

DRM Information from dmesg:
---------------------------
[    1.269824] Linux agpgart interface v0.103
[    1.269990] agpgart-intel 0000:00:00.0: Intel 855GM Chipset
[    1.270008] agpgart-intel 0000:00:00.0: detected gtt size: 131072K total, 131072K mappable
[    1.270136] agpgart-intel 0000:00:00.0: detected 1024K stolen memory
[    1.270312] agpgart-intel 0000:00:00.0: AGP aperture is 128M @ 0xf0000000
[   12.751232] [drm] Initialized drm 1.1.0 20060810
[   13.588598] [drm] Memory usable by graphics device = 128M
[   13.588608] [drm] Replacing VGA console driver
[   13.589994] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   13.590000] [drm] Driver supports precise vblank timestamp query.
[   13.684050] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[   13.726278] [drm] initialized overlay support
[   13.766759] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[   13.862064] fbcon: inteldrmfb (fb0) is primary device
[   14.411960] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   14.411991] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[   33.721824] [drm:i9xx_check_fifo_underruns] *ERROR* pipe B underrun
[   33.817442] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[   33.981527] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[   34.049439] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  131.309470] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  131.377686] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  131.541572] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  131.609428] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  133.306985] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  178.996063] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  182.789450] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  429.593813] [drm:i9xx_check_fifo_underruns] *ERROR* pipe B underrun
[  429.621449] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  429.689419] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  429.921409] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  477.837414] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  478.001987] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  478.069421] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  526.933659] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  527.002122] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun
[  537.692405] [drm:i9xx_set_fifo_underrun_reporting] *ERROR* pipe A underrun

-- System Information:
Debian Release: 8.0
  APT prefers testing-updates
  APT policy: (500, 'testing-updates'), (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 3.16.0-4-586
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libgl1-mesa-dri depends on:
ii  libc6              2.19-15
ii  libdrm-intel1      2.4.58-2
ii  libdrm-nouveau2    2.4.58-2
ii  libdrm-radeon1     2.4.58-2
ii  libdrm2            2.4.58-2
ii  libelf1            0.159-4.2
ii  libexpat1          2.1.0-6+b3
ii  libffi6            3.1-2+b2
ii  libgcc1            1:4.9.2-10
ii  libllvm3.4         1:3.4.2-13
ii  libstdc++6         4.9.2-10
ii  libtinfo5          5.9+20140913-1+b1
ii  multiarch-support  2.19-15

Versions of packages libgl1-mesa-dri recommends:
ii  libtxc-dxtn-s2tc0 [libtxc-dxtn0]  0~git20131104-1.1

libgl1-mesa-dri suggests no packages.

Versions of packages xserver-xorg depends on:
ii  libc6                                                 2.19-15
ii  x11-xkb-utils                                         7.7+1
ii  xkb-data                                              2.12-1
ii  xserver-xorg-core                                     2:1.16.4-1
ii  xserver-xorg-input-all                                1:7.7+7
ii  xserver-xorg-input-evdev [xorg-driver-input]          1:2.9.0-2
ii  xserver-xorg-input-mouse [xorg-driver-input]          1:1.9.1-1
ii  xserver-xorg-input-synaptics [xorg-driver-input]      1.8.1-1
ii  xserver-xorg-input-vmmouse [xorg-driver-input]        1:13.0.0-1+b3
ii  xserver-xorg-input-wacom [xorg-driver-input]          0.26.0+20140918-1
ii  xserver-xorg-video-all                                1:7.7+7
ii  xserver-xorg-video-ati [xorg-driver-video]            1:7.5.0-1
ii  xserver-xorg-video-cirrus [xorg-driver-video]         1:1.5.2-2+b1
ii  xserver-xorg-video-fbdev [xorg-driver-video]          1:0.4.4-1+b2
ii  xserver-xorg-video-geode [xorg-driver-video]          2.11.16-7
ii  xserver-xorg-video-intel [xorg-driver-video]          2:2.21.15-2+b2
ii  xserver-xorg-video-mach64 [xorg-driver-video]         6.9.4-2
ii  xserver-xorg-video-mga [xorg-driver-video]            1:1.6.3-2+b1
ii  xserver-xorg-video-modesetting [xorg-driver-video]    0.9.0-1+b1
ii  xserver-xorg-video-neomagic [xorg-driver-video]       1:1.2.8-1+b2
ii  xserver-xorg-video-nouveau [xorg-driver-video]        1:1.0.11-1
ii  xserver-xorg-video-openchrome [xorg-driver-video]     1:0.3.3-1+b2
ii  xserver-xorg-video-qxl [xorg-driver-video]            0.1.1-2+b1
ii  xserver-xorg-video-r128 [xorg-driver-video]           6.9.2-1+b2
ii  xserver-xorg-video-radeon [xorg-driver-video]         1:7.5.0-1
ii  xserver-xorg-video-savage [xorg-driver-video]         1:2.3.7-2+b2
ii  xserver-xorg-video-siliconmotion [xorg-driver-video]  1:1.7.7-2+b2
ii  xserver-xorg-video-sisusb [xorg-driver-video]         1:0.9.6-2+b2
ii  xserver-xorg-video-tdfx [xorg-driver-video]           1:1.4.5-1+b2
ii  xserver-xorg-video-trident [xorg-driver-video]        1:1.3.6-2+b2
ii  xserver-xorg-video-vesa [xorg-driver-video]           1:2.3.3-1+b3
ii  xserver-xorg-video-vmware [xorg-driver-video]         1:13.0.2-3+b1

xserver-xorg recommends no packages.

Versions of packages xserver-xorg-core depends on:
ii  keyboard-configuration    1.118
ii  libaudit1                 1:2.4-1+b1
ii  libc6                     2.19-15
ii  libdrm2                   2.4.58-2
ii  libegl1-mesa              10.3.2-1
ii  libepoxy0                 1.2-1
ii  libgbm1                   10.3.2-1
ii  libgcrypt20               1.6.2-4+b1
ii  libgl1-mesa-glx [libgl1]  10.3.2-1
ii  libpciaccess0             0.13.2-3+b1
ii  libpixman-1-0             0.32.6-3
ii  libselinux1               2.3-2
ii  libudev1                  215-12
ii  libxau6                   1:1.0.8-1
ii  libxdmcp6                 1:1.1.1-1+b1
ii  libxfont1                 1:1.4.99.901-1+b3
ii  libxshmfence1             1.1-4
ii  udev                      215-12
ii  xserver-common            2:1.16.4-1

xserver-xorg-core recommends no packages.

Versions of packages xserver-xorg-core suggests:
ii  xfonts-100dpi    1:1.0.3
ii  xfonts-75dpi     1:1.0.3
ii  xfonts-scalable  1:1.0.3-1

-- no debconf information

---

From: Bernhard Übelacker <[email-masked]>
Date: Sun, 15 Mar 2015 19:03:41 +0100

Hello Philip,
probably your case is more an example for the problem described in bugs
#770130 and #776911.
    https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=770130
    https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776911

When you rebuilt your mesa packages did you apply the patch mentioned in
message 15? And was package llvm-3.4-dev installed? If not, I would
assume that your rebuilt packages are also using llvm-3.5.

I have only tested both patches (message 15 and message 32) if they help
with the error "LLVM ERROR: Do not know how to split the result of this
operator!" inside a qemu VM.
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=775235#15
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=775235#32

If they could help with the "underrun" error on real hardware, as in
your case, I cannot say.

Kind regards,
Bernhard

---

From: Philip Hands <[email-masked]>
Date: Sun, 15 Mar 2015 19:48:07 +0000

> assume that your rebuilt packages are also using llvm-3.5.

As I said, only the 3.4 versions of the llvm packages were installed, so
I'm certain that I did not use the 3.5 version.

That being the case, yes I did use the patch (well, I applied the same
trivial edits) since otherwise the Build-Deps would have insisted on 3.5

If you're pointing at the other bugs because you think they might
contain a fix for my problem, well the simplest fix for me is to avoid
gdm3.

I only posted to the bug because I saw no mention of the fact that one
can get things working by avoiding gdm3 in any of these bugs, which
seemed like it might be relevant.  The fact that llvm-3.4 didn't help me
is just an extra detail really.

If anyone would like me to run any extra tests, feel free to ask.

Cheers, Phil.
-- 
|)|  Philip Hands  [+44 (0)20 8530 9560]  HANDS.COM Ltd.
|-|  http://www.hands.com/    http://ftp.uk.debian.org/
|(|  Hugo-Klemm-Strasse 34,   21075 Hamburg,    GERMANY

---

From: Julien Cristau <[email-masked]>
Date: Mon, 16 Mar 2015 11:13:15 +0100

> If they could help with the "underrun" error on real hardware, as in
Please stop mixing up unrelated bugs.  The intel driver doesn't use
llvm.

Cheers,
Julien

---

From: Simon McVittie <[email-masked]>
Date: Mon, 16 Mar 2015 10:26:21 +0000

> is just an extra detail really.

Anything that crashes GNOME Shell (via an assertion failure or any
other reason) has the same superficial symptom: the "fail whale"
(oops, something has gone wrong) from gnome-session.
As a result, #775235, #770130/#776911, and #780413 all have the same
superficial symptom, but I suspect their root causes differ (particularly
#775235 and the others), and they can only be distinguished easily
by log messages in syslog / the systemd Journal.

Reasons I think this is the same thing as #770130/#776911 and perhaps #780413:

* all involve approximately decade-old Intel graphics (Eric on #770130: 830M;
  Rafal on #776911: 852GM/855GM; Philip: 855GM; me on #780413: 865G)

* Eric, Rafal and Philip all report "*ERROR* pipe A underrun"
  whereas I get a different symptom for #780413 ("GPU HANG"),
  which is why I haven't merged #780413 with the others

> Hints about where gdm3 might be logging what happened would be useful.

You seem to be running systemd as pid 1, so the catch-all answer is
"in the journal" (available via either journalctl or the traditional
syslog interface).

Could you please look in the journal and see whether you are getting
an assertion failure something like this?

  May 17 01:20:15 debian gnome-session[952]: (gnome-shell:1092):
  Cogl-ERROR **: Failed to create texture 2d due to size/format
  constraints

(systemd blames it on gnome-session because it comes out of gnome-session's
stderr, which is inherited by gnome-shell - but the message is really
from gnome-shell)

My prediction is that you will. You'd typically see several iterations
of that, before gnome-session gives up hope of successfully starting
gnome-shell and displays the fail-whale instead.

> installing lightdm and running from there solves the problem

That's interesting. I could only reproduce something similar on #780413
by starting the "real login" version of GNOME Shell; I only tried going
via gdm, but gdm's login screen *is* (a special configuration of)
GNOME Shell (in particular, it is the same from a graphics/compositing/3D
point of view AIUI); so if GNOME Shell is going to crash like this, it's
rather surprising that gdm's login screen does not already do the same before
we could even log in.

I'll try with startx or lightdm on my 865M hardware at some point.
It's possible that the way to reproduce this bug is something like "run
an accelerated compositing environment (GNOME Shell) on one VT, and then
try to run *another* accelerated compositing environment on another VT"?
If that was the case, then something like gdm -> xfce would work because
gdm's Shell was the first composited environment running and xfce isn't
composited; and lightdm -> GNOME Shell would also work because GNOME Shell
was the first composited environment running; but gdm -> GNOME Shell
would not.

Suggesting lightdm provides a workaround for this older hardware,
if nothing else.

> contain a fix for my problem, well the simplest fix for me is to avoid

We're pointing at the unsolved bugs because they sound more like what you're
experiencing than the solved #775235 does, and we hope that your additional
information might give someone enough clues to solve them.

>From a purely practical point of view, if your hardware is this old,
you might well be better off with lightdm or another non-compositing *DM
instead of gdm, and/or GNOME Flashback or a non-GNOME environment instead
of GNOME Shell. On the i865M where I could reproduce #780413,
I was previously using wheezy's GNOME fallback environment (for
which GNOME Flashback is the closest equivalent in jessie), until I
retired it in favour of a second-hand Thinkpad running wheezy's
GNOME Shell.

Perhaps the jessie release notes should recommend GNOME Flashback
as the upgrade path for GNOME on hardware older than some arbitrary cutoff?
Anything with x86-64, and even the more recent 32-bit chipsets (e.g. whatever
is in the Thinkpad X60s), should be fine for GNOME; but older than that is,
realistically, not going to be tested by most developers any more.

    S

---

From: Philip Hands <[email-masked]>
Date: Tue, 17 Mar 2015 01:13:39 +0000

Hi Simon,

Thanks for the detailed response.

Simon McVittie <[email-masked]> writes:

...
> "in the journal" (available via either journalctl or the traditional

Yes -- I thought I'd looked there, but it turns out there was enough
other stuff splurged into the journal that I'd missed the needle in that
haystack.

>   Cogl-ERROR **: Failed to create texture 2d due to size/format

Exactly that -- occuring twice.

> gnome-shell and displays the fail-whale instead.

I see two of those errors, then it bails out with an Unrecoverable error.

...
> of GNOME Shell.

Definitely -- I was aproaching this as a test of what happens if one
just goes with the defaults.  I wasn't really expecting it to be a good
idea, but its a bit of a shame when it fails so completely that one
cannot even get to a browser (so a newbie with just one computer would
then be forced to give up Debian right there).

> On the i865M where I could reproduce #780413,

Having just tried Flashback, I think I'd have to recommend XFCE (or LXDE)
on that hardware.

> realistically, not going to be tested by most developers any more.

... and also will be depressingly slow when compared to the more svelt
alternatives we have available.

BTW I just upgraded back to the standard mesa packages, and can confirm
that lightdm is able to launch Gnome on this machine with the normal
packages.

Cheers, Phil.