Subject: Bug#779778: xfce4-power-manager: Transition to libsystemd

From: [email-masked]
Date: Wed, 04 Mar 2015 18:31:02 +0100

Source: xfce4-power-manager
Version: 1.4.1-2
Severity: normal
User: [email-masked]
Usertags: libsystemd

Hi!

In systemd v209, released over a year ago, the various libsystemd-* libraries
(libsystemd-journal.so, libsystemd-login.so, libsystem-daemon.so,
libsystemd-id128.so) were merged into a single libsystemd.so library to reduce
code duplication and avoid cyclic dependencies [1].

Your package declares a build-dependency on either libsystemd-daemon-dev,
libsystemd-login-dev or libsystemd-journal-dev.

Please update your package so it can be built against libsystemd.

Updating the configure check / build system
===========================================
If your package use pkg-config and autotools, a typical configure check
looks like:

 PKG_CHECK_MODULES(FOO, libsystemd-login)
All you need to do, is change that to
 PKG_CHECK_MODULES(FOO, libsystemd)

If there are checks for libsystemd-journal, libsystemd-login and
libsystemd-journal, you can merge that into a single check:

 PKG_CHECK_MODULES(FOO, libsystemd-login)
 PKG_CHECK_MODULES(BAR, libsystemd-daemon)
 PKG_CHECK_MODULES(BAZ, libsystemd-journal)
=>
 PKG_CHECK_MODULES(FOO, libsystemd)

BAR_{CFLAGS,LIBS} and BAZ_{CFLAGS,LIBS} need to be updated accordingly.

If you/upstream wants to support building against older versions of systemd,
you can update the configure check as follows:

 PKG_CHECK_MODULES(FOO, libsystemd-login)
=>
 PKG_CHECK_MODULES(FOO, libsystemd,, [PKG_CHECK_MODULES(FOO, libsystemd-login)])

See [2] as an example how to do that.

Updating Build-Depends
======================
Please replace the Build-Depends on libsystemd-*-dev with libsystemd-dev [3].
I would recommend against adding alternative Build-Depends against the old
dev packages. This is not necessary, since libsystemd-dev is already provided
in jessie.

Backports
=========
Debian jessie already ships with libsystemd-dev, so this change is safe
regarding backports.

Upstream
========
Please consider forwarding this upstream. In some cases upstream might already
have a fix for that

Thanks for considering.

Michael,
on behalf of the pkg-systemd team.

[1] http://lists.freedesktop.org/archives/systemd-devel/2014-February/017146.html
[2] http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=8f6317f88a3ca3f42cf72137bb033b4a020b7b82
[3] http://anonscm.debian.org/cgit/pkg-utopia/network-manager.git/commit/?id=69b95405b07fc2a5833dfcbe18c9229706c2104e

---

From: [email-masked] (Debian Bug Tracking System)
Date: Wed, 04 Mar 2015 17:54:32 +0000

Thank you for filing a new Bug report with Debian.

This is an automatically generated reply to let you know your message
has been received.

Your message has been forwarded to the package maintainers (but not
other interested parties, as you requested) for their attention; they
will reply in due course.

Your message has been sent to the package maintainer(s):
 Debian Xfce Maintainers <[email-masked]>

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
779778: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=779778
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Yves-Alexis Perez <[email-masked]>
Date: Thu, 05 Mar 2015 18:38:49 +0100

> libsystemd-login-dev or libsystemd-journal-dev.

I have to admit I have no idea why xfpm build-deps on
libsystemd-daemon-dev, I can't find a trace in configure.ac.

Jackson, any idea? It seems to build just fine and not change any
dependencies in the binary package, so it just look like a spurious
build-dep.

Regards,
-- 
Yves-Alexis

---

From: [email-masked] (Debian Bug Tracking System)
Date: Thu, 05 Mar 2015 17:42:04 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 08 Mar 2015 21:54:18 +0000

This is an automatic notification regarding your Bug report
which was filed against the src:xfce4-power-manager package:

#779778: xfce4-power-manager: Transition to libsystemd

It has been closed by Yves-Alexis Perez <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Yves-Alexis Perez <[email-masked]> by
replying to this email.

Subject: Bug#779778: fixed in xfce4-power-manager 1.4.3-1
From: Yves-Alexis Perez <[email-masked]>
To: [email-masked]
Date: Sun, 08 Mar 2015 21:52:27 +0000

Source-Version: 1.4.3-1

We believe that the bug you reported is fixed in the latest version of
xfce4-power-manager, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Yves-Alexis Perez <[email-masked]> (supplier of updated xfce4-power-manager package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sun, 08 Mar 2015 21:57:47 +0100
Source: xfce4-power-manager
Binary: xfce4-power-manager xfce4-power-manager-data xfce4-power-manager-plugins
Architecture: source amd64 all
Version: 1.4.3-1
Distribution: experimental
Urgency: medium
Maintainer: Debian Xfce Maintainers <[email-masked]>
Changed-By: Yves-Alexis Perez <[email-masked]>
Description:
 xfce4-power-manager - power manager for Xfce desktop
 xfce4-power-manager-data - power manager for Xfce desktop, arch-indep files
 xfce4-power-manager-plugins - power manager plugins for Xfce panel
Closes: 762500 779778
Changes:
 xfce4-power-manager (1.4.3-1) experimental; urgency=medium
 .
   * New upstream release.
     - add symlinks for UPS icons.                               closes: #762500
   * debian/patches:
     - 0001-Use-translated-device-type-for-unknown-devices-bug-1 dropped,
       included upstream.
   * debian/control:
     - drop libsystemd-daemon-dev build-dep, obsolete.           closes: #779778
Checksums-Sha1:
 4c029353cc7f73ef2e6ba01eb897ea8a73aeacdd 2213 xfce4-power-manager_1.4.3-1.dsc
 7bf53c14c64aa9632db8dbc1f96d8de3f83f597d 1138831 xfce4-power-manager_1.4.3.orig.tar.bz2
 a1799c7f60d3fb18c437df161219681dd3eec98f 6660 xfce4-power-manager_1.4.3-1.debian.tar.xz
 fa9cfea839371331af9a62a84028487281a446f8 203392 xfce4-power-manager_1.4.3-1_amd64.deb
 85c9989c50c112a6f2db8b026e2017da8f9428db 575060 xfce4-power-manager-data_1.4.3-1_all.deb
 fbab2c7f7fe66067ce761fb9d59de7998a0c2194 148582 xfce4-power-manager-plugins_1.4.3-1_amd64.deb
Checksums-Sha256:
 19a181e55c9d561633a405a971afdb342aed6e118a3e3294fc2fb5eec7475fbf 2213 xfce4-power-manager_1.4.3-1.dsc
 018e11dd315745f582d70108b6071d37fb94854fde70961e17325bc19c4e2011 1138831 xfce4-power-manager_1.4.3.orig.tar.bz2
 c0b2b2005499ad465bd85736a42e6bc8a2acc2c5fb71cb1379ebf4c683a34dc8 6660 xfce4-power-manager_1.4.3-1.debian.tar.xz
 4fb3c9dd0dc0f6c6f28b20cf0d66f90d078cbe99a1a30b6008282aee6dc44b55 203392 xfce4-power-manager_1.4.3-1_amd64.deb
 c2f25b50471b8adbfb11402986e537b6e385a877724c1fb8c39985c58a3084ef 575060 xfce4-power-manager-data_1.4.3-1_all.deb
 6fcfc97c0eb960fb7e257e3d8bcad282def29ddcb5bad5f73cd412a8f941e53d 148582 xfce4-power-manager-plugins_1.4.3-1_amd64.deb
Files:
 195ce51528d28b5379b4664b323a02f8 2213 xfce optional xfce4-power-manager_1.4.3-1.dsc
 caa17bfd96c0879e7bcc7432896fad52 1138831 xfce optional xfce4-power-manager_1.4.3.orig.tar.bz2
 8232ffa89e337e329f6d30157fee8324 6660 xfce optional xfce4-power-manager_1.4.3-1.debian.tar.xz
 285e68cb889bd20402272d059f83211e 203392 xfce optional xfce4-power-manager_1.4.3-1_amd64.deb
 b616107cd407d9768054e586038b236e 575060 xfce optional xfce4-power-manager-data_1.4.3-1_all.deb
 edc4cbf822e3e2cc62782fe785b5999d 148582 xfce optional xfce4-power-manager-plugins_1.4.3-1_amd64.deb

Subject: xfce4-power-manager: Transition to libsystemd
From: [email-masked]
To: [email-masked]
Date: Wed, 04 Mar 2015 18:31:02 +0100

Hi!

Updating Build-Depends
======================

Backports
=========

Upstream
========

Thanks for considering.

Michael,