Subject: libpoppler: Some contents in some pdf documents seem to be ignored

From: Rogier <[email-masked]>
Date: Tue, 28 Apr 2015 12:38:56 +0200

Package: libpoppler46
Version: 0.26.5-1
Severity: important

Dear Maintainer,

Poppler fails to correctly process the contents of some pdf files. Part of
the contents seem to be simply ignored.

An example file is attached (decompressed pdf). Using pdftotext, a euro sign
and two blank lines are displayed, whereas the file contains much more text
than that, as can be verified using other pdf tools, or by viewing the file
in a text editor.

I tested version 0.28.1-1 as well (using pdftotext), and the behavior is
the same.

The attached file is rendered incorrectly by okular, evince, xpdf and
poppler-utils (pdftotext, pdftohtml).
It is correctly rendered when using gv (1:3.7.4-1), firefox (iceweasel
31.6.0esr-1, using the built-in PDF viewer) and mupdf (1.6-1).

(I tested these packages on an up-to-date debian stretch system (as of 28 april 2015))

Kind regards,

Rogier.

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (x86_64)

Kernel: Linux 3.16-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libpoppler46:i386 depends on:
ii  libc6              2.19-11
ii  libfontconfig1     2.11.0-6.1
ii  libfreetype6       2.5.2-2
ii  libgcc1            1:4.9.1-16
ii  libjpeg62          1:1.3.1-3
ii  liblcms2-2         2.6-3+b1
ii  libopenjpeg5       1:1.5.2-3
ii  libpng12-0         1.2.50-2
ii  libstdc++6         4.9.1-16
ii  libtiff5           4.0.3-10+b1
ii  multiarch-support  2.19-11

Versions of packages libpoppler46:i386 recommends:
ii  poppler-data  0.4.7-1

libpoppler46:i386 suggests no packages.

-- no debconf information

---

From: "Andreas Goesele" <[email-masked]>
Date: Tue, 09 Jan 2018 21:53:12 +0100

This bug is still present in libpoppler46:amd64 0.26.5-2+deb8u1 and
libpoppler46:amd64 0.26.5-2+deb8u2

---

From: Michael Weghorn <[email-masked]>
Date: Wed, 10 Jan 2018 11:33:19 +0100

Hi,

the bug is still reproducible in current Debian stable (libpoppler64
0.48.0-2+deb9u1).

However, I can no longer reproduce it in current Debian unstable
(libpoppler72 0.61.1-2), so it seems to have been fixed in the meanwhile.

Regards,
  Michael