Subject: Bug#796541: gnome-shell: "gnome-shell version" echoes "org.gnome.Shell already exists on bus and --replace not specified"

From: FarkR <[email-masked]>
Date: Sat, 22 Aug 2015 08:40:42 -0400

Package: gnome-shell
Version: 3.14.4-1~deb8u1
Severity: important

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
occured two days after installing Debian DVD-1. I did not try viewing the gnome-shell version beforehand, so I have no idea whether this has to do with my installation or not
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
"gnome-shell --replace" mostly works, but does not fix the bug and gives the following output: "Gjs-Message: JS LOG: Failed to launch ibus-daemon: Failed to execute child process "ibus-daemon" (No such file or directory)
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/[email-masked]/extension.js 9]: assignment to undeclared variable _activateOriginal

(gnome-shell:2157): Gjs-WARNING **: JS ERROR: Exception in callback for signal: startup-complete: Error: Requiring GSystem, version none: Typelib file for namespace 'GSystem' (any version) not found
_initializeUI/<@resource:///org/gnome/shell/ui/main.js:216
_emit@resource:///org/gnome/gjs/modules/signals.js:124
LayoutManager<._startupAnimationComplete@resource:///org/gnome/shell/ui/layout.js:704
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
_addHandler/params[name]@resource:///org/gnome/shell/ui/tweener.js:91
_callOnFunction@resource:///org/gnome/gjs/modules/tweener/tweener.js:203
_updateTweenByIndex@resource:///org/gnome/gjs/modules/tweener/tweener.js:333
_updateTweens@resource:///org/gnome/gjs/modules/tweener/tweener.js:345
_onEnterFrame@resource:///org/gnome/gjs/modules/tweener/tweener.js:360
_emit@resource:///org/gnome/gjs/modules/signals.js:124
ClutterFrameTicker<._onNewFrame@resource:///org/gnome/shell/ui/tweener.js:208
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
ClutterFrameTicker<._init/<@resource:///org/gnome/shell/ui/tweener.js:183"
   * What was the outcome of this action?
a large error message
   * What outcome did you expect instead?
a fixed gnome-shell

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: 8.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gnome-shell depends on:
ii  dconf-gsettings-backend [gsettings-back  0.22.0-1
ii  evolution-data-server                    3.12.9~git20141128.5242b0-2+deb8u2
ii  gir1.2-accountsservice-1.0               0.6.37-3+b1
ii  gir1.2-atspi-2.0                         2.14.0-1
ii  gir1.2-caribou-1.0                       0.4.15-1
ii  gir1.2-clutter-1.0                       1.20.0-1
ii  gir1.2-freedesktop                       1.42.0-2.2
ii  gir1.2-gcr-3                             3.14.0-2
ii  gir1.2-gdesktopenums-3.0                 3.14.1-1
ii  gir1.2-gdm3                              3.14.1-7
ii  gir1.2-gkbd-3.0                          3.6.0-1
ii  gir1.2-glib-2.0                          1.42.0-2.2
ii  gir1.2-gnomebluetooth-1.0                3.14.0-2
ii  gir1.2-gnomedesktop-3.0                  3.14.1-1
ii  gir1.2-gtk-3.0                           3.14.5-1
ii  gir1.2-ibus-1.0                          1.5.9-1
ii  gir1.2-mutter-3.0                        3.14.4-1~deb8u1
ii  gir1.2-networkmanager-1.0                0.9.10.0-7
ii  gir1.2-nmgtk-1.0                         0.9.10.0-2
ii  gir1.2-pango-1.0                         1.36.8-3
ii  gir1.2-polkit-1.0                        0.105-8
ii  gir1.2-soup-2.4                          2.48.0-1
ii  gir1.2-telepathyglib-0.12                0.24.1-1
ii  gir1.2-telepathylogger-0.2               0.8.1-1
ii  gir1.2-upowerglib-1.0                    0.99.1-3.2
ii  gjs                                      1.42.0-1
ii  gnome-backgrounds                        3.14.1-1
ii  gnome-icon-theme-symbolic                3.12.0-1
ii  gnome-settings-daemon                    3.14.2-3
ii  gnome-shell-common                       3.14.4-1~deb8u1
ii  gnome-themes-standard                    3.14.2.2-1
ii  gsettings-desktop-schemas                3.14.1-1
ii  libatk-bridge2.0-0                       2.14.0-2
ii  libatk1.0-0                              2.14.0-1
ii  libc6                                    2.19-18
ii  libcairo2                                1.14.0-2.1
ii  libcanberra-gtk3-0                       0.30-2.1
ii  libcanberra0                             0.30-2.1
ii  libclutter-1.0-0                         1.20.0-1
ii  libcogl-pango20                          1.18.2-3
ii  libcogl20                                1.18.2-3
ii  libcroco3                                0.6.8-3+b1
ii  libdbus-glib-1-2                         0.102-1
ii  libecal-1.2-16                           3.12.9~git20141128.5242b0-2+deb8u2
ii  libedataserver-1.2-18                    3.12.9~git20141128.5242b0-2+deb8u2
ii  libgcr-base-3-1                          3.14.0-2
ii  libgdk-pixbuf2.0-0                       2.31.1-2+deb8u2
ii  libgirepository-1.0-1                    1.42.0-2.2
ii  libgjs0e [libgjs0-libmozjs-24-0]         1.42.0-1
ii  libglib2.0-0                             2.42.1-1
ii  libgstreamer1.0-0                        1.4.4-2
ii  libgtk-3-0                               3.14.5-1
ii  libical1a                                1.0-1.3
ii  libjson-glib-1.0-0                       1.0.2-1
ii  libmozjs-24-0                            24.2.0-2
ii  libmutter0e                              3.14.4-1~deb8u1
ii  libnm-glib4                              0.9.10.0-7
ii  libnm-util2                              0.9.10.0-7
ii  libpango-1.0-0                           1.36.8-3
ii  libpangocairo-1.0-0                      1.36.8-3
ii  libpolkit-agent-1-0                      0.105-8
ii  libpolkit-gobject-1-0                    0.105-8
ii  libpulse-mainloop-glib0                  5.0-13
ii  libpulse0                                5.0-13
ii  libsecret-1-0                            0.18-1+b1
ii  libstartup-notification0                 0.12-4
ii  libsystemd0                              215-17+deb8u1
ii  libtelepathy-glib0                       0.24.1-1
ii  libx11-6                                 2:1.6.2-3
ii  libxfixes3                               1:5.0.1-2+b2
ii  mutter                                   3.14.4-1~deb8u1
ii  python                                   2.7.9-1
ii  telepathy-mission-control-5              1:5.16.3-1

Versions of packages gnome-shell recommends:
ii  gdm3                  3.14.1-7
ii  gkbd-capplet          3.6.0-1
ii  gnome-contacts        3.14.1-1
ii  gnome-control-center  1:3.14.2-3
ii  gnome-user-guide      3.14.1-1
ii  unzip                 6.0-16

gnome-shell suggests no packages.

-- no debconf information

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Mon, 21 Apr 2025 18:24:23 +0000

This is an automatic notification regarding your Bug report
which was filed against the gnome-shell package:

#796541: gnome-shell: "gnome-shell version" echoes "org.gnome.Shell already exists on bus and --replace not specified"

It has been closed by Jeremy Bícha <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Jeremy Bícha <[email-masked]> by
replying to this email.

-- 
796541: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=796541
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: closing old GNOME Shell bugs
From: Jeremy Bícha <[email-masked]>
To: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
Date: Mon, 21 Apr 2025 14:22:25 -0400

There have been many changes to Debian since this bug was originally
reported. If you are still experiencing this issue with Debian 12 (or
with Testing or Unstable), please report a new bug.

Thank you,
Jeremy Bícha

Subject: gnome-shell: "gnome-shell version" echoes "org.gnome.Shell already exists on bus and --replace not specified"
From: FarkR <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sat, 22 Aug 2015 08:40:42 -0400

Package: gnome-shell
Version: 3.14.4-1~deb8u1
Severity: important

Dear Maintainer,

-- System Information:
Debian Release: 8.1
  APT prefers stable