Subject: gwenview: some menu and print options vanished

From: Dominik George <[email-masked]>
Date: Wed, 16 Sep 2015 13:38:28 +0200

Package: gwenview
Version: 4:15.08.0-3
Severity: important

Recently, some important menu options (like Open with…) and almost every
option in the Print dialog vanished into thin air.

- -- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.1.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/lksh
Init: systemd (via /run/systemd/system)

Versions of packages gwenview depends on:
ii  libc6                   2.19-20
ii  libexiv2-14             0.25-2
ii  libgcc1                 1:5.2.1-17
ii  libjpeg62-turbo         1:1.4.1-2
ii  libkf5activities5       5.14.0-1
ii  libkf5baloo5            5.14.0-1
ii  libkf5completion5       5.14.0-1
ii  libkf5configcore5       5.14.0-1
ii  libkf5configgui5        5.14.0-1
ii  libkf5configwidgets5    5.14.0-1
ii  libkf5coreaddons5       5.14.0-1
ii  libkf5filemetadata3     5.14.0-1
ii  libkf5i18n5             5.14.0-1
ii  libkf5iconthemes5       5.14.0-1
ii  libkf5itemmodels5       5.14.0-1
ii  libkf5itemviews5        5.14.0-1
ii  libkf5jobwidgets5       5.14.0-1
ii  libkf5kdelibs4support5  5.14.0-1
ii  libkf5kiocore5          5.14.0-1
ii  libkf5kiofilewidgets5   5.14.0-1
ii  libkf5kiowidgets5       5.14.0-1
ii  libkf5notifications5    5.14.0-1
ii  libkf5parts5            5.14.0-1
ii  libkf5service5          5.14.0-1
ii  libkf5textwidgets5      5.14.0-1
ii  libkf5widgetsaddons5    5.14.0-1
ii  libkf5xmlgui5           5.14.0-1
ii  liblcms2-2              2.6-3+b3
ii  libphonon4qt5-4         4:4.8.3-2
ii  libpng12-0              1.2.50-2+b2
ii  libqt5core5a            5.4.2+dfsg-9
ii  libqt5gui5              5.4.2+dfsg-9
ii  libqt5opengl5           5.4.2+dfsg-9
ii  libqt5printsupport5     5.4.2+dfsg-9
ii  libqt5svg5              5.4.2-3
ii  libqt5widgets5          5.4.2+dfsg-9
ii  libqt5x11extras5        5.4.2-2+b1
ii  libstdc++6              5.2.1-17
ii  libx11-6                2:1.6.3-1
ii  phonon4qt5              4:4.8.3-2

Versions of packages gwenview recommends:
ii  kamera      4:4.14.2-1+b1
ii  kio-extras  4:15.08.0-1

gwenview suggests no packages.

- -- no debconf information

---

From: Juha Jäykkä <[email-masked]>
Date: Thu, 07 Jan 2016 23:17:59 +0000

Package: gwenview
Version: 4:15.08.3-1
Followup-For: Bug #799157

Just to confirm, this still exists on 4:15.08.3-1. Non-KDE printing works
fine.

Furthermore, it looks like simultaneously with vanishing printing options,
the landscape option stopped working, too: it works on jessie's version using
the same printer queue. The newer gwenview simply prints the long edge of the
parallel to the short edge of the paper, centers it on the paper (both edges)
and scales to maximum size (i.e. short edge size). I did ask gwenview to "fit
to page".

Cheers,
Juha

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.2.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=UTF-8) (ignored: LC_ALL set to en_GB.UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gwenview depends on:
ii  libc6                   2.21-4
ii  libexiv2-14             0.25-2.1
ii  libgcc1                 1:5.3.1-4
ii  libjpeg62-turbo         1:1.4.1-2
ii  libkf5activities5       5.16.0-1
ii  libkf5baloo5            5.16.0-1
ii  libkf5completion5       5.16.0-1
ii  libkf5configcore5       5.16.0-1
ii  libkf5configgui5        5.16.0-1
ii  libkf5configwidgets5    5.16.0-1
ii  libkf5coreaddons5       5.16.0-1
ii  libkf5filemetadata3     5.16.0-1
ii  libkf5i18n5             5.16.0-1
ii  libkf5iconthemes5       5.16.0-1
ii  libkf5itemmodels5       5.16.0-1
ii  libkf5itemviews5        5.16.0-1
ii  libkf5jobwidgets5       5.16.0-1
ii  libkf5kdelibs4support5  5.16.0-1
ii  libkf5kiocore5          5.16.0-1
ii  libkf5kiofilewidgets5   5.16.0-1
ii  libkf5kiowidgets5       5.16.0-1
ii  libkf5notifications5    5.16.0-1
ii  libkf5parts5            5.16.0-1
ii  libkf5service-bin       5.16.0-1
ii  libkf5service5          5.16.0-1
ii  libkf5textwidgets5      5.16.0-1
ii  libkf5widgetsaddons5    5.16.0-1
ii  libkf5xmlgui5           5.16.0-1
ii  liblcms2-2              2.6-3+b3
ii  libphonon4qt5-4         4:4.8.3-2
ii  libpng12-0              1.2.54-1
ii  libqt5core5a            5.5.1+dfsg-8
ii  libqt5gui5              5.5.1+dfsg-8
ii  libqt5opengl5           5.5.1+dfsg-8
ii  libqt5printsupport5     5.5.1+dfsg-8
ii  libqt5svg5              5.5.1-2
ii  libqt5widgets5          5.5.1+dfsg-8
ii  libqt5x11extras5        5.5.1-3
ii  libstdc++6              5.3.1-4
ii  libx11-6                2:1.6.3-1
ii  phonon4qt5              4:4.8.3-2

Versions of packages gwenview recommends:
ii  kamera                     4:4.14.2-1+b1
ii  kio-extras                 4:15.08.3-1
ii  qt5-image-formats-plugins  5.5.1-2

-- no debconf information