Subject: ncurses-term: screen terminfo is missing 'erase_chars' capstring

From: Paul LeoNerd Evans <[email-masked]>
Date: Wed, 30 Sep 2015 23:37:37 +0100

Package: ncurses-term
Version: 6.0+20150810-1
Severity: normal
Tags: upstream

The `screen` program has the ability to perform the 'erase_chars'
behaviour, using an ECMA-48-standard CSI X; for example:

  $ echo -e "ABCDEF\e[3G\e[2X"
  AB  EF

correctly erases the 2 chars in the middle when run via screen.

However, the `screen` terminfo file fails to include the `erase_chars`
capstring:

  $ infocmp -L1 screen | grep erase_chars
  <no output>

as compared other terms that do; for example:

  $ infocmp -L1 xterm | grep erase_chars
          erase_chars=\E[%p1%dX,

This capstring should be added to the screen terminfo. (and likewise
screen-bce, screen-256color, screen-256color-bce)

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

-- no debconf information

---

From: Thomas Dickey <[email-masked]>
Date: Wed, 30 Sep 2015 20:36:19 -0400

> correctly erases the 2 chars in the middle when run via screen.

maybe/maybe not: there are a few descriptions where ECH is not used
because the terminal's treatment of bce differs from that used in ncurses.

I can investigate it (again)...

-- 
Thomas E. Dickey <[email-masked]>
http://invisible-island.net
ftp://invisible-island.net

---

From: Thomas Dickey <[email-masked]>
Date: Sat, 10 Oct 2015 14:29:09 -0400

> because the terminal's treatment of bce differs from that used in ncurses.

In a quick check, vttest screen 11.6.5 shows the problem I mentioned.
	Test BCE-style clear line/display (ECH, Indexing)