Subject: Bug#801105: /usr/lib/i386-linux-gnu/dri/i915_dri.so: Most of accelerated applications crash

From: Ivan Krylov <[email-masked]>
Date: Tue, 06 Oct 2015 13:46:09 +0300

Package: libgl1-mesa-dri
Version: 10.3.2-1+deb8u1
Severity: important
File: /usr/lib/i386-linux-gnu/dri/i915_dri.so

Dear Maintainer,
Since the upgrade from Wheezy to Jessie most of OpenGL-accelerated
applications crash in i915_dri.so on my Asus 1011PX, for example,
glxgears, quakespasm, Carmageddon(CARMA95.EXE). Diablo II does not
crash, but does not render anything meaningful, either.

Attaching an example backtrace from glxgears.

--
Best regards,
Ivan

-- System Information:
Debian Release: 8.2
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 3.16.0-4-686-pae (SMP w/4 CPU cores)
Locale: LANG=ru_RU.utf8, LC_CTYPE=ru_RU.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libgl1-mesa-dri:i386 depends on:
ii  libc6              2.19-18+deb8u1
ii  libdrm-intel1      2.4.58-2
ii  libdrm-nouveau2    2.4.58-2
ii  libdrm-radeon1     2.4.58-2
ii  libdrm2            2.4.58-2
ii  libelf1            0.159-4.2
ii  libexpat1          2.1.0-6+deb8u1
ii  libgcc1            1:4.9.2-10
ii  libllvm3.5         1:3.5-10
ii  libstdc++6         4.9.2-10
ii  multiarch-support  2.19-18+deb8u1

Versions of packages libgl1-mesa-dri:i386 recommends:
pn  libtxc-dxtn-s2tc0 | libtxc-dxtn0  <none>

libgl1-mesa-dri:i386 suggests no packages.

-- no debconf information

---

From: Julien Cristau <[email-masked]>
Date: Tue, 6 Oct 2015 18:02:42 +0200

Control: tag -1 moreinfo

> Attaching an example backtrace from glxgears.
Please provide X and kernel logs.

Cheers,
Julien

---

From: Ivan Krylov <[email-masked]>
Date: Thu, 8 Oct 2015 02:06:46 +0300

В Tue, 6 Oct 2015 18:02:42 +0200

> Please provide X and kernel logs.

Sure, here they are. Though there is nothing of interest just after the
crash and initialization messages look very ordinary. Should I
have increased a verbosity level somewhere?

-- 
Best regards,
Ivan