Subject: reprepro: Please add an --ignore option for --export=never warnings

From: Frédéric Brière <[email-masked]>
Date: Fri, 08 Apr 2016 12:52:25 -0400

Package: reprepro
Version: 4.17.0-1
Severity: wishlist

Specifying --export=never will trigger a "no index file was exported"
warning, which can result in a slew of messages when performing a batch
of multiple operations (which is the typical case for --export=never).
An --ignore option to silence this warning would be nice.

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable-debug
  APT policy: (500, 'unstable-debug'), (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.4.0-1-amd64 (SMP w/3 CPU cores)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages reprepro depends on:
ii  libarchive13     3.1.2-11+b1
ii  libbz2-1.0       1.0.6-8
ii  libc6            2.22-5
ii  libdb5.3         5.3.28-11
ii  libgpg-error0    1.21-2
ii  libgpgme11       1.6.0-1
ii  liblzma5         5.1.1alpha+20120614-2.1
ii  pinentry-curses  0.9.7-5
ii  zlib1g           1:1.2.8.dfsg-2+b1

Versions of packages reprepro recommends:
ii  apt  1.2.10

Versions of packages reprepro suggests:
ii  gnupg-agent  2.1.11-6
pn  inoticoming  <none>
pn  lzip         <none>

-- no debconf information

---

From: "Bernhard R. Link" <[email-masked]>
Date: Thu, 22 Dec 2016 16:25:31 +0100

Control: tags -1 +pending

> An --ignore option to silence this warning would be nice.

When looking to implement it, I found it was already there (albeit not
documented).  There is a --export=silent-never which is like
--export=never but supresses most warnings. Will be documented in the
next version.

	Bernhard R. Link
-- 
F8AC 04D5 0B9B 064B 3383  C3DA AFFC 96D1 151D FFDC