Subject: Bug#82104: menu: can produce submenus with only 1 item

From: Yann Dirson <[email-masked]>
Date: Sat, 13 Jan 2001 17:18:21 +0100

Package: menu
Version: 2.1.5-6
Severity: normal

The layout optimisation algorithm accasionally produces submenus with
only 1 item, which is less optimal than not creating the submenu.

-- System Information
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux bylbo 2.2.18 #1 Wed Dec 20 23:25:48 CET 2000 i586

Versions of packages menu depends on:
ii  libc6                        2.2-11      GNU C Library: Shared libraries an
ii  libstdc++2.10                1:2.95.2-14 The GNU stdc++ library

---

From: joost witteveen <[email-masked]>
Date: Sun, 14 Jan 2001 01:41:49 +0100

> only 1 item, which is less optimal than not creating the submenu.

Does look like it, yes:)
Could you, when you see one of those 1-item submenus, 

cp /usr/share/doc/menu/examples/cat /etc/menu-methods/
update-menus
tar -cvzf - /tmp/menu-stdin /etc/menu-methods/*|uuencode m.tar.gz m.tar.gz|mail -s menu-1-item-submenu [email-masked]

(or something simmilar)

Thanks,
joostje

---

From: Yann Dirson <[email-masked]>
Date: Sun, 14 Jan 2001 10:55:50 +0100

> tar -cvzf - /tmp/menu-stdin /etc/menu-methods/*|uuencode m.tar.gz m.tar.gz|mail -s menu-1-item-submenu [email-masked]

:}  Wrong command-line, you put 2 parameters instead of 1 to uuencode.  Hope
it's OK.

The item to look at is /Apps/Net/Clients/Lftp

-- 
Yann Dirson    <[email-masked]> |    Why make M$-Bill richer & richer ?
debian-email:   <[email-masked]> |   Support Debian GNU/Linux:
                                    | Cheaper, more Powerful, more Stable !
http://ydirson.free.fr/             | Check <http://www.debian.org/>

---

From: Morten Brix Pedersen <[email-masked]>
Date: Sun, 9 Mar 2003 13:30:06 +0100

> The item to look at is /Apps/Net/Clients/Lftp

I know this bug report is a bit old, but are you able to reproduce this
still? I would be very much interested in the menu output.

I know you already sent it to joost, but it doesn't really help much
when it's only in his mailbox.

By the way, these days you can use 'update-menus --stdout > file' to
retrieve the menu output.

  - Morten.

-- 
http://mbrix.dk/

---

From: Yann Dirson <[email-masked]>
Date: Sun, 9 Mar 2003 14:31:41 +0100

On Sun, Mar 09, 2003 at 01:30:06PM +0100, Morten Brix Pedersen wrote:
> still?

Yes

> I would be very much interested in the menu output.

Here it is.  You can see the problem today in Apps/CAD/  or Apps/Net/Monotoring/
or Apps/Net/HTML editor

-- 
Yann Dirson    <[email-masked]> |    Why make M$-Bill richer & richer ?
Debian-related: <[email-masked]> |   Support Debian GNU/Linux:
Pro:    <[email-masked]> |  Freedom, Power, Stability, Gratuity
     http://ydirson.free.fr/        | Check <http://www.debian.org/>

---

From: Bill Allombert <[email-masked]>
Date: Sun, 9 Mar 2003 20:37:16 +0100

> > I know this bug report is a bit old, but are you able to reproduce this

For the record I can also reproduce the problem easily.

(I personnally find ugly that menu remove standard section if they 
contains only one entry. This does not apply to to hints section
of course, and this is cnfigurable with the forcetree stuff.)

Cheers,
-- 
Bill. <[email-masked]>

---

From: Yann Dirson <[email-masked]>
Date: Sun, 9 Mar 2003 22:39:34 +0100

> of course, and this is cnfigurable with the forcetree stuff.)

It may be worth to provide an easy way to toggle on/off a set of forcetree
statements.  This could then be (un)commented on answer to a debconf question.