Subject: Re: task-lxde-desktop: LXDE desktop does not include a web browser

From: Holger Wansing <[email-masked]>
Date: Mon, 31 Dec 2018 16:28:38 +0100

Control: reassign -1 lxde

Jonathan Dowland <[email-masked]> wrote:
> If I were to try and
> summarize it as succinctly as possible, it would be
> 
>   "LXDE desktop include an icon to launch a graphical web browser,
>   but does not depend upon one."
> 
> And that's still the situation since the virtual package www-browser ≠ a
> graphical one, since it can be satisfied by w3m or links and others.

Therefore forwarding to LXDE people.

@lxde: if you want to get that solved by a change in the xlde task, let me 
know.

Regards
Holger

-- 
Holger Wansing <[email-masked]>
PGP-Finterprint: 496A C6E8 1442 4B34 8508  3529 59F1 87CA 156E B076

---

From: Andriy Grytsenko <[email-masked]>
Date: Mon, 22 Feb 2021 16:09:50 +0200

control: reassign -1 lxpanel 0.10.1-1

Thank you for reporting this and investigating on it. As much as I can
see the root issue is that an icon on a panel does not work without a
working x-www-browser alternative installed. That can be solved with
adding a line

TryExec: /usr/bin/x-www-browser

into lxde-x-www-browser.desktop file. Therefore reassigning this bug to
the lxpanel package to fix it.