Subject: tail --retry doesn't

From: Harald Dunkel <[email-masked]>
Date: Mon, 29 Aug 2016 09:55:13 +0200

Package: coreutils
Version: 8.23-4

I am running tail in a dedicated window for some days now:

% ps -ef | grep tai[l]
hdunkel   2928  2915  0 Aug15 pts/1    00:00:00 tail --retry --max-unchanged-stats=5 -f /var/log/messages

Problem: It's frozen. /var/log/messages is changing all the
time, but tail doesn't recognize.

lsof -p shows:

% lsof -p 2928
lsof: WARNING: can't stat() tracefs file system /sys/kernel/debug/tracing
      Output information may be incomplete.
COMMAND  PID    USER   FD   TYPE DEVICE SIZE/OFF      NODE NAME
tail    2928 hdunkel  cwd    DIR   0,40    20480 189573782 /home/hdunkel (nfs-data:/space/home)
tail    2928 hdunkel  rtd    DIR  259,0     4096         2 /
tail    2928 hdunkel  txt    REG  259,0    64232    657851 /usr/bin/tail
tail    2928 hdunkel  mem    REG  259,0  1738176   1724334 /lib/x86_64-linux-gnu/libc-2.19.so
tail    2928 hdunkel  mem    REG  259,0   140928   1724331 /lib/x86_64-linux-gnu/ld-2.19.so
tail    2928 hdunkel    0u   CHR  136,1      0t0         4 /dev/pts/1
tail    2928 hdunkel    1u   CHR  136,1      0t0         4 /dev/pts/1
tail    2928 hdunkel    2u   CHR  136,1      0t0         4 /dev/pts/1
tail    2928 hdunkel    3r   REG  259,0   100176    263640 /var/log/messages.1 (deleted)
tail    2928 hdunkel    4r  0000   0,11        0      8294 anon_inode

AFAICT this is not supposed to happen. According to the man
page "tail --retry --max-unchanged-stats=5" should reopen
/var/log/messages.

Regards
Harri

---

From: Pádraig Brady <[email-masked]>
Date: Mon, 29 Aug 2016 11:57:42 +0100

> page "tail --retry --max-unchanged-stats=5" should reopen

There were tail fixes in this area in v8.24.
Previously renames may have been missed when inotify was used