Subject: Bug#841053: wicd-cli -z -n X -c connects to default wired profile regardless of value of X

From: Gregor Zattler <[email-masked]>
Date: Mon, 17 Oct 2016 10:44:16 +0200

Package: wicd-cli
Version: 1.7.4+tb2-2
Severity: important

Dear Maintainer,

I configured wicd to use two wired network configurations.

The configuration "wired-default" is set as default and uses dhcp
whilste the other configuration uses statich values for IP
address, dns servers and the like.

With this settings I can switch these configurations via wicd-curses.

But I want to script my network usage.

wicd-cli -z -l

shows two networks with ids "0" and "1"

but regardless of the value of X

wicd-cli -z -n X -c

unconditionally connects to the default configuration.  It does
not even check if X is a valid id.  So

wicd-cli -z -n 5 -c

happily connects via the default settings (using dhcp in my
case).

I would expect to be able to switch wired network settings via
wicd-cli. 

This is my /etc/wicd/wired-settings.conf:

[wired-default]
default = 1
profilename = wired-default
lastused = False

[wired-m89-static]
default = 0
profilename = wired-m89-static
ip = 192.168.1.22
netmask = 255.255.255.0
broadcast = 192.168.1.255
gateway = 192.168.1.1
use_static_dns = True
use_global_dns = False
dns1 = 127.0.0.1
dns2 = 192.168.1.1
dns3 = 8.8.8.8
lastused = True

Thanks for your attention, Gregor

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.7.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages wicd-cli depends on:
pn  python:any   <none>
ii  wicd-daemon  1.7.4+tb2-2

Versions of packages wicd-cli recommends:
ii  sudo  1.8.17p1-2

wicd-cli suggests no packages.

Versions of packages wicd-curses depends on:
ii  python-urwid  1.3.1-2+b1
pn  python:any    <none>
ii  wicd-daemon   1.7.4+tb2-2

Versions of packages wicd-curses recommends:
ii  sudo  1.8.17p1-2

Versions of packages wicd-daemon depends on:
ii  adduser          3.115
ii  dbus             1.10.12-1
ii  debconf          1.5.59
ii  ethtool          1:4.6-1
ii  iproute2         4.6.0-4
ii  iputils-ping     3:20150815-2
ii  isc-dhcp-client  4.3.5~b1-1
ii  lsb-base         9.20160629
ii  net-tools        1.60+git20150829.73cef8a-2
ii  psmisc           22.21-2.1+b1
ii  python-dbus      1.2.4-1
ii  python-gobject   3.22.0-1
ii  python-wicd      1.7.4+tb2-2
pn  python:any       <none>
ii  wireless-tools   30~pre9-12
ii  wpasupplicant    2.5-2+v2.4-3+b1

Versions of packages wicd-daemon recommends:
ii  rfkill  0.5-1

Versions of packages wicd-daemon suggests:
ii  pm-utils  1.4.1-16

Versions of packages python-wicd depends on:
pn  python:any  <none>

-- debconf information:
* wicd/users:

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Sat, 22 Aug 2020 15:27:28 +0000

This is an automatic notification regarding your Bug report
which was filed against the wicd-cli package:

#841053: wicd-cli -z -n X -c connects to default wired profile regardless of value of X

It has been closed by Debian FTP Masters <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Debian FTP Masters <[email-masked]> by
replying to this email.

-- 
841053: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=841053
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Bug#968033: Removed package(s) from unstable
From: Debian FTP Masters <[email-masked]>
To: [email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],
Cc: [email-masked]
Date: Sat, 22 Aug 2020 15:20:20 +0000

Version: 1.7.4+tb2-6+rm

Dear submitter,

as the package wicd has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see https://bugs.debian.org/968033

The version of this package that was in Debian prior to this removal
can still be found using http://snapshot.debian.org/.

Please note that the changes have been done on the master archive and
will not propagate to any mirrors until the next dinstall run at the
earliest.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
[email-masked].

Debian distribution maintenance software
pp.
Sean Whitton (the ftpmaster behind the curtain)

Subject: wicd-cli -z -n X -c connects to default wired profile regardless of value of X
From: Gregor Zattler <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Mon, 17 Oct 2016 10:44:16 +0200

Package: wicd-cli
Version: 1.7.4+tb2-2
Severity: important

Dear Maintainer,

wicd-cli -z -l

wicd-cli -z -n X -c

wicd-cli -z -n 5 -c

[wired-default]
default = 1

[wired-m89-static]
default = 0

-- System Information:

-- debconf information:
* wicd/users: