Subject: Bug#856443: mousepad: Fonts settings not working

From: Khurram Mahmood <[email-masked]>
Date: Wed, 01 Mar 2017 10:06:56 +0500

Package: mousepad
Version: 0.4.0-4
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
Normal working

   * What exactly did you do (or not do) that was effective (or
     ineffective)?
Changing the fonts size and bold etc not working.

   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: 9.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages mousepad depends on:
ii  dconf-gsettings-backend [gsettings-backend]  0.26.0-2
ii  libc6                                        2.24-9
ii  libglib2.0-0                                 2.50.2-2
ii  libgtk2.0-0                                  2.24.31-2
ii  libgtksourceview2.0-0                        2.10.5-3
ii  libpango-1.0-0                               1.40.3-3

mousepad recommends no packages.

mousepad suggests no packages.

-- no debconf information

---

From: Yves-Alexis Perez <[email-masked]>
Date: Thu, 07 Jun 2018 11:43:59 +0200

control: tag -1 unreproducible moreinfo

> Changing the fonts size and bold etc not working.

It seems to work just fine for me. Could you elaborate a bit?

Regards,
- -- 
Yves-Alexis

---

From: Amy Wrigley <[email-masked]>
Date: Sat, 15 Jun 2019 09:21:48 +0100

On Thu, 07 Jun 2018 11:43:59 +0200 Yves-Alexis Perez wrote:
 > -----BEGIN PGP SIGNED MESSAGE-----
 > Hash: SHA256
 >

While I am not the user who originally reported this, I can confirm
that this bug is still present in the current testing/unstable version
of mousepad. I don't know what more I can say about the problem
other than that the 'Select Font...' settings have absolutely no effect
on the text that is displayed. It is always the defaults mousepad
started with no matter which settings I select.

If there is any further information I could provide to help I will
do what I can.

---

From: Yves-Alexis Perez <[email-masked]>
Date: Thu, 15 Aug 2019 17:04:21 +0200

> started with no matter which settings I select.

Is there anything displayed on the console or something? Is something peculiar
about your setup? Because here everything just works as it should so I'm a bit
lost at what happens for you.

Regards,
- -- 
Yves-Alexis

---

From: Yves-Alexis Perez <[email-masked]>
Date: Sun, 25 Aug 2019 18:33:09 +0200

> lost at what happens for you.

Actually, can you check if “use system monospace font” is checked in the
preferences, and if unchecking it fix the problem for you? It's likely a
duplicate of #794330

Regards,
- -- 
Yves-Alexis