Subject: Bug#858176: pulseaudio: module-combine is deprecated

From: Cristian Ionescu-Idbohrn <[email-masked]>
Date: Sun, 19 Mar 2017 13:37:03 +0100 (CET)

Package: pulseaudio
Version: 10.0-1
Severity: normal

I see these log messages:

/var/log/user.log:Mar 18 22:43:50 debian pulseaudio[5682]: [pulseaudio] module.c: module-combine is deprecated: Please use module-combine-sink instead of module-combine!
/var/log/user.log:Mar 18 22:43:50 debian pulseaudio[5682]: [pulseaudio] module-combine.c: We will now load module-combine-sink. Please make sure to remove module-combine from your configuration.

but I can't find any 'module-combine' reference in the configuration
files, neither under /etc/pulse nor ~/.pulse.  I see though both libs:

pulseaudio: /usr/lib/pulse-10.0/modules/module-combine-sink.so
pulseaudio: /usr/lib/pulse-10.0/modules/module-combine.so

are distributed.  My conclusion is that the deprecated module-combine
is loaded by default.  What can I do to avoid seeing those messages?

I do see some traces of the word 'combine' in the output from:

$ pactl info
Server String: /tmp/pulse-2L9K88eMlGn7/native
Library Protocol Version: 32
Server Protocol Version: 32
Is Local: yes
Client Index: 7
Tile Size: 65496
User Name: foo
Host Name: debian
Server Name: pulseaudio
Server Version: 10.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1b.0.analog-stereo
Default Source: combined.monitor
                ^^^^^^^^
Cookie: b907:c1f0

and:

$ pactl list
Module #13
	Name: module-combine
	Argument:
	Usage counter: n/a
	Properties:
		module.author = "Colin Guthrie"
		module.description = "Compatibility module (module-combine rename)"
		module.version = "10.0"

Module #14
	Name: module-combine-sink
	Argument:
	Usage counter: n/a
	Properties:
		module.author = "Lennart Poettering"
		module.description = "Combine multiple sinks to one"
		module.version = "10.0"

Sink #1
	State: SUSPENDED
	Name: combined
	Description: Simultaneous output to Built-in Audio Analog Stereo
	Driver: module-combine-sink.c
	Sample Specification: s16le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 14
	Mute: no
	Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
		balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: combined.monitor
	Latency: 0 usec, configured 0 usec
	Flags: DECIBEL_VOLUME LATENCY
	Properties:
		device.class = "filter"
		device.description = "Simultaneous output to Built-in Audio Analog Stereo"
		device.icon_name = "audio-card"
	Formats:
		pcm

Source #2
	State: SUSPENDED
	Name: combined.monitor
	Description: Monitor Source of Simultaneous output to Built-in Audio Analog Stereo
	Driver: module-combine-sink.c
	Sample Specification: s16le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 14
	Mute: no
	Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
		balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor of Sink: combined
	Latency: 0 usec, configured 0 usec
	Flags: DECIBEL_VOLUME LATENCY
	Properties:
		device.description = "Monitor Source of Simultaneous output to Built-in Audio Analog Stereo"
		device.class = "monitor"
		device.icon_name = "audio-input-microphone"
	Formats:
		pcm

-- Package-specific info:
File '/etc/default/pulseaudio' does not exist

-- System Information:
Debian Release: 9.0
  APT prefers testing
  APT policy: (500, 'testing'), (99, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 4.9.0-2-686-pae (SMP w/2 CPU cores)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages pulseaudio depends on:
ii  adduser                      3.115
ii  libasound2                   1.1.3-5
ii  libasound2-plugins           1:1.1.1-dmo1
ii  libc6                        2.24-9
ii  libcap2                      1:2.25-1
ii  libdbus-1-3                  1.10.16-1
ii  libgcc1                      1:6.3.0-6
ii  libice6                      2:1.0.9-2
ii  libltdl7                     2.4.6-2
ii  liborc-0.4-0                 1:0.4.26-2
ii  libpulse0                    10.0-1
ii  libsm6                       2:1.2.2-1+b3
ii  libsndfile1                  1.0.27-1+b1
ii  libsoxr0                     0.1.2-2
ii  libspeexdsp1                 1.2~rc1.2-1+b2
ii  libstdc++6                   6.3.0-6
ii  libsystemd0                  232-19
ii  libtdb1                      1.3.11-2
ii  libudev1                     232-19
ii  libwebrtc-audio-processing1  0.3-1
ii  libx11-6                     2:1.6.4-3
ii  libx11-xcb1                  2:1.6.4-3
ii  libxcb1                      1.12-1
ii  libxtst6                     2:1.2.3-1
ii  lsb-base                     9.20161125
ii  pulseaudio-utils             10.0-1

Versions of packages pulseaudio recommends:
ii  rtkit  0.11-4+b1

Versions of packages pulseaudio suggests:
ii  paman        0.9.4-1+b3
pn  paprefs      <none>
ii  pavucontrol  3.0-3+b3
ii  pavumeter    0.9.3-4+b3
ii  udev         232-19

-- no debconf information

Cheers,

--
Cristian

---

From: Felipe Sateler <[email-masked]>
Date: Sun, 19 Mar 2017 17:16:34 -0300

Control:tags -1 moreinfo

> is loaded by default.  What can I do to avoid seeing those messages?

Do you have module-gconf loaded? It might have been loaded by
configuraton set via paprefs.

-- 

Saludos,
Felipe Sateler

---

From: Cristian Ionescu-Idbohrn <[email-masked]>
Date: Sun, 19 Mar 2017 22:26:43 +0100 (CET)

> configuraton set via paprefs.

Yes, `pactl list' shows it:

Module #12
        Name: module-gconf
        Argument: 
        Usage counter: n/a
        Properties:
                module.author = "Lennart Poettering"
                module.description = "GConf Adapter"
                module.version = "10.0"

Cheers,

-- 
Cristian

---

From: Felipe Sateler <[email-masked]>
Date: Sun, 19 Mar 2017 20:37:18 -0300

On Sun, Mar 19, 2017 at 6:26 PM, Cristian Ionescu-Idbohrn <
[email-masked]> wrote:
>> > /var/log/user.log:Mar 18 22:43:50 debian pulseaudio[5682]:
[pulseaudio] module.c: module-combine is deprecated: Please use
module-combine-sink instead of module-combine!
>> > /var/log/user.log:Mar 18 22:43:50 debian pulseaudio[5682]:
[pulseaudio] module-combine.c: We will now load module-combine-sink. Please
make sure to remove module-combine from your configuration.
> module.description = "GConf Adapter"

Do you have set in paprefs "output to all devices"?

-- 

Saludos,
Felipe Sateler

---

From: Cristian Ionescu-Idbohrn <[email-masked]>
Date: Mon, 20 Mar 2017 19:49:59 +0100 (CET)

On Sun, 19 Mar 2017, Felipe Sateler wrote:
> On Sun, Mar 19, 2017 at 6:26 PM, Cristian Ionescu-Idbohrn < [email-masked]> wrote:

How would I go about to find that out?

This laptop (eeepc) has very limited resources.  The only (reliable)? 
way to play sound is over bluetooth.  The sound device is:

00:1b.0 Audio device: Intel Corporation System Controller Hub (SCH Poulsbo) HD Audio Controller (rev 07)
        Subsystem: ASUSTeK Computer Inc. System Controller Hub (SCH Poulsbo) HD Audio Controller
        Flags: bus master, fast devsel, latency 0, IRQ 23
        Memory at f3f38000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Root Complex Link
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel

plain jerky :(  I get sick of listening to mp3s on the local device.

Cheers,

-- 
Cristian

---

From: Felipe Sateler <[email-masked]>
Date: Mon, 20 Mar 2017 16:47:50 -0300

> How would I go about to find that out?

Open the paprefs program, and check if you have set the option to play
to all devices. Disable that, and the warning should go away.

-- 

Saludos,
Felipe Sateler

---

From: Cristian Ionescu-Idbohrn <[email-masked]>
Date: Wed, 22 Mar 2017 21:23:10 +0100 (CET)

On Mon, 20 Mar 2017, Felipe Sateler wrote:
> On Mon, Mar 20, 2017 at 3:49 PM, Cristian Ionescu-Idbohrn <[email-masked]> wrote:

Cheers.

I didn't have that package installed.  Done that now.  Have not 
verified that the messages vanish, yet.  Still:

1. this still does not explain _why_ both module-combine-sink and 
   module-combine are loaded, just to report module-combine is 
   deprecated afterwords

2. the paprefs package has these dependencies:

   The following additional packages will be installed:
     avahi-daemon libavahi-core7 libdaemon0 libgconfmm-2.6-1v5 libnss-mdns
     pulseaudio-module-zeroconf

   which may seem strange.  I don't want avahi on my system, as it 
   already performs poorly and I have no need for avahi; I intend to 
   remove the avahi packages again; will I be hit by the same 
   "deprecation" messages again?

Cheers,

-- 
Cristian