Subject: Please don't emit init.d-script-needs-depends-on-lsb-base if package ships native service file

From: Michael Biebl <[email-masked]>
Date: Sun, 18 Jun 2017 16:27:08 +0200

Package: lintian
Version: 2.5.50.4
Severity: normal

Hi,

lintian added a check which warns if a SysV init script uses the lsb
init-functions but doesn't have a dependency on lsb-base.

For a package which ships a native service file where the SysV init
script is only used to support booting with sysvinit, this dependency
seems unwanted, as "initscripts", which is a dependency of sysvinit-core
already ensures that lsb-base is installed.

As for init-less (build)-chroots, not having lsb-base installed isn't an
issue either, as those are supposed to install a policy-rc.d script
which disables the start of any services.

Michael

-- System Information:
Debian Release: 9.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (200, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.9.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8), LANGUAGE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages lintian depends on:
ii  binutils                          2.28-6
ii  bzip2                             1.0.6-8.1
ii  diffstat                          1.61-1+b1
ii  file                              1:5.30-1
ii  gettext                           0.19.8.1-2
ii  intltool-debian                   0.35.0+20060710.4
ii  libapt-pkg-perl                   0.1.32
ii  libarchive-zip-perl               1.59-1
ii  libclass-accessor-perl            0.34-1
ii  libclone-perl                     0.38-2+b1
ii  libdigest-sha-perl                5.96-1+b1
ii  libdpkg-perl                      1.18.24
ii  libemail-valid-perl               1.202-1
ii  libfile-basedir-perl              0.07-1
ii  libipc-run-perl                   0.94-1
ii  liblist-moreutils-perl            0.416-1+b1
ii  libparse-debianchangelog-perl     1.2.0-12
ii  libperl5.24 [libdigest-sha-perl]  5.24.1-3
ii  libtext-levenshtein-perl          0.13-1
ii  libtimedate-perl                  2.3000-2
ii  liburi-perl                       1.71-1
ii  libyaml-libyaml-perl              0.63-2
ii  man-db                            2.7.6.1-2
ii  patchutils                        0.3.4-2
ii  perl                              5.24.1-3
ii  t1utils                           1.39-2
ii  xz-utils                          5.2.2-1.2+b1

Versions of packages lintian recommends:
ii  dpkg                                 1.18.24
ii  libautodie-perl                      2.29-2
ii  libperlio-gzip-perl                  0.19-1+b2
ii  perl                                 5.24.1-3
ii  perl-modules-5.24 [libautodie-perl]  5.24.1-3

Versions of packages lintian suggests:
pn  binutils-multiarch     <none>
ii  dpkg-dev               1.18.24
ii  libhtml-parser-perl    3.72-3
ii  libtext-template-perl  1.46-1

-- no debconf information

---

From: Chris Lamb <[email-masked]>
Date: Tue, 19 Dec 2017 17:49:11 +0000

tags 864999 + pending
thanks

Fixed in Git:

  https://anonscm.debian.org/git/lintian/lintian.git/commit/?id=c32b9949d6226439fd73366ee9b03208dd39395c

Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      [email-masked] / chris-lamb.co.uk
       `-