Subject: Bug#874706: gwenview: Two actions with same shortcut

From: Francesco <[email-masked]>
Date: Sat, 09 Sep 2017 00:00:43 +0200

Package: gwenview
Version: 4:16.08.3-3
Severity: minor

Dear Maintainer,

  At start gwenview reports about same shortcut (shift + del) for two
  actions: delete and cut. Indeed they're default shortcuts.

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.12.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8), LANGUAGE= (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gwenview depends on:
ii  kinit                   5.37.0-2
ii  kio                     5.37.0-2
ii  libc6                   2.24-17
ii  libexiv2-14             0.25-3.1
ii  libgcc1                 1:7.2.0-3
ii  libjpeg62-turbo         1:1.5.2-2
ii  libkf5activities5       5.37.0-2
ii  libkf5baloo5            5.37.0-2
ii  libkf5completion5       5.37.0-2
ii  libkf5configcore5       5.37.0-2
ii  libkf5configgui5        5.37.0-2
ii  libkf5configwidgets5    5.37.0-2
ii  libkf5coreaddons5       5.37.0-2
ii  libkf5filemetadata3     5.37.0-2
ii  libkf5i18n5             5.37.0-2
ii  libkf5iconthemes5       5.37.0-2
ii  libkf5itemmodels5       5.37.0-2
ii  libkf5itemviews5        5.37.0-2
ii  libkf5jobwidgets5       5.37.0-2
ii  libkf5kdcraw5           16.04.0-2+b1
ii  libkf5kdelibs4support5  5.37.0-2
ii  libkf5kiocore5          5.37.0-2
ii  libkf5kiofilewidgets5   5.37.0-2
ii  libkf5kiowidgets5       5.37.0-2
ii  libkf5kipi31.0.0        4:16.08.2-1
ii  libkf5notifications5    5.37.0-2
ii  libkf5parts5            5.37.0-2
ii  libkf5service-bin       5.37.0-2
ii  libkf5service5          5.37.0-2
ii  libkf5textwidgets5      5.37.0-2
ii  libkf5widgetsaddons5    5.37.0-2
ii  libkf5xmlgui5           5.37.0-2
ii  liblcms2-2              2.8-4
ii  libphonon4qt5-4         4:4.9.0-4
ii  libpng16-16             1.6.32-1
ii  libqt5core5a            5.9.1+dfsg-9
ii  libqt5gui5              5.9.1+dfsg-9
ii  libqt5opengl5           5.9.1+dfsg-9
ii  libqt5printsupport5     5.9.1+dfsg-9
ii  libqt5svg5              5.9.1-2+b1
ii  libqt5widgets5          5.9.1+dfsg-9
ii  libqt5x11extras5        5.9.1-2+b1
ii  libstdc++6              7.2.0-3
ii  libx11-6                2:1.6.4-3
ii  phonon4qt5              4:4.9.0-4

Versions of packages gwenview recommends:
ii  kamera                     4:16.08.3-1
ii  kio-extras                 4:16.08.3-1
ii  qt5-image-formats-plugins  5.9.1-1

gwenview suggests no packages.

-- no debconf information

---

From: nurupo <[email-masked]>
Date: Fri, 22 Sep 2017 01:52:50 -0400

This is also happening for me. Whenever I start Gwenview, I get a message
box:

"There are two actions (Cut, Delete) that want to use the same shortcut
(Shift+Del). This is most probably a bug. Please report it in bugs.kde.org"

It's minor bug as clicking Ok in the message box takes you to Gwenview, but
it's annoying.

It looks like this was already reported and fixed upstream
https://bugs.kde.org/show_bug.cgi?id=347373

---

From: nurupo <[email-masked]>
Date: Sun, 10 Dec 2017 21:44:49 -0500

Looks like this bug got resolved. Had the same issue before, but it got
fixed in the latest (4:17.08.3-1) version of the package.