Subject: gnome-shell: gdm greeter session sometimes exits 1: Can't initialize KMS backend: could not find drm kms device

From: Simon McVittie <[email-masked]>
Date: Sat, 27 Jan 2018 18:29:12 +0000

Package: gnome-shell
Version: 3.26.2-3
Severity: normal
Tags: moreinfo
Control: submitter -1 [email-masked]

(This is split out from the logs sent to gjs bug #888052, since it
appears to be an unrelated issue.)

On Sat, 27 Jan 2018 at 16:02:19 +0100, Manuel Bilderbeek wrote:
> I do still see the issue at startup (I guess when the greeter is started):
>¯
> jan 27 10:13:47 sonata gnome-shell[1297]: Can't initialize KMS backend: could not find drm kms device
> jan 27 10:13:47 sonata gnome-session[1276]: gnome-session-binary[1276]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
> jan 27 10:13:47 sonata gnome-session-binary[1276]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
> jan 27 10:13:47 sonata gnome-session-binary[1276]: Unrecoverable failure in required component org.gnome.Shell.desktop

Am I right in thinking that immediately after this, gdm restarts the
greeter, and on this second attempt (or on a third or fourth attempt)
it works OK?

Does this have any practical effect on your use of gdm or GNOME, other
than delaying your first opportunity to log in?

Thanks,
    smcv

-- System Information:
See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=888052#5

---

From: Manuel Bilderbeek <[email-masked]>
Date: Sat, 27 Jan 2018 19:49:18 +0100

Hi,

> greeter, and on this second attempt (or on a third or fourth attempt)

I should take a better look, I'll let you know if it's different than this.

> than delaying your first opportunity to log in?

So: no.

But the 'sometimes' isn't valid for me: this seems to happen all the 
time for me. (I.e.: it happened at every boot I checked the log for in 
the last couple of days.)

-- 
Kind regards,
Manuel