Subject: cpufreq_stat is built into Debian kernel, powertop complains about failed modprobe

From: Marc Haber <[email-masked]>
Date: Sun, 11 Mar 2018 19:47:34 +0100

Package: powertop
Version: 2.8-1+b1
Severity: normal

Dear Maintainer,

I am filing this as Severity: normal since I do not know whether this
issue affects powertop functionality. Please feel free to downgrad the
severity if it's a purely cosmetic issue, which I suspect.

In Debian, CPU_FREQ_STAT is set to y in the kernel config, so the driver
is built into the kernel. Yet, powertop tries to unconditionally
modprobe cpufreq_stat and complains when this fails. At least, the
complaint needs to be silenced.

Greetings
Marc

-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.15.8-zgws1 (SMP w/4 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8), LANGUAGE=en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages powertop depends on:
ii  libc6             2.27-2
ii  libgcc1           1:8-20180308-1
ii  libncurses5       6.1-1
ii  libncursesw5      6.1-1
ii  libnl-3-200       3.2.27-2
ii  libnl-genl-3-200  3.2.27-2
ii  libpci3           1:3.5.2-1
ii  libstdc++6        8-20180308-1
ii  libtinfo5         6.1-1

powertop recommends no packages.

Versions of packages powertop suggests:
ii  cpufrequtils       008-1+b1
pn  laptop-mode-tools  <none>

-- no debconf information

---

From: "Kan-Ru Chen" <[email-masked]>
Date: Fri, 03 Jan 2020 23:12:06 +0900

Hi Marc,

On Sun, 11 Mar 2018 19:47:34  0100 Marc Haber <mh [email-masked]> wrote:
> Version: 2.8-1 b1

I believe the issue is purely cosmetic. I'm not sure if there is a way to detect reliably
the kernel has CPU_FREQ_STAT compiled in. On my system although I'm running
the Debian kernel, I don't have the `/sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state` file.

Kanru