Subject: uscan: ignore USCAN_SYMLINK=rename with --download-version

From: Mattia Rizzolo <[email-masked]>
Date: Sat, 13 Oct 2018 12:31:42 +0200

Package: devscripts
Version: 2.18.6
User: [email-masked]
Usertag: uscan

With USCAN_SYMLINK=rename in my ~/.devscripts, it downloads the version
I want it to download, but then doesn't rename it as expected.

mattia@warren ~/devel/debian/inkscape/inkscape (git)-[master] % uscan --report --download-version 0.92.2 -dd
uscan info: The directory to store downloaded files($destdir): ..
uscan info: uscan (version 2.18.6) See uscan(1) for help
uscan info: Scan watch files in .
uscan info: Check debian/watch and debian/changelog in ./.git/refs/tags
uscan info: Check debian/watch and debian/changelog in .
uscan info: package="inkscape" version="0.92.3-5" (as seen in debian/changelog)
uscan info: package="inkscape" version="0.92.3" (no epoch/revision)
uscan info: ./debian/changelog sets package="inkscape" version="0.92.3"
uscan info: Found upstream signing keyring: debian/upstream/signing-key.asc
uscan info: Process watch file at: debian/watch
    package = inkscape
    version = 0.92.3
    pkg_dir = .
uscan info: Set passive mode: 1
uscan info: opts: uversionmangle=s/(\d)[_\.\-\+]?((RC|rc|pre|dev|beta|alpha|b|a)[\-\.]?\d*)$/$1~$2/, dversionmangle=auto, pgpmode=auto
uscan info: line: https://launchpad.net/inkscape/+download (?:.*/)?inkscape[_\-\.]?(\d\S+)\.(?:tgz|txz|tar\.(?:bz2|gz|z2|xz)) debian
uscan info: Parsing uversionmangle=s/(\d)[_\.\-\+]?((RC|rc|pre|dev|beta|alpha|b|a)[\-\.]?\d*)$/$1~$2/
uscan info: Parsing  dversionmangle=auto
uscan info: Parsing  pgpmode=auto
uscan info: line: https://launchpad.net/inkscape/+download (?:.*/)?inkscape[_\-\.]?(\d\S+)\.(?:tgz|txz|tar\.(?:bz2|gz|z2|xz)) debian
uscan info: Last orig.tar.* tarball version (from debian/changelog): 0.92.3
uscan info: Download the --download-version specified version: 0.92.2
uscan info: Requesting URL:
   https://launchpad.net/inkscape/+download
uscan info: Matching pattern:
   (?:(?:https://launchpad.net)?\/inkscape\/\+download)?(?:.*/)?inkscape[_\-\.]?(\d\S+)\.(?:tgz|txz|tar\.(?:bz2|gz|z2|xz))
uscan info: Found the following matching hrefs on the web page (newest first):
   https://launchpad.net/inkscape/0.92.x/0.92.3/+download/inkscape-0.92.3.tar.bz2 (0.92.3) index=0.92.3-2
   https://launchpad.net/inkscape/0.92.x/0.92.2/+download/inkscape-0.92.2.tar.bz2 (0.92.2) index=0.92.2-2 matched with the download version
   https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.tar.bz2 (0.92.1) index=0.92.1-2
   https://launchpad.net/inkscape/0.92.x/0.92.1pre2/+download/inkscape-0.92.1pre2.tar.bz2 (0.92.1~pre2) index=0.92.1~pre2-2
   https://launchpad.net/inkscape/0.92.x/0.92.1pre1/+download/inkscape-0.92.1pre1.tar.bz2 (0.92.1~pre1) index=0.92.1~pre1-2
   https://launchpad.net/inkscape/0.92.x/0.92.1pre0/+download/inkscape-0.92.1pre0.tar.bz2 (0.92.1~pre0) index=0.92.1~pre0-2
   https://launchpad.net/inkscape/0.92.x/0.92/+download/inkscape-0.92.0.tar.bz2 (0.92.0) index=0.92.0-2
   https://launchpad.net/inkscape/0.92.x/0.92pre4/+download/inkscape-0.92pre4.tar.bz2 (0.92~pre4) index=0.92~pre4-2
   https://launchpad.net/inkscape/0.92.x/0.92pre3/+download/inkscape-0.92pre3.tar.bz2 (0.92~pre3) index=0.92~pre3-2
   https://launchpad.net/inkscape/0.91.x/0.91/+download/inkscape-0.91.tar.bz2 (0.91) index=0.91-2
   https://launchpad.net/inkscape/0.91.x/0.91/+download/inkscape-0.91.tar.gz (0.91) index=0.91-1
uscan info: Looking at $base = https://launchpad.net/inkscape/+download with
    $filepattern = (?:.*/)?inkscape[_\-\.]?(\d\S+)\.(?:tgz|txz|tar\.(?:bz2|gz|z2|xz)) found
    $newfile     = https://launchpad.net/inkscape/0.92.x/0.92.2/+download/inkscape-0.92.2.tar.bz2
    $newversion  = 0.92.2 which is newer than
    $lastversion = 0.92.3
uscan info: Matching target for downloadurlmangle: https://launchpad.net/inkscape/0.92.x/0.92.2/+download/inkscape-0.92.2.tar.bz2
uscan info: Upstream URL(+tag) to download is identified as    https://launchpad.net/inkscape/0.92.x/0.92.2/+download/inkscape-0.92.2.tar.bz2
uscan info: Filename (filenamemangled) for downloaded file: inkscape-0.92.2.tar.bz2
uscan: Newest version of inkscape on remote site is 0.92.2, specified download version is 0.92.2
uscan info: Downloading upstream package: inkscape-0.92.2.tar.bz2
uscan info: Requesting URL:
   https://launchpad.net/inkscape/0.92.x/0.92.2/+download/inkscape-0.92.2.tar.bz2
uscan info: Successfully downloaded package: inkscape-0.92.2.tar.bz2
uscan info: Start checking for common possible upstream OpenPGP signature files
uscan info: End checking for common possible upstream OpenPGP signature files
uscan info: Don't check OpenPGP signature
uscan info: New orig.tar.* tarball version (oversionmangled): 0.92.2
uscan info: SKIP generation of orig.tar.* and running of script/uupdate (--safe)
uscan info: Scan finished
mattia@warren ~/devel/debian/inkscape/inkscape (git)-[master] % ..
mattia@warren ~/devel/debian/inkscape % l
total 64524
drwx------  3 mattia mattia     4096 Feb 21  2017 gpghome
drwxr-xr-x 16 mattia mattia     4096 Oct 13 12:01 inkscape
-rw-r--r--  1 mattia mattia 31224100 Oct 13 12:25 inkscape-0.92.2.tar.bz2
-rw-r--r--  1 mattia mattia  3132993 Oct  8 15:36 inkscape_0.92.3-4_amd64.build
-rw-r--r--  1 mattia mattia    31560 Oct  8 15:32 inkscape_0.92.3-4.debian.tar.xz
-rw-r--r--  1 mattia mattia     2891 Oct  8 15:51 inkscape_0.92.3-4.dsc
-rw-r--r--  1 mattia mattia     2197 Oct  8 15:32 inkscape_0.92.3-4_source.changes
-rw-r--r--  1 mattia mattia    35160 Oct 13 11:50 inkscape_0.92.3-5.debian.tar.xz
-rw-r--r--  1 mattia mattia     2008 Oct 13 11:50 inkscape_0.92.3-5.dsc
-rw-r--r--  1 mattia mattia 31606442 Mar 23  2018 inkscape_0.92.3.orig.tar.bz2
-rw-r--r--  1 mattia mattia      181 Mar 23  2018 inkscape_0.92.3.orig.tar.bz2.asc
drwxr-xr-x  3 mattia mattia     4096 Mar 23  2018 upstream
mattia@warren ~/devel/debian/inkscape % cat inkscape/debian/watch
version=4

opts="\
uversionmangle=s/(\d)[_\.\-\+]?((RC|rc|pre|dev|beta|alpha|b|a)[\-\.]?\d*)$/$1~$2/, \
dversionmangle=auto, \
pgpmode=auto" \
https://launchpad.net/inkscape/+download \
(?:.*/)?inkscape[_\-\.]?(\d\S+)\.(?:tgz|txz|tar\.(?:bz2|gz|z2|xz)) debian

-- 
regards,
                        Mattia Rizzolo

GPG Key: 66AE 2B4A FCCF 3F52 DA18  4D18 4B04 3FCD B944 4540      .''`.
more about me:  https://mapreri.org                             : :'  :
Launchpad user: https://launchpad.net/~mapreri                  `. `'`
Debian QA page: https://qa.debian.org/developer.php?login=mattia  `-

---

From: Xavier <[email-masked]>
Date: Sun, 14 Oct 2018 09:46:02 +0200

Hello,

could you please retry with the following changes in your debian/watch
file ?

diff --git a/debian/watch b/debian/watch
index 0a2e820..f62563c 100644
--- a/debian/watch
+++ b/debian/watch
@@ -11,4 +11,4 @@ https://launchpad.net/inkscape/+download \
 # find the signature
 opts="pgpmode=previous" \
 https://launchpad.net/inkscape/+download \
-Y(?:.*/)?@PACKAGE@@ANY_VERSION@@ARCHIVE_EXT@?.(?:asc|pgp|gpg|sig) previous
+(?:.*/)?@PACKAGE@@ANY_VERSION@(?:@ARCHIVE_EXT@)?\.(?:asc|pgp|gpg|sig)
previous

Until now, @ARCHIVE_EXT@ isn't enclosed in (), so @ARCHIVE_EXT@?
produces  \.(?:tar...)? and not (?:\.(?:tar...)). That's why this change
is required.

Note also a "Y" at the beginning of line

---

From: Mattia Rizzolo <[email-masked]>
Date: Sun, 14 Oct 2018 10:52:26 +0200

Hi,

> Note also a "Y" at the beginning of line

Oh wow, I wonder I managed to add that Y…  and thanks for pointing out
that other error.

However I had the reported bugs before this last small rewrite, so with
version 0.92.3-4.

And even fixing those two issues you pointed out I can still see the
reported issues…

-- 
regards,
                        Mattia Rizzolo

---

From: Xavier <[email-masked]>
Date: Mon, 15 Oct 2018 18:45:30 +0200

Hello,

looking at uscan doc, --report (same as --same) disables mk-origtargz,
so no operation is done and you fall on actual behavior (no rename).
What changes do you want?

NB: there are still other bugs :-(, I'm trying to fix them

---

From: Mattia Rizzolo <[email-masked]>
Date: Mon, 15 Oct 2018 19:10:03 +0200

Control: tag -1 moreinfo

> What changes do you want?

Right, that's me being silly.  I used both --report and
--download-version, which don't really make sense (shouldn't --report
(and --safe) conflict with all the --*)ownload* options? - unrelated,
eh!)

I'm now in a slow network place, so I'll try again tomrrow...

-- 
regards,
                        Mattia Rizzolo

---

From: Xavier <[email-masked]>
Date: Mon, 15 Oct 2018 20:11:47 +0200

> I'm now in a slow network place, so I'll try again tomrrow...

An idea:
retitle -1 uscan: --safe should allow operations that doesn't need to repack
severity -1 wishlist

---

From: Mattia Rizzolo <[email-masked]>
Date: Mon, 15 Oct 2018 20:44:59 +0200

> retitle -1 uscan: --safe should allow operations that doesn't need to repack

not really: since --safe is an alias for --report, that's clearly
something that is meant to only report the status, not do anything,
imho.

-- 
regards,
                        Mattia Rizzolo

---

From: Mattia Rizzolo <[email-masked]>
Date: Tue, 16 Oct 2018 11:55:07 +0200

Control: tag -1 -moreinfo
Control: clone -1 -2
Control: retitle -2 uscan: disallow using --report together with --*download*

> I'm now in a slow network place, so I'll try again tomrrow...

Indeed, it works *nearly* as expected (check the bottom).
So, I'm also proposing to disallow --report with all the download
options, as they don't really make sense anyway.

mattia@warren ~/devel/debian/inkscape/inkscape (git)-[master] % uscan --download-version 0.92.1
uscan info: The directory to store downloaded files($destdir): ..
uscan info: uscan (version 2.18.6) See uscan(1) for help
uscan info: Scan watch files in .
uscan info: Check debian/watch and debian/changelog in ./.git/refs/tags
uscan info: Check debian/watch and debian/changelog in .
uscan info: package="inkscape" version="0.92.3-5" (as seen in debian/changelog)
uscan info: package="inkscape" version="0.92.3" (no epoch/revision)
uscan info: ./debian/changelog sets package="inkscape" version="0.92.3"
uscan info: Found upstream signing keyring: debian/upstream/signing-key.asc
uscan info: Process watch file at: debian/watch
    package = inkscape
    version = 0.92.3
    pkg_dir = .
uscan info: Set passive mode: 1
uscan info: opts: uversionmangle=s/(\d)[_\.\-\+]?((RC|rc|pre|dev|beta|alpha|b|a)[\-\.]?\d*)$/$1~$2/, dversionmangle=auto, pgpmode=next
uscan info: line: https://launchpad.net/inkscape/+download (?:.*/)?inkscape[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz) debian
uscan info: Parsing uversionmangle=s/(\d)[_\.\-\+]?((RC|rc|pre|dev|beta|alpha|b|a)[\-\.]?\d*)$/$1~$2/
uscan info: Parsing  dversionmangle=auto
uscan info: Parsing  pgpmode=next
uscan info: line: https://launchpad.net/inkscape/+download (?:.*/)?inkscape[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz) debian
uscan info: Last orig.tar.* tarball version (from debian/changelog): 0.92.3
uscan info: Download the --download-version specified version: 0.92.1
uscan info: Requesting URL:
   https://launchpad.net/inkscape/+download
uscan info: Matching pattern:
   (?:(?:https://launchpad.net)?\/inkscape\/\+download)?(?:.*/)?inkscape[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz)
uscan info: Found the following matching hrefs on the web page (newest first):
   https://launchpad.net/inkscape/0.92.x/0.92.3/+download/inkscape-0.92.3.tar.bz2 (0.92.3) index=0.92.3-2
   https://launchpad.net/inkscape/0.92.x/0.92.2/+download/inkscape-0.92.2.tar.bz2 (0.92.2) index=0.92.2-2
   https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.tar.bz2 (0.92.1) index=0.92.1-2 matched with the download version
   https://launchpad.net/inkscape/0.92.x/0.92.1pre2/+download/inkscape-0.92.1pre2.tar.bz2 (0.92.1~pre2) index=0.92.1~pre2-2
   https://launchpad.net/inkscape/0.92.x/0.92.1pre1/+download/inkscape-0.92.1pre1.tar.bz2 (0.92.1~pre1) index=0.92.1~pre1-2
   https://launchpad.net/inkscape/0.92.x/0.92.1pre0/+download/inkscape-0.92.1pre0.tar.bz2 (0.92.1~pre0) index=0.92.1~pre0-2
   https://launchpad.net/inkscape/0.92.x/0.92/+download/inkscape-0.92.0.tar.bz2 (0.92.0) index=0.92.0-2
   https://launchpad.net/inkscape/0.92.x/0.92pre4/+download/inkscape-0.92pre4.tar.bz2 (0.92~pre4) index=0.92~pre4-2
   https://launchpad.net/inkscape/0.92.x/0.92pre3/+download/inkscape-0.92pre3.tar.bz2 (0.92~pre3) index=0.92~pre3-2
   https://launchpad.net/inkscape/0.91.x/0.91/+download/inkscape-0.91.tar.bz2 (0.91) index=0.91-2
   https://launchpad.net/inkscape/0.91.x/0.91/+download/inkscape-0.91.tar.gz (0.91) index=0.91-1
   https://launchpad.net/inkscape/0.91.x/0.91/+download/inkscape-0.91.zip (0.91) index=0.91-0
uscan info: Looking at $base = https://launchpad.net/inkscape/+download with
    $filepattern = (?:.*/)?inkscape[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz) found
    $newfile     = https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.tar.bz2
    $newversion  = 0.92.1 which is newer than
    $lastversion = 0.92.3
uscan info: Matching target for downloadurlmangle: https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.tar.bz2
uscan info: Upstream URL(+tag) to download is identified as    https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.tar.bz2
uscan info: Filename (filenamemangled) for downloaded file: inkscape-0.92.1.tar.bz2
uscan: Newest version of inkscape on remote site is 0.92.1, specified download version is 0.92.1
uscan info: Downloading upstream package: inkscape-0.92.1.tar.bz2
uscan info: Requesting URL:
   https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.tar.bz2
uscan info: Successfully downloaded package: inkscape-0.92.1.tar.bz2
uscan info: Defer checking OpenPGP signature to the next watch line
uscan info: previous_newfile_base = inkscape-0.92.1.tar.bz2
uscan info: previous_sigfile_base = inkscape-0.92.1.tar.bz2
uscan info: previous_newversion = 0.92.1
uscan info: previous_download_available = 1
uscan info: New orig.tar.* tarball version (oversionmangled): 0.92.1
uscan info: Read the next watch line (pgpmode=next)
uscan info: opts: pgpmode=previous
uscan info: line: https://launchpad.net/inkscape/+download (?:.*/)?inkscape[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?:(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz))?.(?:asc|pgp|gpg|sig) previous
uscan info: Parsing pgpmode=previous
uscan info: line: https://launchpad.net/inkscape/+download (?:.*/)?inkscape[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?:(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz))?.(?:asc|pgp|gpg|sig) previous
uscan info: Previous version downloaded: 0.92.1
uscan info: Download the --download-version specified version: 0.92.1
uscan info: Requesting URL:
   https://launchpad.net/inkscape/+download
uscan info: Matching pattern:
   (?:(?:https://launchpad.net)?\/inkscape\/\+download)?(?:.*/)?inkscape[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?:(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz))?.(?:asc|pgp|gpg|sig)
uscan info: Found the following matching hrefs on the web page (newest first):
   https://launchpad.net/inkscape/0.92.x/0.92.3/+download/inkscape-0.92.3.sig (0.92.3) index=0.92.3-0
   https://launchpad.net/inkscape/0.92.x/0.92.2/+download/inkscape-0.92.2.sig (0.92.2) index=0.92.2-0
   https://launchpad.net/inkscape/0.92.x/0.92.1pre2/+download/inkscape-0.92.1pre2.sig (0.92.1pre2) index=0.92.1pre2-0
   https://launchpad.net/inkscape/0.92.x/0.92.1pre1/+download/inkscape-0.92.1pre1.sig (0.92.1pre1) index=0.92.1pre1-0
   https://launchpad.net/inkscape/0.92.x/0.92.1pre0/+download/inkscape-0.92.1pre0.sig (0.92.1pre0) index=0.92.1pre0-0
   https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.sig (0.92.1) index=0.92.1-0 matched with the download version
   https://launchpad.net/inkscape/0.92.x/0.92/+download/inkscape-0.92.0.sig (0.92.0) index=0.92.0-0
   https://launchpad.net/inkscape/0.92.x/0.92pre4/+download/inkscape-0.92pre4.sig (0.92pre4) index=0.92pre4-0
   https://launchpad.net/inkscape/0.92.x/0.92pre3/+download/inkscape-0.92pre3.tar.bz2.sig (0.92pre3.tar.bz2) index=0.92pre3.tar.bz2-2
   https://launchpad.net/inkscape/0.91.x/0.91/+download/inkscape-0.91.zip.sig (0.91.zip) index=0.91.zip-0
   https://launchpad.net/inkscape/0.91.x/0.91/+download/inkscape-0.91.tar.gz.sig (0.91.tar.gz) index=0.91.tar.gz-1
   https://launchpad.net/inkscape/0.91.x/0.91/+download/inkscape-0.91.tar.bz2.sig (0.91.tar.bz2) index=0.91.tar.bz2-2
uscan info: Looking at $base = https://launchpad.net/inkscape/+download with
    $filepattern = (?:.*/)?inkscape[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?:(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz))?.(?:asc|pgp|gpg|sig) found
    $newfile     = https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.sig
    $newversion  = 0.92.1 which is newer than
    $lastversion = 0.92.1
uscan info: Matching target for downloadurlmangle: https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.sig
uscan info: Upstream URL(+tag) to download is identified as    https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.sig
uscan info: Filename (filenamemangled) for downloaded file: inkscape-0.92.1.sig
uscan: Newest version of inkscape on remote site is 0.92.1, specified download version is 0.92.1
uscan info: Downloading OpenPGP signature from
   https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.sig (pgpmode=previous)
   as inkscape-0.92.1.sig
uscan info: Requesting URL:
   https://launchpad.net/inkscape/0.92.x/0.92.1/+download/inkscape-0.92.1.sig
uscan info: Use inkscape-0.92.1.tar.bz2 as upstream package (pgpmode=previous)
uscan info: Verifying OpenPGP signature ../inkscape-0.92.1.sig for ../inkscape-0.92.1.tar.bz2
uscan info: Execute: gpgv --homedir /dev/null --keyring /tmp/7Jn5LOyhAB/trustedkeys.gpg ../inkscape-0.92.1.sig ../inkscape-0.92.1.tar.bz2...
gpgv: Signature made Tue 14 Feb 2017 12:55:30 AM CET
gpgv:                using DSA key 11A30156E0E67611
gpgv: Good signature from "Bryce Harrington <[email-masked]>"
gpgv:                 aka "Bryce Harrington <[email-masked]>"
gpgv:                 aka "Bryce Harrington <[email-masked]>"
gpgv:                 aka "Bryce Harrington <[email-masked]>"
gpgv:                 aka "Bryce Harrington <[email-masked]>"
gpgv:                 aka "Bryce Harrington <[email-masked]>"
uscan info: Executing internal command:
   mk-origtargz --package inkscape --version 0.92.1 --rename --signature 1 --signature-file ../inkscape-0.92.1.sig --compression gzip --directory .. --copyright-file debian/copyright ../inkscape-0.92.1.tar.bz2
uscan info: New orig.tar.* tarball version (after mk-origtargz): 0.92.1
uscan info: Successfully renamed ../inkscape-0.92.1.tar.bz2 to ../inkscape_0.92.1.orig.tar.bz2.
uscan info: Scan finished
uscan --download-version 0.92.1  8.02s user 0.89s system 20% cpu 43.325 total
mattia@warren ~/devel/debian/inkscape/inkscape (git)-[master] % l ..
total 67596
drwxr-xr-x  2 mattia mattia     4096 Oct 14 15:29 1
drwx------  3 mattia mattia     4096 Feb 21  2017 gpghome
drwxr-xr-x 16 mattia mattia     4096 Oct 13 12:48 inkscape
-rw-r--r--  1 mattia mattia 31222684 Oct 16 11:46 inkscape_0.92.1.orig.tar.bz2
-rw-r--r--  1 mattia mattia      359 Oct 16 11:46 inkscape_0.92.1.orig.tar.bz2.asc
-rw-r--r--  1 mattia mattia      181 Oct 16 11:46 inkscape-0.92.1.sig

↑↑ note the signature: that one appear to have been mangled (I suspect
it thought that the signature was not armored, so it imported and then
re-exported it, which is fine), but the old file still lies around.

-- 
regards,
                        Mattia Rizzolo

---

From: Xavier <[email-masked]>
Date: Tue, 16 Oct 2018 14:48:33 +0200

> options, as they don't really make sense anyway.

If user choose --safe, it makes me feel uncomfortable to launch repack.
Today "--safe -d" downloads package and don't launch mk-origtargz.
That's why I proposed to launch mk-origtargz with also a --safe mode to
avoid unsafe operations but allow rename/copy/symlink (will fail if
repack is needed).